Bug 1106796 - Bluetooth stops working after trying to switch headset to HSP/HFP mode
Bluetooth stops working after trying to switch headset to HSP/HFP mode
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Kernel
Leap 15.0
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Al Cho
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-31 17:45 UTC by Iakov Karpov
Modified: 2018-09-10 11:55 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
lsusb -s 001:005 -v (8.90 KB, text/plain)
2018-08-31 17:45 UTC, Iakov Karpov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Iakov Karpov 2018-08-31 17:45:33 UTC
Created attachment 781589 [details]
lsusb -s 001:005 -v

When I try to switch my bluetooth headset to HSP/HFP mode via KDE GUI, bluetooth stops working completely, the only option is to reboot computer. rfkill and hardware switches don't save the situation

kernel messages:

Aug 31 20:24:30 n-day1.day kernel: ACPI Warning: \_SB.PCI0.PEG0.GFX0._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170303/nsarguments-95)
Aug 31 20:24:54 n-day1.day kernel: NET: Registered protocol family 38
Aug 31 20:24:56 n-day1.day kernel: input: E3:28:E9:22:11:64 as /devices/virtual/input/input21
Aug 31 20:25:16 n-day1.day kernel: Bluetooth: hci0 command 0x0428 tx timeout
Aug 31 20:25:32 n-day1.day kernel: Bluetooth: hci0 command 0x0804 tx timeout
Aug 31 20:25:35 n-day1.day kernel: Bluetooth: hci0 command 0x041f tx timeout
Aug 31 20:25:37 n-day1.day kernel: Bluetooth: hci0 command 0x0406 tx timeout
Aug 31 20:27:00 n-day1.day kernel: VBoxPciLinuxLinuxUnload
Aug 31 20:27:05 n-day1.day kernel: wlan0: deauthenticating from 28:10:7b:f1:bb:20 by local choice (Reason: 3=DEAUTH_LEAVING)
Aug 31 20:27:07 n-day1.day kernel: Ebtables v2.0 unregistered
Aug 31 20:27:08 n-day1.day systemd-shutdown[1]: Sending SIGTERM to remaining processes...
Comment 1 Takashi Iwai 2018-09-03 14:21:20 UTC
What about unloading and reloading the driver module?
Comment 2 Al Cho 2018-09-04 04:45:49 UTC
May we have more logs for that? (eg. fully journalctl and dmesg
Comment 3 Iakov Karpov 2018-09-05 05:28:36 UTC
Well, I think bug should be closed for now. I did hit it with no problem last Friday, but for some reason I can't reproduce it anymore.

You see, I was experimenting with bumblebee/nvidia driver a lot over the weekend to workaround nasty nouveau problems, tried different kernel versions, etc. And after that I don't have any problems with bluetooth headset, even with stock kernel and firmware. I don't really know why, maybe it's because I broke something horribly, maybe it's because something was fixed by purging and reinstalling multiple system packages :)
Comment 4 Takashi Iwai 2018-09-10 11:55:48 UTC
OK, let's close now.  Feel free to reopen if the issue is reproduced reliably.  Thanks.