Bug 1107116 - (CVE-2018-16429) VUL-1: CVE-2018-16429: glib,glib2: out-of-bounds read vulnerability ing_markup_parse_context_parse() in gmarkup.c, related to utf8_str()
(CVE-2018-16429)
VUL-1: CVE-2018-16429: glib,glib2: out-of-bounds read vulnerability ing_marku...
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/213704/
CVSSv3:SUSE:CVE-2018-16429:4.0:(AV:L/...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-09-04 14:12 UTC by Karol Babioch
Modified: 2020-06-17 14:23 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karol Babioch 2018-09-04 14:12:32 UTC
CVE-2018-16429

GNOME GLib 2.56.1 has an out-of-bounds read vulnerability in
g_markup_parse_context_parse() in gmarkup.c, related to utf8_str().

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-16429
https://gitlab.gnome.org/GNOME/glib/issues/1361
https://gitlab.gnome.org/GNOME/glib/commit/cec71705406f0b2790422f0c1aa0ff3b4b464b1b
Comment 1 Karol Babioch 2018-09-04 14:22:49 UTC
glib seems to be unaffected.

All supported codestreams of glib2 are affected, though:

SUSE:SLE-10-SP3:Update
SUSE:SLE-11-SP1:Update
SUSE:SLE-12:Update
SUSE:SLE-12-SP2:Update
SUSE:SLE-15:Update
Comment 6 Swamp Workflow Management 2018-11-26 20:13:42 UTC
SUSE-SU-2018:3913-1: An update that solves two vulnerabilities and has one errata is now available.

Category: security (moderate)
Bug References: 1107116,1107121,1111499
CVE References: CVE-2018-16428,CVE-2018-16429
Sources used:
SUSE Linux Enterprise Module for Packagehub Subpackages 15 (src):    glib2-2.54.3-4.7.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (src):    glib2-2.54.3-4.7.1
SUSE Linux Enterprise Module for Basesystem 15 (src):    glib2-2.54.3-4.7.1
Comment 7 Swamp Workflow Management 2018-12-03 20:11:23 UTC
SUSE-SU-2018:3966-1: An update that solves one vulnerability and has one errata is now available.

Category: security (moderate)
Bug References: 1107116,1111499
CVE References: CVE-2018-16429
Sources used:
SUSE Studio Onsite 1.3 (src):    glib2-2.22.5-0.8.36.1
SUSE Linux Enterprise Software Development Kit 11-SP4 (src):    glib2-2.22.5-0.8.36.1
SUSE Linux Enterprise Server 11-SP4 (src):    glib2-2.22.5-0.8.36.1
SUSE Linux Enterprise Debuginfo 11-SP4 (src):    glib2-2.22.5-0.8.36.1
Comment 8 Swamp Workflow Management 2018-12-07 11:25:14 UTC
openSUSE-SU-2018:4005-1: An update that solves two vulnerabilities and has one errata is now available.

Category: security (moderate)
Bug References: 1107116,1107121,1111499
CVE References: CVE-2018-16428,CVE-2018-16429
Sources used:
openSUSE Leap 15.0 (src):    glib2-2.54.3-lp150.3.3.1
Comment 10 Swamp Workflow Management 2019-06-21 13:50:28 UTC
SUSE-SU-2019:1596-1: An update that solves three vulnerabilities and has one errata is now available.

Category: security (important)
Bug References: 1107116,1107121,1111499,1137001
CVE References: CVE-2018-16428,CVE-2018-16429,CVE-2019-12450
Sources used:
SUSE Linux Enterprise Server 12-SP1-LTSS (src):    glib2-2.38.2-7.9.2
SUSE Linux Enterprise Server 12-LTSS (src):    glib2-2.38.2-7.9.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 11 Swamp Workflow Management 2019-07-02 13:14:45 UTC
SUSE-SU-2019:1722-1: An update that solves three vulnerabilities and has one errata is now available.

Category: security (important)
Bug References: 1061599,1107116,1107121,1137001
CVE References: CVE-2018-16428,CVE-2018-16429,CVE-2019-12450
Sources used:
SUSE OpenStack Cloud 7 (src):    glib2-2.48.2-12.12.2
SUSE Linux Enterprise Workstation Extension 12-SP5 (src):    glib2-2.48.2-12.12.2
SUSE Linux Enterprise Workstation Extension 12-SP4 (src):    glib2-2.48.2-12.12.2
SUSE Linux Enterprise Workstation Extension 12-SP3 (src):    glib2-2.48.2-12.12.2
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    glib2-2.48.2-12.12.2
SUSE Linux Enterprise Software Development Kit 12-SP4 (src):    glib2-2.48.2-12.12.2
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    glib2-2.48.2-12.12.2
SUSE Linux Enterprise Server for SAP 12-SP2 (src):    glib2-2.48.2-12.12.2
SUSE Linux Enterprise Server 12-SP5 (src):    glib2-2.48.2-12.12.2
SUSE Linux Enterprise Server 12-SP4 (src):    glib2-2.48.2-12.12.2
SUSE Linux Enterprise Server 12-SP3 (src):    glib2-2.48.2-12.12.2
SUSE Linux Enterprise Server 12-SP2-LTSS (src):    glib2-2.48.2-12.12.2
SUSE Linux Enterprise Server 12-SP2-BCL (src):    glib2-2.48.2-12.12.2
SUSE Linux Enterprise Desktop 12-SP5 (src):    glib2-2.48.2-12.12.2
SUSE Linux Enterprise Desktop 12-SP4 (src):    glib2-2.48.2-12.12.2
SUSE Linux Enterprise Desktop 12-SP3 (src):    glib2-2.48.2-12.12.2
SUSE Enterprise Storage 4 (src):    glib2-2.48.2-12.12.2
SUSE CaaS Platform 3.0 (src):    glib2-2.48.2-12.12.2
OpenStack Cloud Magnum Orchestration 7 (src):    glib2-2.48.2-12.12.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.