Bug 1110236 - Schematize YaST icons' names
Schematize YaST icons' names
Status: RESOLVED FEATURE
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Minor (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks: 1081517
  Show dependency treegraph
 
Reported: 2018-09-29 10:10 UTC by Sasi Olin
Modified: 2021-02-19 14:06 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sasi Olin 2018-09-29 10:10:27 UTC
YaST icons are named seemingly at random, with icons like printer2 and fcoe not really fitting within any scheme of naming icons. It would be nice, especially for people that would like to create external themes containing YaST icons, to create some scheme for names of icons. My suggestion is: yast-*function*-*name*
Examples of that would be:
yast-module-apparmor
yast-pattern-apparmor
yast-device-fcoe
yast-symbol-red-dot
Maybe it's not the shortest, but it represents what every single icon does very well.
Comment 1 Ladislav Slezák 2018-10-04 11:05:11 UTC
I'm not sure if this is the best solution. I mean I can see your point, but I'm not sure if the *function* really makes sense.

For example what would be the reason to have separate "yast-module-apparmor" and "yast-pattern-apparmor"? Usually you want to use some Apparmor icon and you do not care if it was designed for patterns, YaST modules or whatever else.

(I suppose we want to make the life for the designers easier and have as small set of icons as possible. I do not think we really need to have a completely different set of icons e.g. for patterns and YaST modules.)


What if we would like to have the same icon for the Apparmor pattern used also in the YaST module? I'd like to avoid duplicates...


In some cases the long name does not provide any value like "yast-symbol-red-dot", simple "red-dot" is self-descriptive. More over the suggested scheme might be a bit confusing, "yast-symbol-red-dot" is too specific. I think "error-bullet" or something like that would be better.

The reason is that if you want to design a completely different theme then red might not fit to your schema and maybe magenta is better. But having "yast-symbol-red-dot" file with magenta dot inside looks weird...

I think this needs some more discussion, please open a feature or probably better, discuss it on the yast-devel ML.
Comment 2 Sasi Olin 2018-10-04 12:56:29 UTC
I would honestly like to avoid any repeating icons and would like to replace all of them (and ready to make them). Also, patterns icons have both different function and different possible resolutions in which they appear (patterns are at 32px and modules basically at every single possible resolution due to DE differences). Also allowing people with different themes to theme YaST differently, because they might want to go crazier than we do. Icons that are allowed to be repeated with that scheme would be device and symbol icons, which would live together with yast-yast2, so they work across modules (because devices are way more universal than module icons).