Bug 1115022 - (CVE-2018-16843) VUL-0: CVE-2018-16843: nginx,nginx-1.0: Excessive memory consumption in HTTP/2 implementation
(CVE-2018-16843)
VUL-0: CVE-2018-16843: nginx,nginx-1.0: Excessive memory consumption in HTTP/...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Artem Chernikov
Security Team bot
https://smash.suse.de/issue/218728/
CVSSv3:RedHat:CVE-2018-16843:5.3:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-11-07 13:44 UTC by Robert Frohl
Modified: 2021-03-19 08:05 UTC (History)
4 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 2 Robert Frohl 2018-11-07 13:53:42 UTC
rh#1644511

nginx before versions 1.15.6 and 1.14.1 has a vulnerability in the implementation of HTTP/2 that can allow for excessive memory consumption.

upstream patch:
https://hg.nginx.org/nginx/rev/d4448892a294

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1644511
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-16843
http://people.canonical.com/~ubuntu-security/cve/2018/CVE-2018-16843.html
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16843
Comment 3 Robert Frohl 2018-11-07 14:09:00 UTC
Hi Artem,
my investigation suggests that the following codestream is affected:
- SUSE:SLE-15:Update/nginx


SLE-11-SP2 is not affected because HTTP/2 is not supported in the version we ship there.
Comment 4 Christian Wittmer 2018-12-18 09:40:53 UTC
################################
Excessive memory usage in HTTP/2
Severity: low
Advisory
CVE-2018-16843
Not vulnerable: 1.15.6+, 1.14.1+
Vulnerable: 1.9.5-1.15.5
################################

Preparing Maintenance Request ...
Comment 5 Swamp Workflow Management 2018-12-18 11:43:30 UTC
This is an autogenerated message for OBS integration:
This bug (1115022) was mentioned in
https://build.opensuse.org/request/show/659058 15.0+42.3+Backports:SLE-12 / nginx
Comment 6 Robert Frohl 2019-01-03 12:25:32 UTC
I think everything should be clarified, currently waiting for submission (removing needinfo)
Comment 7 Swamp Workflow Management 2019-02-05 11:40:13 UTC
This is an autogenerated message for OBS integration:
This bug (1115022) was mentioned in
https://build.opensuse.org/request/show/671823 42.3 / nginx
Comment 8 Swamp Workflow Management 2019-02-05 13:30:11 UTC
This is an autogenerated message for OBS integration:
This bug (1115022) was mentioned in
https://build.opensuse.org/request/show/671853 15.0 / nginx
Comment 9 Swamp Workflow Management 2019-02-05 19:00:13 UTC
This is an autogenerated message for OBS integration:
This bug (1115022) was mentioned in
https://build.opensuse.org/request/show/671959 15.0+42.3+Backports:SLE-12 / nginx
Comment 11 Swamp Workflow Management 2019-02-12 17:10:34 UTC
SUSE-SU-2019:0334-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1115015,1115022,1115025
CVE References: CVE-2018-16843,CVE-2018-16844,CVE-2018-16845
Sources used:
SUSE Linux Enterprise Module for Server Applications 15 (src):    nginx-1.14.2-3.3.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (src):    nginx-1.14.2-3.3.1
Comment 12 Swamp Workflow Management 2019-02-18 14:13:50 UTC
openSUSE-SU-2019:0195-1: An update that fixes three vulnerabilities is now available.

Category: security (moderate)
Bug References: 1115015,1115022,1115025
CVE References: CVE-2018-16843,CVE-2018-16844,CVE-2018-16845
Sources used:
openSUSE Leap 42.3 (src):    nginx-1.14.2-2.7.1
openSUSE Leap 15.0 (src):    nginx-1.14.2-lp150.2.4.1
Comment 13 Swamp Workflow Management 2019-02-18 14:15:12 UTC
openSUSE-SU-2019:0195-1: An update that fixes three vulnerabilities is now available.

Category: security (moderate)
Bug References: 1115015,1115022,1115025
CVE References: CVE-2018-16843,CVE-2018-16844,CVE-2018-16845
Sources used:
openSUSE Leap 42.3 (src):    nginx-1.14.2-2.7.1
openSUSE Leap 15.0 (src):    nginx-1.14.2-lp150.2.4.1
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    nginx-1.14.2-16.1
Comment 15 Swamp Workflow Management 2019-09-05 19:14:17 UTC
SUSE-SU-2019:2309-1: An update that fixes 6 vulnerabilities is now available.

Category: security (important)
Bug References: 1115015,1115022,1115025,1145579,1145580,1145582
CVE References: CVE-2018-16843,CVE-2018-16844,CVE-2018-16845,CVE-2019-9511,CVE-2019-9513,CVE-2019-9516
Sources used:
SUSE Linux Enterprise Module for Server Applications 15-SP1 (src):    nginx-1.14.2-6.3.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (src):    nginx-1.14.2-6.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 16 Swamp Workflow Management 2019-09-10 22:19:15 UTC
openSUSE-SU-2019:2120-1: An update that fixes 6 vulnerabilities is now available.

Category: security (important)
Bug References: 1115015,1115022,1115025,1145579,1145580,1145582
CVE References: CVE-2018-16843,CVE-2018-16844,CVE-2018-16845,CVE-2019-9511,CVE-2019-9513,CVE-2019-9516
Sources used:
openSUSE Leap 15.1 (src):    nginx-1.14.2-lp151.4.3.1
Comment 17 Marcus Meissner 2020-08-05 17:45:30 UTC
released