Bug 1119161 - xen-libs-32bit not current on Leap 42.3, unresolvable due to pandoc build requirement
xen-libs-32bit not current on Leap 42.3, unresolvable due to pandoc build req...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Xen
Leap 42.3
Other Other
: P5 - None : Minor (vote)
: ---
Assigned To: Charles Arnold
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-12-11 16:25 UTC by Andreas Stieger
Modified: 2019-04-17 22:52 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Stieger 2018-12-11 16:25:31 UTC
openSUSE:Leap:42.3/xen from SUSE:SLE-12-SP3:Update/xen
build a xen-libs-32bit via baselibs.conf

On Leap 42.3 this does not build for i586 since pandoc is not available for this arch. Could xen(-libs) be built without pandoc on 32 bit so that we can ship a current xen-libs-32bit?

$ zypper search -s xen-libs
Loading repository data...
Reading installed packages...

S | Name           | Type    | Version       | Arch   | Repository               
--+----------------+---------+---------------+--------+--------------------------
  | xen-libs       | package | 4.9.3_03-31.1 | x86_64 | openSUSE-Leap-42.3-Update
  | xen-libs       | package | 4.9.2_10-28.1 | x86_64 | openSUSE-Leap-42.3-Update
  | xen-libs       | package | 4.9.2_08-25.2 | x86_64 | openSUSE-Leap-42.3-Update
  | xen-libs       | package | 4.9.2_06-22.1 | x86_64 | openSUSE-Leap-42.3-Update
  | xen-libs       | package | 4.9.2_04-19.2 | x86_64 | openSUSE-Leap-42.3-Update
  | xen-libs       | package | 4.9.1_08-16.1 | x86_64 | openSUSE-Leap-42.3-Update
  | xen-libs       | package | 4.9.1_02-13.2 | x86_64 | openSUSE-Leap-42.3-Update
  | xen-libs       | package | 4.9.0_14-10.1 | x86_64 | openSUSE-Leap-42.3-Update
  | xen-libs       | package | 4.9.0_12-7.1  | x86_64 | openSUSE-Leap-42.3-Update
  | xen-libs       | package | 4.9.0_11-4.1  | x86_64 | openSUSE-Leap-42.3-Update
  | xen-libs       | package | 4.9.0_08-2.1  | x86_64 | openSUSE-Leap-42.3-Oss   
  | xen-libs-32bit | package | 4.9.0_08-2.1  | x86_64 | openSUSE-Leap-42.3-Oss
Comment 1 Charles Arnold 2019-01-09 21:00:17 UTC
I have fixed this. Next time there is a maintenance update for 12-SP3
it will show up for openSUSE 42.3

See Devel:Virt:SLE-12-SP3/xen for source.
Comment 3 Swamp Workflow Management 2019-04-05 19:22:55 UTC
SUSE-SU-2019:0891-1: An update that solves two vulnerabilities and has 16 fixes is now available.

Category: security (important)
Bug References: 1026236,1027519,1069468,1119161,1120067,1123157,1126140,1126141,1126192,1126195,1126196,1126197,1126198,1126201,1126325,1127400,1127620,1129623
CVE References: CVE-2019-6778,CVE-2019-9824
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP4 (src):    xen-4.11.1_04-2.6.1
SUSE Linux Enterprise Server 12-SP4 (src):    xen-4.11.1_04-2.6.1
SUSE Linux Enterprise Desktop 12-SP4 (src):    xen-4.11.1_04-2.6.1

*** NOTE: This information is not intended to be used for external
    communication, because this may only be a partial fix.
    If you have questions please reach out to maintenance coordination.
Comment 4 Swamp Workflow Management 2019-04-17 19:21:36 UTC
openSUSE-SU-2019:1226-1: An update that solves 8 vulnerabilities and has 15 fixes is now available.

Category: security (important)
Bug References: 1026236,1027519,1069468,1105528,1114988,1115040,1115045,1115047,1116380,1117756,1119161,1123157,1126140,1126141,1126192,1126195,1126196,1126197,1126198,1126201,1126325,1127400,1129623
CVE References: CVE-2018-19665,CVE-2018-19961,CVE-2018-19962,CVE-2018-19965,CVE-2018-19966,CVE-2018-19967,CVE-2019-6778,CVE-2019-9824
Sources used:
openSUSE Leap 42.3 (src):    xen-4.9.4_02-37.1