Bug 1121945 - (CVE-2019-6286) VUL-1: CVE-2019-6286: libsass: heap-based buffer over-read exists in Sass:Prelexer:skip_over_scopes in prelexer.hpp when called from Sass:Parser:parse_import()
(CVE-2019-6286)
VUL-1: CVE-2019-6286: libsass: heap-based buffer over-read exists in Sass:Pre...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 15.0
Other Other
: P4 - Low : Minor (vote)
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/222774/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-01-15 07:25 UTC by Karol Babioch
Modified: 2019-08-14 16:13 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karol Babioch 2019-01-15 07:25:40 UTC
CVE-2019-6286

In LibSass 3.5.5, a heap-based buffer over-read exists in
Sass::Prelexer::skip_over_scopes in prelexer.hpp when called from
Sass::Parser::parse_import(), a similar issue to CVE-2018-11693.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-6286
http://www.cvedetails.com/cve/CVE-2019-6286/
https://github.com/sass/libsass/issues/2815
Comment 1 Tomáš Chvátal 2019-07-11 11:38:18 UTC
This is automated batch bugzilla cleanup.

The openSUSE 42.3 changed to end-of-life (EOL [1]) status. As such
it is no longer maintained, which means that it will not receive any
further security or bug fix updates.
As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
openSUSE (At this moment openSUSE Leap 15.1, 15.0 and Tumbleweed) please
feel free to reopen this bug against that version (!you must update the
"Version" component in the bug fields, do not just reopen please), or
alternatively create a new ticket.

Thank you for reporting this bug and we are sorry it could not be fixed
during the lifetime of the release.

[1] https://en.opensuse.org/Lifetime
Comment 2 Marcus Meissner 2019-07-12 05:35:05 UTC
still unfixed in 15.0, 15.1 and factory.
Comment 3 Cédric Bosdonnat 2019-07-12 07:51:05 UTC
Fixes submitted with new release:

Factory: SR#714781
15.0: SR#714782
15.1: SR#714783
15.2: SR#714784
Comment 4 Swamp Workflow Management 2019-07-12 08:20:39 UTC
This is an autogenerated message for OBS integration:
This bug (1121945) was mentioned in
https://build.opensuse.org/request/show/714782 15.0 / libsass
https://build.opensuse.org/request/show/714783 15.1 / libsass
Comment 5 Swamp Workflow Management 2019-07-23 16:15:44 UTC
openSUSE-SU-2019:1791-1: An update that fixes 12 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1096894,1118301,1118346,1118348,1118349,1118351,1119789,1121943,1121944,1121945,1133200,1133201
CVE References: CVE-2018-11499,CVE-2018-19797,CVE-2018-19827,CVE-2018-19837,CVE-2018-19838,CVE-2018-19839,CVE-2018-20190,CVE-2018-20821,CVE-2018-20822,CVE-2019-6283,CVE-2019-6284,CVE-2019-6286
Sources used:
openSUSE Leap 15.1 (src):    libsass-3.6.1-lp151.3.3.1
openSUSE Leap 15.0 (src):    libsass-3.6.1-lp150.2.3.1
Comment 6 Marcus Meissner 2019-07-24 06:03:47 UTC
fixed in the meantime by version update.
Comment 7 Swamp Workflow Management 2019-07-24 16:12:23 UTC
openSUSE-SU-2019:1800-1: An update that fixes 12 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1096894,1118301,1118346,1118348,1118349,1118351,1119789,1121943,1121944,1121945,1133200,1133201
CVE References: CVE-2018-11499,CVE-2018-19797,CVE-2018-19827,CVE-2018-19837,CVE-2018-19838,CVE-2018-19839,CVE-2018-20190,CVE-2018-20821,CVE-2018-20822,CVE-2019-6283,CVE-2019-6284,CVE-2019-6286
Sources used:
openSUSE Backports SLE-15 (src):    libsass-3.6.1-bp150.3.3.1
Comment 8 Swamp Workflow Management 2019-08-14 16:13:16 UTC
openSUSE-SU-2019:1883-1: An update that fixes 12 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1096894,1118301,1118346,1118348,1118349,1118351,1119789,1121943,1121944,1121945,1133200,1133201
CVE References: CVE-2018-11499,CVE-2018-19797,CVE-2018-19827,CVE-2018-19837,CVE-2018-19838,CVE-2018-19839,CVE-2018-20190,CVE-2018-20821,CVE-2018-20822,CVE-2019-6283,CVE-2019-6284,CVE-2019-6286
Sources used:
openSUSE Backports SLE-15-SP1 (src):    libsass-3.6.1-bp151.4.3.1