Bug 1122174 - [Build 142.1] multiple missing icons
[Build 142.1] multiple missing icons
Status: VERIFIED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
Other Other
: P3 - Medium : Normal (vote)
: Current
Assigned To: YaST Team
Jiri Srain
https://openqa.suse.de/tests/2378630/...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-01-16 11:45 UTC by Rodion Iafarov
Modified: 2021-03-23 09:39 UTC (History)
7 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rodion Iafarov 2019-01-16 11:45:35 UTC
## Observation
With the new nice log message introduced by HuHa, in the Beta2 candidate we have following:
Couldn't load pixmap from computer
Couldn't load pixmap from drive-harddisk
Couldn't load pixmap from drive-partition
Couldn't load pixmap from drive-multidisk

I guess there might be more if we open more dialogues, will evaluate these.

openQA test in scenario sle-15-SP1-Installer-DVD-x86_64-detect_yast2_failures@64bit fails in
[logs_from_installation_system](https://openqa.suse.de/tests/2378630/modules/logs_from_installation_system/steps/53)


## Reproducible

Fails since (at least) Build [88.6](https://openqa.suse.de/tests/2248314)


## Expected result

Last good: (unknown) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.suse.de/tests/latest?version=15-SP1&flavor=Installer-DVD&machine=64bit&test=detect_yast2_failures&arch=x86_64&distri=sle)
Comment 1 Stefan Hundhammer 2019-01-21 10:30:00 UTC
AFAICS the icons are there in the sources:

  https://github.com/libyui/libyui-qt/tree/master/src/icons

and they appear to be listed correctly in the Qt resource description XML file:

  https://github.com/libyui/libyui-qt/blob/master/src/qt_icons.qrc
Comment 2 Stefan Hundhammer 2019-01-21 10:42:01 UTC
The icons in that directory all render fine on my machine with inkscape and with gimp.
Comment 4 Rodion Iafarov 2019-01-22 14:57:13 UTC
Moved to TW to make visible for community as we have same problem in TW and leap 15.1
Comment 5 Marco Calistri 2019-02-04 16:37:51 UTC
Hello,

I'm sorry, I'm just a simple user of Opensuse Tumbleweed, not a developer, so try to be understanding.

There is something strange that appears to my eyes:

I have an opensuse TW installation on a Lenovo Z470 laptop which is the default machine / O.S. which I am being using it so far.

In this environment the GUI of Yast is "ugly": I mean that it is not "geometrically adjusted" and that all its expected icons are missing.

I have on this same machine, a VirtualBox opensuse Leap 15 Guest, wherein the YAST GUI is perfectly adjusted and shown with all its expected icons.

I'm not able to understand why in the hell this has happened and also because it has not yet been resolved.

It is evident that some of the latest "zypper dup" updates, have dragged this unwanted result into Tumbleweed, so I would like to know if you have any predictions to solve it or any alternative solution to apply in the meantime.

yast2 version installed on Tumbleweed:

Informazioni per pacchetto yast2:
---------------------------------
Repository            : Repo-Oss                    
Nome                  : yast2                       
Versione              : 4.1.53-1.1                  
Arch.                 : x86_64                      
Fornitore             : openSUSE                    
Dimensione installata : 2,3 MiB                     
installato            : Sì                          
Stato                 : aggiornato                  
Pacchetto sorgente    : yast2-4.1.53-1.1.src        
Sommario              : YaST2 - pacchetto principale
Descrizione           :                             
    This package contains scripts and data needed for SUSE Linux
    installation with YaST2

yast2 version installed on Leap 15.0:

Informazioni per pacchetto yast2:
---------------------------------
Repository            : Repository principale degli aggiornamenti
Nome                  : yast2                                    
Versione              : 4.0.87-lp150.2.9.1                       
Arch.                 : x86_64                                   
Fornitore             : openSUSE                                 
Dimensione installata : 2,3 MiB                                  
installato            : Sì (autometicamente)                     
Stato                 : aggiornato                               
Pacchetto sorgente    : yast2-4.0.87-lp150.2.9.1.src             
Sommario              : YaST2 - pacchetto principale             
Descrizione           :                                          
    This package contains scripts and data needed for SUSE Linux
    installation with YaST2



Thanks for the attention!
Comment 6 Stefan Hundhammer 2019-02-04 16:56:44 UTC
Marco, thank you for this additional information, but I fear things have become rather complicated with that eye candy stuff.

For one thing, it's not a single package yast2 - it's a bunch of packages that all together collectively form the thing known to users as YaST2. That one package you mentioned is just a small part of it. For GUI stuff, there is libyui-qt (plus subpackages), a lot of libqt5 packages, and yast2-control-center-qt which is a standalone Qt application. And then there are icon theme packages.

And as if that were not enough, now we are using icons from whatever desktop environment you are using: GNOME, KDE / Plasma 5, Xfce, whatever. And those in turn also have icon theme packages.

So, it's quite hard to say exactly where and why those icons went missing.

On current TW, I see even more icons missing, but in other places: In the software manager, there are no patterns icons anymore (but there are status icons, so icon loading and rendering does work in general).
Comment 7 Marco Calistri 2019-02-04 17:20:37 UTC
Thanks Stefan and I'm sorry if I downplayed the difficulty in correcting this problem.

I was not sure about the size of the dependencies involved to form the Yast2 environment.

I hope you guys will soon identify the root cause of this issue and you would be able to correct it.

Best regards,
Comment 8 Stefan Hundhammer 2019-02-05 12:35:09 UTC
No problem; my intention was just to explain why this even made it into our task queue rather than being simply fixed right away. If it had been simple, we would have done just that. ;-)
Comment 9 Marco Calistri 2019-02-09 16:00:06 UTC
I keep trying several things as uninstall, reinstall yast2 and its dependencies and Googling and trying some of the suggested steps, but all had not succeeded.

Among these tests I would like to report the following:
if I click on Yast configuration_management I get the following error:

"There are no formulas available. Please check the log files.There are no formulas available. Please check the log files."

But I don't know where is the log for this error.

Regards,
Comment 10 Christian Boltz 2019-02-10 00:55:06 UTC
(In reply to Marco Calistri from comment #9)
> if I click on Yast configuration_management I get the following error:
> 
> "There are no formulas available. Please check the log files.There are no
> formulas available. Please check the log files."

That sounds like a completely different bug - please open a separate bugreport for it.

> But I don't know where is the log for this error.

Run save_y2logs to collect the logs, for details see 
https://en.opensuse.org/openSUSE:Report_a_YaST_bug
Comment 11 Marco Calistri 2019-02-10 13:35:50 UTC
(In reply to Christian Boltz from comment #10)
> (In reply to Marco Calistri from comment #9)
> > if I click on Yast configuration_management I get the following error:
> > 
> > "There are no formulas available. Please check the log files.There are no
> > formulas available. Please check the log files."
> 
> That sounds like a completely different bug - please open a separate
> bugreport for it.
> 
> > But I don't know where is the log for this error.
> 
> Run save_y2logs to collect the logs, for details see 
> https://en.opensuse.org/openSUSE:Report_a_YaST_bug

Thanks for the instructions Christian, I will open a separate bug.
Comment 12 Marco Calistri 2019-02-10 13:38:24 UTC
(In reply to Christian Boltz from comment #10)
> (In reply to Marco Calistri from comment #9)
> > if I click on Yast configuration_management I get the following error:
> > 
> > "There are no formulas available. Please check the log files.There are no
> > formulas available. Please check the log files."
> 
> That sounds like a completely different bug - please open a separate
> bugreport for it.
> 
> > But I don't know where is the log for this error.
> 
> Run save_y2logs to collect the logs, for details see 
> https://en.opensuse.org/openSUSE:Report_a_YaST_bug

Thanks for the instructions Christian, I will open a separate bug.
Comment 13 Marco Calistri 2019-02-10 14:07:09 UTC
(In reply to Marco Calistri from comment #11)
> (In reply to Christian Boltz from comment #10)
> > (In reply to Marco Calistri from comment #9)
> > > if I click on Yast configuration_management I get the following error:
> > > 
> > > "There are no formulas available. Please check the log files.There are no
> > > formulas available. Please check the log files."
> > 
> > That sounds like a completely different bug - please open a separate
> > bugreport for it.
> > 
> > > But I don't know where is the log for this error.
> > 
> > Run save_y2logs to collect the logs, for details see 
> > https://en.opensuse.org/openSUSE:Report_a_YaST_bug
> 
> Thanks for the instructions Christian, I will open a separate bug.

Created the Bug https://bugzilla.opensuse.org/show_bug.cgi?id=1124895
Comment 14 Marco Calistri 2019-02-11 16:03:28 UTC
(In reply to Stefan Hundhammer from comment #8)
> No problem; my intention was just to explain why this even made it into our
> task queue rather than being simply fixed right away. If it had been simple,
> we would have done just that. ;-)

Dunno if it is matter of being interesting or not:

If I run "/usr/lib/YaST2/bin/y2controlcenter" by console, I see the foreseen icons for this process executed by a non-root user: the CD/DVD icon for support verification and the Release Notes icon.

Instead if I run it by "gnomesu /usr/lib/YaST2/bin/y2controlcenter",

The YaST Control Center appears with all its  functions but without all the related icons.

Regards,
Comment 15 Michael Pujos 2019-02-20 14:49:35 UTC
Assuming the Qt version of the UI is started (the GTK version is deprecated and has no icons), this issue is probably due to not having a Qt theme configured for root.

You can experiment doing this:

- login as root using su
- install qt5ct: zypper in qt5ct
- start qt5ct and set a theme
- start yast2 on the shell without argument. Compare the UI with yast2 --gtk and yast2 --qt to determine which version (Qt or GTL) yast2 without argument starts 
Assuming, the Qt version is started (otherwise add --qt arg), if you do not have icons, try:
QT_QPA_PLATFORMTHEME=qt5ct yast2
Comment 16 Stefan Hundhammer 2019-02-20 16:48:27 UTC
(In reply to Michael Pujos from comment #15)
> Assuming the Qt version of the UI is started (the GTK version is deprecated
> and has no icons), this issue is probably due to not having a Qt theme
> configured for root.
> 
> You can experiment doing this:
> 
> - login as root using su
> - install qt5ct: zypper in qt5ct
> - start qt5ct and set a theme
> - start yast2 on the shell without argument. Compare the UI with yast2 --gtk
> and yast2 --qt to determine which version (Qt or GTL) yast2 without argument
> starts 
> Assuming, the Qt version is started (otherwise add --qt arg), if you do not
> have icons, try:
> QT_QPA_PLATFORMTHEME=qt5ct yast2

I can confirm this; it's the same on my system (running Xfce).
Thanks for this hint!

Everybody please notice that this is about the missing icons in the YaST Qt control center.

The original bug here was about missing icons in the partitioner's dialog headings which is something quite different.

The same icon is present in the wizard tree, but it is missing in the dialog heading.
Comment 17 Stefan Hundhammer 2019-02-20 16:53:36 UTC
For y2cc-qt:

sudo bash
export QT_QPA_PLATFORMTHEME=qt5ct
yast2


-> no icons


unset QT_QPA_PLATFORMTHEME
yast2


-> the icons are all there as expected.

I added that environment variable to the "Defaults env_keep" line in my /etc/sudoers file so I get reasonable font sizes and widget styles for Qt applications started with "sudo". It appears that this clashes with our YaST icon theme.
Comment 18 Stefan Hundhammer 2019-02-20 16:57:59 UTC
Ok, the fix for that y2cc-qt thing is simple enough:

When you set QT_QPA_PLATFORMTHEME to qt5ct for root, make sure to call qt5ct once for root (i.e. with "sudo") and set an icon theme (and save, of course).
Comment 19 Marco Calistri 2019-02-20 19:19:04 UTC
(In reply to Michael Pujos from comment #15)
> Assuming the Qt version of the UI is started (the GTK version is deprecated
> and has no icons), this issue is probably due to not having a Qt theme
> configured for root.
> 
> You can experiment doing this:
> 
> - login as root using su
> - install qt5ct: zypper in qt5ct
> - start qt5ct and set a theme
> - start yast2 on the shell without argument. Compare the UI with yast2 --gtk
> and yast2 --qt to determine which version (Qt or GTL) yast2 without argument
> starts 
> Assuming, the Qt version is started (otherwise add --qt arg), if you do not
> have icons, try:
> QT_QPA_PLATFORMTHEME=qt5ct yast2

You really are the MAN! :-)

Everything works as expected after I followed your instructions:
- login as root and settings default Qt5 theme
all the icons are there both if using just "yast2" as well as "yast2 --qt".

Now with logged with my normal username I see the YaST2 control-center icons as well.

Then it was just a matter of settings?

Cheers and thanks indeed.
Comment 20 Stefan Hundhammer 2019-02-27 16:42:15 UTC
For the other icons (mostly in the partitioner), see bug #1119688.
Comment 21 Stefan Hundhammer 2019-02-27 17:13:09 UTC
Pull request with the fix:

https://github.com/libyui/libyui-qt/pull/100
Comment 22 Stefan Hundhammer 2019-02-27 17:31:09 UTC
The fix will appear with libyui-qt-2.49.15.
Comment 23 Rodion Iafarov 2019-03-13 09:15:37 UTC
Build189.1
Thanks for the patch.