Bug 1124342 - (CVE-2019-1000020) VUL-1: CVE-2019-1000020: libarchive: Infinite Loop vulnerability in ISO9660 parser
(CVE-2019-1000020)
VUL-1: CVE-2019-1000020: libarchive: Infinite Loop vulnerability in ISO9660 p...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Minor
: ---
Assigned To: Adrian Schröter
Security Team bot
https://smash.suse.de/issue/224194/
CVSSv3:SUSE:CVE-2019-1000020:3.3:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-05 14:57 UTC by Robert Frohl
Modified: 2020-07-13 09:45 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Frohl 2019-02-05 14:57:36 UTC
CVE-2019-1000020

libarchive version commit 5a98dcf8a86364b3c2c469c85b93647dfb139961 onwards
(version v2.8.0 onwards) contains a CWE-835: Loop with Unreachable Exit
Condition ('Infinite Loop') vulnerability in ISO9660 parser,
archive_read_support_format_iso9660.c, read_CE()/parse_rockridge() that can
result in DoS by infinite loop. This attack appears to be exploitable via the
victim opening a specially crafted ISO9660 file.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-1000020
https://github.com/libarchive/libarchive/pull/1120/commits/8312eaa576014cd9b965012af51bc1f967b12423
https://github.com/libarchive/libarchive/pull/1120
Comment 1 Robert Frohl 2019-02-05 14:59:45 UTC
both SLE12 and SLE15 seem to be affected
Comment 2 Swamp Workflow Management 2019-02-05 15:56:59 UTC
This is an autogenerated message for OBS integration:
This bug (1124342) was mentioned in
https://build.opensuse.org/request/show/671920 Factory / libarchive
Comment 4 Swamp Workflow Management 2019-04-01 16:12:06 UTC
SUSE-SU-2019:0831-1: An update that fixes 6 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1120653,1120654,1120656,1120659,1124341,1124342
CVE References: CVE-2018-1000877,CVE-2018-1000878,CVE-2018-1000879,CVE-2018-1000880,CVE-2019-1000019,CVE-2019-1000020
Sources used:
SUSE Linux Enterprise Module for Development Tools 15 (src):    libarchive-3.3.2-3.8.4
SUSE Linux Enterprise Module for Basesystem 15 (src):    libarchive-3.3.2-3.8.4

*** NOTE: This information is not intended to be used for external
    communication, because this may only be a partial fix.
    If you have questions please reach out to maintenance coordination.
Comment 6 Swamp Workflow Management 2019-11-28 20:15:08 UTC
SUSE-SU-2019:3093-1: An update that fixes 5 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1120653,1120654,1124341,1124342,1155079
CVE References: CVE-2018-1000877,CVE-2018-1000878,CVE-2019-1000019,CVE-2019-1000020,CVE-2019-18408
Sources used:
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (src):    libarchive-3.3.2-3.11.1
SUSE Linux Enterprise Module for Development Tools 15-SP1 (src):    libarchive-3.3.2-3.11.1
SUSE Linux Enterprise Module for Development Tools 15 (src):    libarchive-3.3.2-3.11.1
SUSE Linux Enterprise Module for Basesystem 15-SP1 (src):    libarchive-3.3.2-3.11.1
SUSE Linux Enterprise Module for Basesystem 15 (src):    libarchive-3.3.2-3.11.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2019-11-28 20:21:50 UTC
SUSE-SU-2019:3092-1: An update that fixes 10 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1032089,1037008,1037009,1059134,1059139,1120653,1120654,1124341,1124342,1155079
CVE References: CVE-2016-10209,CVE-2016-10349,CVE-2016-10350,CVE-2017-14501,CVE-2017-14502,CVE-2018-1000877,CVE-2018-1000878,CVE-2019-1000019,CVE-2019-1000020,CVE-2019-18408
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    libarchive-3.1.2-26.6.1
SUSE Linux Enterprise Software Development Kit 12-SP4 (src):    libarchive-3.1.2-26.6.1
SUSE Linux Enterprise Server 12-SP5 (src):    libarchive-3.1.2-26.6.1
SUSE Linux Enterprise Server 12-SP4 (src):    libarchive-3.1.2-26.6.1
SUSE Linux Enterprise Desktop 12-SP4 (src):    libarchive-3.1.2-26.6.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 8 Swamp Workflow Management 2019-12-03 20:12:36 UTC
openSUSE-SU-2019:2615-1: An update that fixes 5 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1120653,1120654,1124341,1124342,1155079
CVE References: CVE-2018-1000877,CVE-2018-1000878,CVE-2019-1000019,CVE-2019-1000020,CVE-2019-18408
Sources used:
openSUSE Leap 15.0 (src):    libarchive-3.3.2-lp150.10.1
Comment 9 Swamp Workflow Management 2019-12-03 23:14:34 UTC
openSUSE-SU-2019:2632-1: An update that fixes 5 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1120653,1120654,1124341,1124342,1155079
CVE References: CVE-2018-1000877,CVE-2018-1000878,CVE-2019-1000019,CVE-2019-1000020,CVE-2019-18408
Sources used:
openSUSE Leap 15.1 (src):    libarchive-3.3.2-lp151.5.3.1
Comment 10 Adrian Schröter 2020-07-13 09:45:55 UTC
fixed