Bug 1127763 - Suspend and Hibernation causes reboot
Suspend and Hibernation causes reboot
Status: RESOLVED NORESPONSE
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
64bit Other
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-03-04 16:03 UTC by Gabriel Fernandes
Modified: 2021-12-31 14:46 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
fvogt: needinfo? (gafernandesil)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Fernandes 2019-03-04 16:03:19 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0
Build Identifier: 

For some reason when I set the computer to Suspend or Hibernate it reboots. It was reported to happen with Vaio notebooks, for which the solution was to add acpi_sleep=nonvs as kernel parameter, but with the notebook Acer V15 nitro it doesn't work. This appeared months ago.
The problem appeared some time after I created a Swap Partition to allow the computer to hibernate. The hibernate worked some times after the Swap partition was created, so I don't know if it is the root of the problem. 


Reproducible: Always




Things that I tried already:

-Add resume=/dev/disk... to GRUB_CMDLINE_LINUX_DEFAULT
-Add acpi_sleep=nonvs
-Add nomodeset

I'm using Bumblebee + Nvidia drivers (GTX 960M).

More information about the system and the journalctl log is available at this threads


https://www.reddit.com/r/openSUSE/comments/aww4zu/suspend_and_hibernate_do_not_work_should_i_report/

https://forums.opensuse.org/showthread.php/534882-Hibernate-and-suspend-not-working
Comment 1 Gabriel Fernandes 2019-03-04 17:00:04 UTC
Hibernating with "sudo systemctl hibernate" works. But not with suspend.
Comment 2 Fabian Vogt 2020-10-01 09:00:47 UTC
Reassigning to kernel. Does the issue still happen on current Tumbleweed?
Comment 3 Miroslav Beneš 2021-12-31 14:46:10 UTC
No response, closing.