Bug 1130165 - (CVE-2019-9755) VUL-0: CVE-2019-9755: ntfs-3g, ntfs-3g_ntfsprogs: heap-based buffer overflow leads to local root privilege escalation
(CVE-2019-9755)
VUL-0: CVE-2019-9755: ntfs-3g, ntfs-3g_ntfsprogs: heap-based buffer overflow ...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/226571/
CVSSv3:SUSE:CVE-2019-9755:5.5:(AV:L/A...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-03-22 09:30 UTC by Karol Babioch
Modified: 2022-06-10 13:34 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karol Babioch 2019-03-22 09:30:30 UTC
A heap-based buffer overflow was discovered in NTFS-3G, a read-write NTFS driver for FUSE. A local user can take advantage of this flaw for local root privilege escalation.

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1691624
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-9755
http://people.canonical.com/~ubuntu-security/cve/2019/CVE-2019-9755.html
http://www.debian.org/security/2019/dsa-4413
https://security-tracker.debian.org/tracker/source-package/ntfs-3g
Comment 1 Karol Babioch 2019-03-22 09:39:31 UTC
Upstream commit: https://sourceforge.net/p/ntfs-3g/ntfs-3g/ci/85c1634a26faa572d3c558d4cf8aaaca5202d4e9/

Vulnerable code can be found in:

- SUSE:SLE-11-SP2:Update / ntfs-3g
- SUSE:SLE-12:Update / ntfs-3g_ntfsprogs
-  SUSE:SLE-15:Update / ntfs-3g_ntfsprogs
Comment 4 Swamp Workflow Management 2019-04-24 15:49:54 UTC
SUSE-SU-2019:1001-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1130165
CVE References: CVE-2019-9755
Sources used:
SUSE Linux Enterprise Workstation Extension 15 (src):    ntfs-3g_ntfsprogs-2016.2.22-3.3.2
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (src):    ntfs-3g_ntfsprogs-2016.2.22-3.3.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 5 Swamp Workflow Management 2019-04-24 16:11:07 UTC
SUSE-SU-2019:1000-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1130165
CVE References: CVE-2019-9755
Sources used:
SUSE Linux Enterprise Workstation Extension 12-SP4 (src):    ntfs-3g_ntfsprogs-2013.1.13-5.6.1
SUSE Linux Enterprise Workstation Extension 12-SP3 (src):    ntfs-3g_ntfsprogs-2013.1.13-5.6.1
SUSE Linux Enterprise Software Development Kit 12-SP4 (src):    ntfs-3g_ntfsprogs-2013.1.13-5.6.1
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    ntfs-3g_ntfsprogs-2013.1.13-5.6.1
SUSE Linux Enterprise Desktop 12-SP4 (src):    ntfs-3g_ntfsprogs-2013.1.13-5.6.1
SUSE Linux Enterprise Desktop 12-SP3 (src):    ntfs-3g_ntfsprogs-2013.1.13-5.6.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 6 Swamp Workflow Management 2019-05-02 19:09:28 UTC
openSUSE-SU-2019:1314-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1130165
CVE References: CVE-2019-9755
Sources used:
openSUSE Leap 15.0 (src):    ntfs-3g_ntfsprogs-2016.2.22-lp150.2.3.1
Comment 7 Swamp Workflow Management 2019-05-02 19:09:53 UTC
openSUSE-SU-2019:1313-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1130165
CVE References: CVE-2019-9755
Sources used:
openSUSE Leap 42.3 (src):    ntfs-3g_ntfsprogs-2013.1.13-7.6.1
Comment 8 Carlos López 2022-06-10 13:34:18 UTC
Done, closing.