Bug 1133776 - (CVE-2019-5429) VUL-0: CVE-2019-5429: filezilla: Privileges escalation via malicious 'fzsftp' binary in home directory.
VUL-0: CVE-2019-5429: filezilla: Privileges escalation via malicious 'fzsftp'...
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Other
Leap 15.1
Other Other
: P3 - Medium : Critical (vote)
: ---
Assigned To: Eric Schirra
Security Team bot
Depends on: 1130088
  Show dependency treegraph
Reported: 2019-04-30 10:04 UTC by Marcus Meissner
Modified: 2020-04-06 09:45 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Eric Schirra 2019-04-30 17:05:58 UTC
In network repo and facory are 3.41.2.

But 3.41.2 can not build for Leap 42.3, 15.0 and 15.1, because wxwidgets is to old.
And nettle and gnutls in 42.3 too.

So what can i do?
Comment 2 Andreas Stieger 2019-05-02 14:15:29 UTC
Instead of doing the version update, apply this patch only:
Comment 3 Eric Schirra 2019-05-20 07:02:29 UTC
I cannot see that this files patch the security issue.

So i have now update libfilzilla and filezilla to 3.42.1 in repo network.

When wxWidgets will update to 3.0.4 then filezilla 3.42.1 will build for 15.0, 15.1. Leap 42.3 is definitive to old.

So. Please update wxWidgets.
See also https://bugzilla.opensuse.org/show_bug.cgi?id=1130088
Comment 4 Tomáš Chvátal 2019-07-11 11:41:47 UTC
This is automated batch bugzilla cleanup.

The openSUSE 42.3 changed to end-of-life (EOL [1]) status. As such
it is no longer maintained, which means that it will not receive any
further security or bug fix updates.
As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
openSUSE (At this moment openSUSE Leap 15.1, 15.0 and Tumbleweed) please
feel free to reopen this bug against that version (!you must update the
"Version" component in the bug fields, do not just reopen please), or
alternatively create a new ticket.

Thank you for reporting this bug and we are sorry it could not be fixed
during the lifetime of the release.

[1] https://en.opensuse.org/Lifetime
Comment 5 Marcus Meissner 2019-07-11 12:12:41 UTC
15.0 still affected
Comment 6 Eric Schirra 2019-11-04 17:15:36 UTC
(In reply to Marcus Meissner from comment #5)
> 15.0 still affected

wxwidgets is still to old.
And still I cannot see that this files patch the security issue.

Please update wxwidgets.
Comment 7 Eric Schirra 2020-03-29 18:42:37 UTC
15.0 is end of lifetime.
Comment 8 Alexandros Toptsoglou 2020-04-06 09:30:57 UTC
15.1 still affected
Comment 9 Eric Schirra 2020-04-06 09:45:30 UTC
Do you read my comment:

wxwidgets is still to old.

filezilla needs 3.0.4
In Leap 15.1 and 15.2 is only 3.0.3
And openSUSE will not accepted my request for update of wxwidgets.
It will be an minor-minor update!

And so i have no changes to update.
Use filezilla from devel or from my repo and security issue is gone.