Bug 1137670 - Cancelling audio configuration disables audio output that worked before using "Sound" module
Cancelling audio configuration disables audio output that worked before using...
Status: CONFIRMED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: YaST2
Leap 15.1
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://trello.com/c/jhrOr0w7
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-06-07 22:28 UTC by Alexander Shchadilov
Modified: 2019-07-30 11:43 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Full YaST2 logs (5.50 MB, application/x-compressed-tar)
2019-06-11 17:51 UTC, Alexander Shchadilov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Shchadilov 2019-06-07 22:28:34 UTC
Overview: 
Generally speaking, audio works fine on my laptop running Leap 15.1. Out of curiosity I tried to look into "Sound" module of YaST. I tried to run "Normal setup", and test sound did not work. After that I cancelled setup and audio became silent, with "Dummy Output" visible in Plasma "Audio Volume" widget. Full system restart (not just logging out) returned audio to a working state.
I was able to reproduce it three times. If fixing is not a trivial task I suppose adding a warning message like "Restart is needed" will help.

Steps to Reproduce:
1. Install openSUSE Leap 15.1 with suggested Plasma desktop environment on x86-64 PC which sound card works out of the box in 15.1.
2. Launch YaST.
3. Click "Sound".
4. Choose audio hardware that is used as default output by Plasma.
5. Click "Edit".
6. Choose "Normal setup"
7. Click "Next".
8. Click "Cancel".
9. Answer "Yes".

Actual Results:
Audio output used by Plasma as default output stops working until restart.

Expected Results:
Audio works in the same way as before launching "Sound" module.

Software versions:
yast2 4.1.69-lp151.1.1
yast2-sound 4.1.1-lp151.1.9
plasma5-desktop 5.12.8-lp151.1.3
libphonon4qt5 4.10.1-lp151.2.4
Comment 1 Alexander Shchadilov 2019-06-08 11:09:44 UTC
Adding information on hardware.

YaST "Sound" module shows two entries:
Haswell-ULT HD Audio Controller
8 Series HD Audio Controller

"sudo lspci | grep Audio" output:
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)

"aplay --list-devices" output:
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Comment 2 Lukas Ocilka 2019-06-10 14:29:33 UTC
Please attach YaST logs.

https://en.opensuse.org/openSUSE:Report_a_YaST_bug

We can't tell what seems to be the problem without them.
At least the last /var/log/YaST2/y2log (if it hasn't rotated out to y2log-*.gz)
should contain the most important information.
Comment 3 Lukas Ocilka 2019-06-10 14:33:22 UTC
Out of curiosity :) What's actually your use case? Trying to configure
something that already works out of the box?
Comment 4 Alexander Shchadilov 2019-06-11 17:51:38 UTC
Created attachment 807309 [details]
Full YaST2 logs

I made steps from the report one more time and saved logs after that.
Comment 5 Alexander Shchadilov 2019-06-11 18:27:32 UTC
When I first clicked on the icon I was thinking it may have something related to audio quality as well, like resampling methods. It seems that's not the case.
So thats's all, I saw a strange thing and reported it.
Comment 6 José Iván López González 2019-07-30 11:43:11 UTC
Alexander, thanks for reporting and thanks for the logs. We will take a look to try to figure out what is happening there.

Please, next time mark the "I am providing the request ..." checkbox to place the bug under our radar again. Thanks!