Bug 1139774 - 'nouveau 0000:01:00.0: fifo: write fault' and unresponsive system
'nouveau 0000:01:00.0: fifo: write fault' and unresponsive system
Status: RESOLVED NORESPONSE
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Kernel
Leap 15.0
x86-64 Other
: P5 - None : Major (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-06-28 18:27 UTC by Suse User
Modified: 2020-09-10 10:31 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
journal (1.63 KB, text/plain)
2019-06-28 18:27 UTC, Suse User
Details
journal (6.32 KB, text/plain)
2019-07-19 19:12 UTC, Suse User
Details
journal (1.39 KB, text/plain)
2019-09-29 14:55 UTC, Suse User
Details
journal excerpt (1.57 KB, text/plain)
2020-01-26 19:51 UTC, Suse User
Details
journal (1.26 KB, text/plain)
2020-02-16 11:49 UTC, Suse User
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Suse User 2019-06-28 18:27:10 UTC
Created attachment 808919 [details]
journal

What I was doing:

In KDE Plasma:

Downloading something using qBittorrent.
A Tor Browser instance was opened (javascript disabled).
Playing something (network stream) on Monitor #2 (mpv)
Opened Dolphin.
Opened an AVI file to play in SMPlayer (on Monitor #1).

What happened:

The whole desktop froze (no motion) and I was able to see only the frame of the just opened SMPlayer. I was able to hear the audio from the playing network stream as well as the audio from the movie playing in SMPlayer. There was no mouse ponter and the system didn't react to any key press at all (including Alt+Ctrl+BkSp or Alt+Ctrl+F1/F2/...) I had to hit the Reset button for a cold restart.

After restarting I looked at the journal (attached)

Repeating the same after the reboot doesn't result in any problem.
Comment 1 Takashi Iwai 2019-07-03 12:04:08 UTC
Could you try Leap 15.1, at least the kernel?  It got lots of updates and nouveau driver is equivalent with 5.0.x kernel.
Comment 2 Suse User 2019-07-07 16:28:59 UTC
Upgrading to 15.1 is on my todo list however I can't do it quickly.

If you explain how to test a newer kernel, I could try that for a faster feedback.

In any case the issue appeared only once and never again. So I am not sure I will be able to reproduce it (unless you suggest a particular testing procedure).
Comment 3 Takashi Iwai 2019-07-08 10:10:46 UTC
You can install the kernel from Leap 15.1 repository onto your 15.0 system.
For example, if you don't need the secure boot, the latest kernel can be taken from OBS Kernel:openSUSE-15.1 repo,
  http://download.opensuse.org/repositories/Kernel:/openSUSE-15.1/standard/
Comment 4 Suse User 2019-07-09 16:45:45 UTC
OK. Installed and booted 4.12.14-lp151.35.gd3899db-default
Now what?
Comment 5 Takashi Iwai 2019-07-09 17:17:40 UTC
Now what?  That's my question to you :)
Does the Leap 15.1 kernel still show the same problem?
Comment 6 Suse User 2019-07-09 17:59:47 UTC
Well, as I said in Comment 2 this is not something which I know how to reproduce. 

The things described in "What I was doing" are nothing extraordinary and I have been doing them for many months without experiencing the issue. After reporting the bug I have repeated them too - many times before updating to this kernel as well now as after updating.

So I can't think of a way to proove whether the problem is fixed or not. That's why I also asked about a testing procedure if you can suggest one.
Comment 7 Takashi Iwai 2019-07-09 20:22:10 UTC
OK, then just keep using Leap 15.1 kernel and see whether you hit any similar problem.  Please clear NEEDINFO once when you encounter the same bug, or close it later if you think it working stably enough.
Comment 8 Suse User 2019-07-19 19:12:35 UTC
Created attachment 811072 [details]
journal

OK, it happened again.

# uname -a
Linux pc 4.12.14-lp151.36.g0ab03b7-default #1 SMP Sat Jul 13 17:59:31 UTC 2019 (0ab03b7) x86_64 x86_64 x86_64 GNU/Linux

What I was doing:

In KDE Plasma:

Downloading something using qBittorrent (minimized to tray FWIW).
ungoogled-chromium instance was opened and I was playing an HTML video.
Playing something (network stream) in mpv
The video in ungoogled-chromium finished so I started playing another one.

What happened:

Just like before the system became unresponsive to mouse and keyboard. Sound and network were working, so I connected from another system via SSH go get the journal (attached).
Comment 9 Suse User 2019-09-29 14:55:41 UTC
Created attachment 819899 [details]
journal

Why is it that 2+ months passed without response for a major bug which hangs the system?

Today it happened again:

# uname -a
Linux i7 4.12.14-lp151.53.gc7184b2-default #1 SMP Wed Sep 25 05:31:39 UTC 2019 (c7184b2) x86_64 x86_64 x86_64 GNU/Linux
Comment 10 Suse User 2020-01-26 19:51:16 UTC
Created attachment 828300 [details]
journal excerpt

Today it happened again:

Leap 15.1

Linux i7 4.12.14-lp151.28.36-default #1 SMP Fri Dec 6 13:50:27 UTC 2019 (8f4a495) x86_64 x86_64 x86_64 GNU/Linux
Comment 11 Suse User 2020-02-16 11:49:30 UTC
Created attachment 830196 [details]
journal

And it happens again:

4.12.14-lp151.28.36-default #1 SMP Fri Dec 6 13:50:27 UTC 2019 (8f4a495) x86_64 x86_64
Comment 12 Miroslav Beneš 2020-05-26 11:41:53 UTC
Unfortunate. I think it would be the best to test it also on upstream kernel (Kernel:HEAD or Kernel:stable projects in OBS) and if it happens also there, it should be reported to upstream. It could be difficult though without a reproducer.
Comment 13 Miroslav Beneš 2020-09-10 10:31:23 UTC
No response. Closing.