Bug 1139863 - (CVE-2019-13067) VUL-1: CVE-2019-13067: nginx: njs has a buffer over-read in nxt_utf8_decode in nxt/nxt_utf8.c
(CVE-2019-13067)
VUL-1: CVE-2019-13067: nginx: njs has a buffer over-read in nxt_utf8_decode i...
Status: RESOLVED INVALID
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Minor
: ---
Assigned To: Artem Chernikov
Security Team bot
https://smash.suse.de/issue/235897/
CVSSv3:SUSE:CVE-2019-13067:3.3:(AV:L/...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-01 08:30 UTC by Alexander Bergmann
Modified: 2020-05-12 18:37 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Bergmann 2019-07-01 08:30:22 UTC
CVE-2019-13067

njs through 0.3.3, used in NGINX, has a buffer over-read in nxt_utf8_decode in
nxt/nxt_utf8.c. This issue occurs after the fix for CVE-2019-12207 is in place.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-13067
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-13067
https://github.com/nginx/njs/issues/183
Comment 1 Alexandros Toptsoglou 2020-01-31 09:35:45 UTC
This is invalid. Our packaged nginx does not contain njs. Closing