Bug 1140573 - Intel/Kabylake: External monitor stops working when coming back from screen save mode (with docking station)
Intel/Kabylake: External monitor stops working when coming back from screen s...
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-06 05:37 UTC by Vincent Untz
Modified: 2022-01-03 12:39 UTC (History)
7 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
gdm-x-session logs after the error (9.22 KB, text/plain)
2019-07-10 06:24 UTC, Vincent Untz
Details
gdm-x-session logs before the error (152.62 KB, text/plain)
2019-07-10 06:27 UTC, Vincent Untz
Details
Error with kernel 5.2.2-1-default (16.85 KB, text/plain)
2019-08-10 20:49 UTC, Vincent Untz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Untz 2019-07-06 05:37:53 UTC
I have a new laptop (Dell Latitude 7290) with a dock (Dell WD15), and two external monitors plugged in the dock.

Every now and then, when I come back to the computer after a while, one monitor (and sometimes both) fails to wake up. I didn't find a way to restore things -- usually, I end up with no screen at all with my attempts, even when unplugging from dock...

I see this in /var/log/messages:

[drm:pipe_config_err [i915]] *ERROR* mismatch in pixel_rate (expected 154000, found 307999)
[drm:pipe_config_err [i915]] *ERROR* mismatch in shared_dpll (expected 00000000ee5f163c, found 00000000c8ae6c97)
[drm:pipe_config_err [i915]] *ERROR* mismatch in dpll_hw_state.ctrl1 (expected 0x00000003, found 0x00000001)
[drm:pipe_config_err [i915]] *ERROR* mismatch in base.adjusted_mode.crtc_clock (expected 154000, found 307999)
[drm:pipe_config_err [i915]] *ERROR* mismatch in port_clock (expected 270000, found 540000)
------------[ cut here ]------------
pipe state doesn't match!
WARNING: CPU: 7 PID: 2081 at drivers/gpu/drm/i915/intel_display.c:12433 verify_crtc_state+0x298/0x2d0 [i915]
Modules linked in: md4 sha512_ssse3 sha512_generic cmac nls_utf8 cifs ccm dns_resolver fscache tun af_packet hid_microsoft ff_memless hid_plantronics snd_usb_audio snd_usbmidi_lib snd_rawmidi usbhid snd_seq_device cdc_ether usbnet r8152 mii thunderbolt fuse uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videodev videobuf2_common xt_tcpudp ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 ipt_REJECT nf_reject_ipv4 xt_conntrack ebtable_nat ip6table_nat ip6table_mangle ip6table_raw ip6table_security iptable_nat nf_nat iptable_mangle iptable_raw iptable_security nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 bnep ip_set scsi_transport_iscsi nfnetlink ebtable_filter ebtables ip6table_filter ip6_tables iptable_filter ip_tables x_tables joydev bpfilter hid_multitouch hid_generic intel_xhci_usb_role_switch roles arc4 btusb btrtl btbcm btintel bluetooth mei_wdt mei_hdcp iTCO_wdt iTCO_vendor_support ecdh_generic msr snd_hda_codec_hdmi dell_rbtn iwlmvm intel_rapl x86_pkg_temp_thermal
 intel_powerclamp snd_soc_skl coretemp snd_soc_hdac_hda mac80211 snd_hda_codec_realtek snd_hda_ext_core snd_soc_skl_ipc snd_soc_sst_ipc snd_soc_sst_dsp kvm_intel snd_soc_acpi_intel_match snd_hda_codec_generic snd_soc_acpi snd_soc_core kvm snd_compress irqbypass snd_pcm_dmaengine snd_hda_intel iwlwifi dell_laptop ledtrig_audio dell_wmi snd_hda_codec dell_smbios dcdbas dell_smm_hwmon snd_hda_core cfg80211 snd_hwdep idma64 snd_pcm crct10dif_pclmul crc32_pclmul e1000e snd_timer ucsi_acpi pcspkr snd rtsx_pci_ms intel_wmi_thunderbolt wmi_bmof dell_wmi_descriptor ghash_clmulni_intel ptp i2c_i801 memstick typec_ucsi rfkill soundcore pps_core processor_thermal_device mei_me typec intel_lpss_pci intel_soc_dts_iosf intel_pch_thermal thermal battery mei intel_hid sparse_keymap int3400_thermal int3403_thermal intel_lpss_acpi intel_lpss int340x_thermal_zone ac acpi_pad acpi_thermal_rel button pcc_cpufreq aesni_intel crypto_simd cryptd glue_helper aes_x86_64 dm_crypt nls_iso8859_1 nls_cp437
 vfat fat btrfs libcrc32c xor i915 raid6_pq rtsx_pci_sdmmc i2c_algo_bit mmc_core drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops xhci_pci drm crc32c_intel xhci_hcd serio_raw usbcore rtsx_pci wmi i2c_hid video sg dm_multipath dm_mod scsi_dh_rdac scsi_dh_emc scsi_dh_alua ecryptfs efivarfs
CPU: 7 PID: 2081 Comm: X Tainted: G      D W         5.1.10-1-default #1 openSUSE Tumbleweed (unreleased)
Hardware name: Dell Inc. Latitude 7290/09386V, BIOS 1.9.3 04/26/2019
RIP: 0010:verify_crtc_state+0x298/0x2d0 [i915]
Code: 14 00 00 0f b6 d0 0f b6 f1 48 c7 c7 60 50 63 c0 0f 85 6c ff ff ff e8 77 6c ea ff 41 0f b6 45 09 e9 15 fe ff ff e8 37 53 b2 dd <0f> 0b e9 1e ff ff ff e8 2b 53 b2 dd 0f 0b e9 85 fe ff ff e8 1f 53
RSP: 0018:ffffa54e01f7bb78 EFLAGS: 00010296
RAX: 0000000000000019 RBX: ffff95fba8f782b0 RCX: 0000000000000006
RDX: 0000000000000007 RSI: 0000000000000086 RDI: ffff95fbae3d6a50
RBP: ffff95fba6ff9800 R08: 000000000000056c R09: 0000000000000030
R10: 0000000000000e21 R11: ffffa54e01f7ba35 R12: ffff95fb3a3b0800
R13: ffff95f9e6f47800 R14: ffff95fba8f78000 R15: ffff95fba8f782b8
FS:  00007fc11364b040(0000) GS:ffff95fbae3c0000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 00007f64e2d8f000 CR3: 0000000105e1a001 CR4: 00000000003606e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
Call Trace:
 ? verify_connector_state.isra.0+0xb7/0x280 [i915]
 intel_atomic_commit_tail+0x650/0xc40 [i915]
 intel_atomic_commit+0x21f/0x2f0 [i915]
 drm_mode_atomic_ioctl+0x821/0x950 [drm]
 ? drm_mode_gamma_set_ioctl+0x157/0x1a0 [drm]
 ? drm_atomic_set_property+0x9b0/0x9b0 [drm]
 drm_ioctl_kernel+0x86/0xd0 [drm]
 ? __switch_to_asm+0x35/0x70
 drm_ioctl+0x1e4/0x370 [drm]
 ? drm_atomic_set_property+0x9b0/0x9b0 [drm]
 ? __switch_to_asm+0x41/0x70
 ? __switch_to_asm+0x35/0x70
 ? __switch_to_asm+0x41/0x70
 ? __switch_to_asm+0x35/0x70
 ? __switch_to_asm+0x41/0x70
 ? __switch_to_asm+0x35/0x70
 ? __switch_to_asm+0x41/0x70
 do_vfs_ioctl+0x437/0x630
 ? __schedule+0x2cf/0x8b0
 ksys_ioctl+0x5e/0x90
 __x64_sys_ioctl+0x16/0x20
 do_syscall_64+0x60/0x120
 entry_SYSCALL_64_after_hwframe+0x49/0xbe
RIP: 0033:0x7fc113af87a7
Code: 00 00 90 48 8b 05 f1 86 0c 00 64 c7 00 26 00 00 00 48 c7 c0 ff ff ff ff c3 66 2e 0f 1f 84 00 00 00 00 00 b8 10 00 00 00 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d c1 86 0c 00 f7 d8 64 89 01 48
RSP: 002b:00007ffcca607ce8 EFLAGS: 00000246 ORIG_RAX: 0000000000000010
RAX: ffffffffffffffda RBX: 00007ffcca607d30 RCX: 00007fc113af87a7
RDX: 00007ffcca607d30 RSI: 00000000c03864bc RDI: 000000000000000c
RBP: 00000000c03864bc R08: 000055bb7746ce20 R09: 000055bb774b4340
R10: 0000000000000002 R11: 0000000000000246 R12: 000055bb7746ce20
R13: 000000000000000c R14: 000055bb76858fc0 R15: 000055bb769ae3e0
---[ end trace e9661e24b2fe9b85 ]---
Comment 1 Takashi Iwai 2019-07-06 06:58:57 UTC
Just to be sure, you don't install xf86-video-intel, right?
Comment 2 Vincent Untz 2019-07-06 11:48:51 UTC
(In reply to Takashi Iwai from comment #1)
> Just to be sure, you don't install xf86-video-intel, right?

This package is not installed, indeed.
Comment 3 Stefan Dirsch 2019-07-09 14:13:29 UTC
Please attach also /var/log/Xorg.0.log
Comment 4 Vincent Untz 2019-07-10 06:24:41 UTC
Created attachment 809919 [details]
gdm-x-session logs after the error

(In reply to Stefan Dirsch from comment #3)
> Please attach also /var/log/Xorg.0.log

I don't have the full Xorg logs from that session anymore, but I can find this in /var/log/messages just after the kernel errors.
Comment 5 Vincent Untz 2019-07-10 06:27:36 UTC
Created attachment 809920 [details]
gdm-x-session logs before the error

This seems to be the logs before the error (from a rotated /var/log/messages)
Comment 6 Stefan Dirsch 2019-07-10 12:58:57 UTC
Kabylake obviously ...

2019-07-05T10:06:29.230571+02:00 sainte-consorce /usr/lib/gdm/gdm-x-session[2079]: (--) PCI:*(0@0:2:0) 8086:5917:1028:081a rev 7, Mem @ 0xeb000000/16777216, 0xa0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072

-->

#define INTEL_KBL_GT2_IDS(info) \
        INTEL_KBL_ULT_GT2_IDS(info), \
        INTEL_KBL_ULX_GT2_IDS(info), \
        INTEL_VGA_DEVICE(0x5917, info), /* Mobile GT2 */ \
Comment 7 Takashi Iwai 2019-07-10 13:31:45 UTC
TW is going to move to 5.2 kernel soon in anyway, so please check whether the problem persists with it (or just test the latest kernel in OBS Kernel:stable repo).
Comment 8 Vincent Untz 2019-08-10 20:49:49 UTC
Created attachment 813621 [details]
Error with kernel 5.2.2-1-default

I had the same issue today again, with kernel 5.2.2 :/ See attachment.
Comment 9 Jiri Slaby 2019-11-01 10:20:51 UTC
(In reply to Vincent Untz from comment #8)
> I had the same issue today again, with kernel 5.2.2 :/ See attachment.

It would be best to move this to fdo as it is likely an upstream bug:
https://bugs.freedesktop.org/enter_bug.cgi?product=DRI&component=DRM/Intel
Comment 10 Stefan Dirsch 2020-01-17 13:50:51 UTC
(In reply to Jiri Slaby from comment #9)
> (In reply to Vincent Untz from comment #8)
> > I had the same issue today again, with kernel 5.2.2 :/ See attachment.
> 
> It would be best to move this to fdo as it is likely an upstream bug:
> https://bugs.freedesktop.org/enter_bug.cgi?product=DRI&component=DRM/Intel

Right. Vincent, could you please do so or at least give current kernel and TW a try?
Comment 11 Vincent Untz 2020-01-18 15:41:39 UTC
(In reply to Stefan Dirsch from comment #10)
> Right. Vincent, could you please do so or at least give current kernel and
> TW a try?

I'm on TW, and still have some issues from time to time, although I'm unclear if this is the same bug. I'll pay attention to it next time it happens.
Comment 12 Jiri Slaby 2020-02-06 07:56:08 UTC
I started having the same problem with dell 7280+wd15. I don't see the kernel errors, only the monitor does not wake up either from suspend to ram or from simple dpms. I reported it upstream here:
https://gitlab.freedesktop.org/drm/intel/issues/1020
Comment 13 Miroslav Beneš 2021-12-31 12:44:21 UTC
Still a problem? Some time has passed meanwhile... the upstream does not seem to care. At least in the original bug. There has been a development in linked #1900. Still not solved?
Comment 14 Vincent Untz 2022-01-03 12:09:29 UTC
(In reply to Miroslav Beneš from comment #13)
> Still a problem?

I don't have that hardware anymore, so can't tell for my case.
Comment 15 Miroslav Beneš 2022-01-03 12:39:35 UTC
Ok, let's close then.