Bug 1141522 - (CVE-2019-13602) VUL-0: CVE-2019-13602: vlc: An Integer Underflow in MP4_EIA608_Convert() in modules/demux/mp4/mp4.c allows remote attackers to cause a denial of service (heap-based buffer overflow and crash)
(CVE-2019-13602)
VUL-0: CVE-2019-13602: vlc: An Integer Underflow in MP4_EIA608_Convert() in m...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 15.0
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/237119/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-15 15:29 UTC by Wolfgang Frisch
Modified: 2019-12-11 15:13 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Frisch 2019-07-15 15:29:50 UTC
CVE-2019-13602

An Integer Underflow in MP4_EIA608_Convert() in modules/demux/mp4/mp4.c in
VideoLAN VLC media player through 3.0.7.1 allows remote attackers to cause a
denial of service (heap-based buffer overflow and crash) or possibly have
unspecified other impact via a crafted .mp4 file.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-13602
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-13602
http://www.cvedetails.com/cve/CVE-2019-13602/
https://git.videolan.org/?p=vlc.git;a=commit;h=b2b157076d9e94df34502dd8df0787deb940e938
https://git.videolan.org/?p=vlc.git;a=commit;h=8e8e0d72447f8378244f5b4a3dcde036dbeb1491
Comment 1 Dominique Leuenberger 2019-07-31 07:41:13 UTC
CVE-2019-13615 is not a VLC bug, but a libebml < 1.3.6 issue
Comment 2 Dominique Leuenberger 2019-07-31 07:44:36 UTC
(In reply to Dominique Leuenberger from comment #1)
> CVE-2019-13615 is not a VLC bug, but a libebml < 1.3.6 issue

True, but this bug is CVE-2019-13602 (wrong bug reassigneD)
Comment 3 Swamp Workflow Management 2019-07-31 09:00:28 UTC
This is an autogenerated message for OBS integration:
This bug (1141522) was mentioned in
https://build.opensuse.org/request/show/719998 15.1 / vlc
https://build.opensuse.org/request/show/719999 15.0 / vlc
Comment 4 Swamp Workflow Management 2019-08-08 19:10:36 UTC
openSUSE-SU-2019:1840-1: An update that fixes 7 vulnerabilities is now available.

Category: security (important)
Bug References: 1118586,1138354,1138933,1141522,1142161,1143547,1143549
CVE References: CVE-2018-19857,CVE-2019-12874,CVE-2019-13602,CVE-2019-13962,CVE-2019-5439,CVE-2019-5459,CVE-2019-5460
Sources used:
openSUSE Leap 15.1 (src):    vlc-3.0.7.1-lp151.6.3.1
Comment 5 Swamp Workflow Management 2019-08-15 13:15:09 UTC
openSUSE-SU-2019:1897-1: An update that fixes 7 vulnerabilities is now available.

Category: security (important)
Bug References: 1118586,1138354,1138933,1141522,1142161,1143547,1143549
CVE References: CVE-2018-19857,CVE-2019-12874,CVE-2019-13602,CVE-2019-13962,CVE-2019-5439,CVE-2019-5459,CVE-2019-5460
Sources used:
openSUSE Backports SLE-15-SP1 (src):    vlc-3.0.7.1-bp151.5.3.3
Comment 6 Swamp Workflow Management 2019-08-15 13:20:06 UTC
openSUSE-SU-2019:1909-1: An update that solves 7 vulnerabilities and has three fixes is now available.

Category: security (important)
Bug References: 1093732,1094893,1118586,1133290,1138354,1138933,1141522,1142161,1143547,1143549
CVE References: CVE-2018-19857,CVE-2019-12874,CVE-2019-13602,CVE-2019-13962,CVE-2019-5439,CVE-2019-5459,CVE-2019-5460
Sources used:
openSUSE Leap 15.0 (src):    libaom-1.0.0-lp150.2.1, vlc-3.0.7.1-lp150.8.1
Comment 7 Swamp Workflow Management 2019-08-26 19:11:38 UTC
openSUSE-SU-2019:2015-1: An update that solves 7 vulnerabilities and has three fixes is now available.

Category: security (important)
Bug References: 1093732,1094893,1118586,1133290,1138354,1138933,1141522,1142161,1143547,1143549
CVE References: CVE-2018-19857,CVE-2019-12874,CVE-2019-13602,CVE-2019-13962,CVE-2019-5439,CVE-2019-5459,CVE-2019-5460
Sources used:
openSUSE Backports SLE-15 (src):    libaom-1.0.0-bp150.2.1, vlc-3.0.7.1-bp150.2.6.1
Comment 8 Dominique Leuenberger 2019-12-11 15:13:27 UTC
Update has been released