Bug 1155938 - System crash caused by i915 driver
System crash caused by i915 driver
Status: RESOLVED NORESPONSE
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-11-05 15:13 UTC by Martin Doucha
Modified: 2022-01-03 12:47 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
tiwai: needinfo? (martin.doucha)


Attachments
kernel log of the crash (2.54 MB, text/plain)
2019-11-05 15:13 UTC, Martin Doucha
Details
kernel log of the crash (20.34 KB, text/plain)
2019-11-05 15:20 UTC, Martin Doucha
Details
Corrected kernel log (139.19 KB, text/plain)
2019-11-05 15:37 UTC, Martin Doucha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Doucha 2019-11-05 15:13:50 UTC
Created attachment 823409 [details]
kernel log of the crash

My laptop repeatedly crashes because of bug in i915 driver.

My HW setup:
- Dell Latitued 7490
- Dell Dock WD15 docking station
- 2 monitors connected to docking station (1 via DisplayPort, 1 via HDMI-to-DVI adapter)

Events leading up to the crash:
At 15:30:39 (according to the log), my laptop lost connection to the network adapter in the docking station (but not the whole docking station). At 15:30:45, I've disconnected the docking station cable and plugged it back in to reset the network adapter. This also disconnected both external monitors and they didn't turn back on after reconnecting the docking station. Instead, the system froze and the Caps Lock LED started flashing.
Comment 1 Martin Doucha 2019-11-05 15:20:47 UTC
Created attachment 823410 [details]
kernel log of the crash

Sorry, I've uploaded a log with data unrelated to the crash. Here's a shorter version.
Comment 2 Takashi Iwai 2019-11-05 15:28:15 UTC
They are no real crash but rather kernel warnings with stack traces.  It's not good, but it's not the direct cause of the kernel panic you faced in the later stage (complete freeze with the LED flushing).

It's not clear whether the kernel panic is from the i915 stuff.  Is the problem reproducible?  If yes, please set up kdump and try to capture the crash.
Comment 3 Martin Doucha 2019-11-05 15:37:54 UTC
Created attachment 823411 [details]
Corrected kernel log

Sorry again, a piece of the log with a second i915 trace was missing. I've reuploaded the kernel log, this time from boot all the way to the crash.
Comment 4 Takashi Iwai 2019-11-05 15:47:13 UTC
No worry.  But through quick skimming, they are again merely kernel warnings and don't indicate the real crash.  It might lead to the blank screen, but it shouldn't be the cause of the complete hang up.

Again, if you can reproduce, please try to get the kdump -- at least the dmesg output that shows the dying message.
Comment 5 Martin Doucha 2019-11-05 15:49:45 UTC
I'll set up kdump and provide more info. I get this kind of crash about twice a month.
Comment 6 Miroslav Beneš 2020-03-24 12:45:21 UTC
This looks exactly like issues I had with 5.3 i915 driver on my Intel NUC. Should be fixed at least in the current 5.5.*.

Martin, could you confirm the issue is gone with the current kernel?
Comment 7 Martin Doucha 2020-03-24 13:13:18 UTC
I can't confirm it while I'm on home office because I didn't bring my docking station with me. I'll get back to you when things return to normal.
Comment 8 Miroslav Beneš 2021-12-31 12:21:50 UTC
Martin, I suppose nothing has changed on the home office situation since March 2020.
Comment 9 Martin Doucha 2022-01-03 12:47:32 UTC
Yes, I'm still on home office without the docking station. Let's close this for now and I'll reopen it if the same issue turns up later when I'm back in the office.