Bug 1158190 - missing keyboard & mouse events ...
missing keyboard & mouse events ...
Status: RESOLVED NORESPONSE
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Kernel
Leap 15.1
Other Other
: P5 - None : Critical (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-12-02 14:16 UTC by Michael Meeks
Modified: 2021-12-31 13:05 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
tiwai: needinfo? (mmeeks)


Attachments
hwinfo in case it helps (1.23 MB, text/plain)
2019-12-02 14:17 UTC, Michael Meeks
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2019-12-02 14:16:08 UTC
I've been suffering terrible keyboard (and some mouse) input with 15.1. My machine is ~constantly under some sort of load, and the K/B response iss terrible. I routinely get omitted key-presses, very often I lose modifiers - so editing in emacs I get 'f's and 'b's as the 'Alt' is dropped: these are often whn I'm trying to jump words to edit the missing / duplicated characters that didn't get entered. Switching virtual desktops is even wose - <ctrl><alt><arrow> keys frequenly fail to do much. I type rather quickly, but even so - hving to go back and edit amot everything I type [ ok, so I gave up here ;-], is hyper-annoying.

Worse - it is a the threshold that it could jut be a c omeetence problem [ perhaps I did't press the kys ? ] - but certainly I didn't type 'ee' twice adjacently in competence but a 'p' then an 'e' just above etc. etc. Somtimes I get doubled or even trippled letters arriving too at random.

Anyhow - it's slowly driving me up the wall ;-) I've tried the very latest suse kernel snapshots and no joy. I've used 'evdev' to trace the events and am missing events for the keystrokes.

The problem recurs on the console as well - so, X / Wayland seem to be unrelated. I'm buying a new H/W keyboard for my Dell 7559 - but since this used to work reasonably nicely in the past, I'm fairly sure it's a S/W problem.

Advice much appreciated - is there a good/easy way of testing a old eg. openSUSE 42.X kernel on this 15.1 machine somehow ? =)

What else can I do to debug what the kernel is up to ? =)

Thanks.
Comment 1 Michael Meeks 2019-12-02 14:17:00 UTC
Created attachment 825274 [details]
hwinfo in case it helps
Comment 2 Takashi Iwai 2019-12-02 15:47:48 UTC
For clearing ambiguous points:

- This is about the laptop built-in keyboard, right?

- Does this happen with the external USB keyboard as well?


And, suppose that it's specific to built-in keyboard.  It's i8042, and the code has been always there.  So the question is whether it's a kernel regression or not.

For checking that, first off, prepare the minimal test setup, e.g. boot without X (runlevel 3), and test on Linux console with evtest.

Once after we get the test environment, install older kernels (Leap 15.0, Leap 42.x, etc) on the system and test with it.

You can simply install it via
  zypper in --oldpackage kernel-default.rpm
and ignore the warning about signature, then choose the old kernel from GRUB menu.

But it'd be safer to increase the number of installable kernels before doing that; edit /etc/zypp/zypp.conf and add more entries for multiversion.kernels line, e.g.
  multiversion.kernels = latest,latest-1,latest-2,latest-3,running

After testing, you can uninstall the old kernel again, and that's done.
Comment 3 Michael Lanczak 2019-12-02 19:57:40 UTC
Your intention is correct! My previous SuseLinux version was Leap 42.3. I remember me, an upgrade(!) from this version to Leap 15.1 runs Leap 15.1 perfect. Seeming runs this upgrade version 15.1 with the kernel of Leap 42.3. You should test it!
Comment 4 Michael Meeks 2019-12-05 13:40:51 UTC
Sounds good - I re-boot rather infrequently, but let me try with the openSUSE 43.2 kernel if I can.

I tested like this:

BOOT_IMAGE=/boot/vmlinuz-5.3.11-1.g0a195a8-default root=UUID=d7f1d717-d6ec-45da-a33a-442675474609 quiet splash showopts nopt acpi_backlight=vendor acpi_osi= i8042.debug i8042.nomux i8042.reset=Y

and beyond spamming syslog amazingly, there was nothing better about life =)
Comment 5 Michael Meeks 2019-12-05 17:02:02 UTC
Interesting the latest (?) 42.3 kernel:

Linux dell.home 4.4.180-102-default #1 SMP Mon Jun 17 13:11:23 UTC 2019 (7cfa20a) x86_64 x86_64 x86_64 GNU/Linux

is also showing the problem; hmm.
Comment 6 Takashi Iwai 2019-12-05 17:52:46 UTC
Then try downgrading further to Leap 42.3 GM kernel -- I suppose it had worked certainly for you in the past?

I somehow suspect it might be something in a lower level.  Can you take a look at BIOS setup, e.g. disabling the Intel MEI (or whatever called the control console thingy)?
Comment 7 Michael Lanczak 2019-12-05 20:22:21 UTC
I remember me, after upgrading of Leap 42.3 to version 15.1 all runs perfect. Then I had done a system safe of the root partition (sda2) from this upgrade, but not safed the boot partition (sda1). After some time I installed Leap 15.1. new complete. Then I got this described problems with keyboard and mouse inputs laming and delaying. 
Now I recovered my upgraded (Leap 42.3 to 15.1) system safing (sda2), start the system new and all blocks in the boot sector by started GRUB, starting was not possible! So I came to the result, that in Leap 15.1. anything was changed in the bootsector in GRUB. 
I recommend, first try installing the previous boot sector GRUB from Leap 42.3 .
Comment 8 Michal Suchanek 2019-12-05 21:34:29 UTC
You need the bootsector that corresponds to the grub installed on your system.
Comment 9 Takashi Iwai 2019-12-06 10:37:35 UTC
Then it might it be some difference of boot option that is gone by some reason?  e.g. any reason of passing acpi_osi option with the empty string?
Comment 10 Michael Lanczak 2019-12-06 11:42:15 UTC
I suppose, that there are some difference of boot option between Leap 42.3 and 15.1 . More I can't say at this moment, I got not more information, since the booting process stopped by my experiment.
Comment 11 Michael Lanczak 2019-12-12 21:33:26 UTC
I have done following experiments: 

First I updated my second Linux-OS UBUNTU in my computer with her specific bootsystem GRUB. That runs without problems and it runs OpenSuse Leap, but the started OpenSuse Leap 15.1. have the same described problems. 

Next I downloaded the 'OpenSuse Leap 15.1.Live' from openSuse and installed it on an USB-stick. Now I start this Live-version and was astonished, that Leap 15.1.Live runs without any problems!

Here we must inspect the difference between Leap 15.1.Live and the full installed version Leap 15.1. Any package or element troubles here. 

If nothing goes and all fails, Leap 15.1. must rebuild new complete, element for element and package for package and test it. 
It's large work, I know, but it is the last possibility...
Comment 12 Takashi Iwai 2019-12-12 22:22:58 UTC
Did you try to boot the system with the very same kernel boot options as done with the (good working) live system?  Of course, some additional package might influence something, but about PS2 keyboard, it's rather a direct kernel stuff, so the influence must be limited.

So, at most, either the power-saving stuff or any additional kernel tuning.  But the first suspect is always the kernel boot option, and module configs.
Comment 13 Michael Lanczak 2019-12-13 21:26:23 UTC
The booting of the good working live system is undepended from the Linux installed kernel boot. 
You start it with the BIOS before GRUB, choosing the boot medium like bootable(!) hard disks, CD's or DVD's, several external disks or USB-stick, which starts automatically. I installed and started successfully Leap 15.1 Live by an USB-stick.
Comment 14 Michal Suchanek 2019-12-13 22:10:35 UTC
however, you can look what kernel version and what kernel parameters are used in the live system and try to replicate that on your installed system.
Comment 15 Michael Lanczak 2019-12-16 21:50:14 UTC
I see in Leap 15.1 two kernels in /boot (I hope it's correct): 
1) vmlinuz-,initrd-,config-,sysctl.conf-,System.map- 4.12.14-lp151.28.32 and 2) vmlinuz ....4.12.14-lp151.28.36  . 
In Leap Live I see only one kernel: 
config-,sysctl.conf-,system.map-4.12.14-lp151.28.16 and 4.12.14-lp151.28.16-default .
Why? 

By the way: You can download Leap Live by https://software.opensuse.org
Comment 16 Michael Lanczak 2020-01-10 14:29:17 UTC
I installed kernel 4.12.14-lp151.28.16 of Leap Live, but is has no effect, the problems are the same.
Comment 17 Miroslav Beneš 2020-04-27 11:49:11 UTC
Michael (Meeks), have you managed to test 42.3 GM kernel as Takashi asked? Also, if I understand comment 4 correctly, some of those debug options solved the problem. Correct? Have you tried to narrow it down to one of them?
Comment 18 Miroslav Beneš 2020-08-28 13:09:51 UTC
No response, closing.
Comment 19 Miroslav Beneš 2021-12-31 13:05:34 UTC
Closing.