Bug 1159263 - [Build 20191214] Yast modules: Window title seems to contain trailing whitespaces
[Build 20191214] Yast modules: Window title seems to contain trailing whitesp...
Status: CONFIRMED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://openqa.opensuse.org/tests/111...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-12-16 08:59 UTC by Dominique Leuenberger
Modified: 2022-10-26 15:24 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2019-12-16 08:59:23 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-yast2_gui@64bit fails in
[yast2_lang](https://openqa.opensuse.org/tests/1114514/modules/yast2_lang/steps/13)

The window title is not centered, and also in the GNOME TopBar, the window name is indicating that it continues with a lot of spaces behind the actual name


## Test suite description
Maintainer: zluo, riafarov

Test for yast2 UI, GUI only. Running on created gnome images which provides both text console for ncurses UI tests as well as the gnome environment for the GUI tests.

Temporarily added YAST2_GUI_TERMINATE_PREVIOUS_INSTANCES to see if helps. This variable triggers code which terminates all yast2 processes before starting new one. (see poo#26104).


## Reproducible

Fails since (at least) Build [20191211](https://openqa.opensuse.org/tests/1111241)


## Expected result

Last good: [20191210](https://openqa.opensuse.org/tests/1109911) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=DVD&machine=64bit&test=yast2_gui&version=Tumbleweed)
Comment 1 Stefan Hundhammer 2019-12-16 09:54:41 UTC
Indeed. When I start that module on my Xfce4 desktop (based on X11) and invoke "xprop" on it, I get this:

...
WM_CLASS(STRING) = "YaST2", "YaST2 - language @ g12                          "
...
WM_CLASS(STRING) = "YaST2", "YaST2 - language @ g12                          "
...

(actually more space characters before the closing quote; reformatted for readability here in Bugzilla)

Those X properties on the outer window manager frame window indicates that this is what we set as a window title.
Comment 28 Oliver Kurz 2021-03-10 06:05:16 UTC
This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: yast2_gui
https://openqa.opensuse.org/tests/1317534

To prevent further reminder comments one of the following options should be followed:
1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
2. The openQA job group is moved to "Released"
3. The label in the openQA scenario is removed
Comment 29 Dominique Leuenberger 2022-10-26 15:24:34 UTC
https://openqa.opensuse.org/tests/2835264#step/yast2_lang/13

Looking at the top panel in GNOME, this issue seems still to be valid