Bug 1159767 - Bluetooth device sometimes vanishes after booting Tumbleweed - needs BIOS on/off cycle to come back
Bluetooth device sometimes vanishes after booting Tumbleweed - needs BIOS on/...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-12-24 22:59 UTC by robert spitzenpfeil
Modified: 2021-12-31 12:50 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
oneukum: needinfo? (rs.opensuse)


Attachments
lsusb with comment (414 bytes, text/plain)
2019-12-24 23:00 UTC, robert spitzenpfeil
Details
lsusb -v (41.78 KB, text/plain)
2019-12-24 23:00 UTC, robert spitzenpfeil
Details
lspci (10.30 KB, text/plain)
2019-12-24 23:01 UTC, robert spitzenpfeil
Details
lsmod (5.91 KB, text/plain)
2019-12-24 23:01 UTC, robert spitzenpfeil
Details
lshw (17.65 KB, text/plain)
2019-12-24 23:01 UTC, robert spitzenpfeil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description robert spitzenpfeil 2019-12-24 22:59:37 UTC
User-Agent:       Mozilla/5.0 (X11; Linux i686 on x86_64; rv:68.0) Gecko/20100101 Firefox/68.0
Build Identifier: 

Hardware: Lenovo V340-IWL, i5-8265U, 8GB RAM, NVME, Qualcomm / Atheros WiFi / BT

Reference: PartedMagic Live (5.2.9)


WiFi / BT just work with PartedMagic. With the latest TW 2019-12-21 WiFi works, but the BT device vanishes after every single boot and does not come back until I disable WLAN in the BIOS, reboot, enable WLAN in the BIOS.

PartedMagic does not "kill" the BT device at all.

Could it be that some Firmware setting kills BT ?

Reproducible: Always

Steps to Reproduce:
1. "fix" BT / WLAN in the BIOS
2. Boot TW
3. BT device gone until Step 1.
Comment 1 robert spitzenpfeil 2019-12-24 23:00:10 UTC
Created attachment 826714 [details]
lsusb with comment
Comment 2 robert spitzenpfeil 2019-12-24 23:00:45 UTC
Created attachment 826715 [details]
lsusb -v
Comment 3 robert spitzenpfeil 2019-12-24 23:01:03 UTC
Created attachment 826716 [details]
lspci
Comment 4 robert spitzenpfeil 2019-12-24 23:01:22 UTC
Created attachment 826717 [details]
lsmod
Comment 5 robert spitzenpfeil 2019-12-24 23:01:47 UTC
Created attachment 826718 [details]
lshw
Comment 6 robert spitzenpfeil 2019-12-24 23:20:35 UTC
I need to do some more testing.

So for now I'll claim "sometimes" with TW, never with PartedMagic as the frequency of occurrence of this problem.
Comment 7 Oliver Neukum 2020-01-13 11:55:49 UTC
Please attach dmesg with PartedMagic and dmesg of a TW boot which detects it and the subsequent failing boot.
Comment 8 robert spitzenpfeil 2020-04-10 18:05:46 UTC
Updating said machine to latest TW & testing again.

Lenovo has released a new BIOS, but unfortunately they only provide the flash utility for the MS stuff, so that won't happen any time soon.
Comment 9 robert spitzenpfeil 2020-04-10 18:07:02 UTC
If anybody knows how to get this stuff running with a WinPE USB stick, that would be great. Tried the X86 and AMD64 versions, doesn't run the .exe :-(
Comment 10 robert spitzenpfeil 2020-04-10 18:33:17 UTC
Well, that didn't help. Bluethooth still doesn't start.

rfkill shows:

---
0 wlan ...
1 bluetooth ideapad_bluetooth unlocked unlocked
2 wlan phy0
---

/sys/class/bluetooth doesn't exist

syslog: systemd: Condition check resulted in Bluetooth service being skipped


Once I have physical access again, I will make further tests.
Comment 11 Miroslav Beneš 2020-07-30 11:31:20 UTC
Robert, any luck? TW is also on 5.7.x kernel now.

And Oliver asked for dmesgs both from TW and PartedMagic if you can provide them, please.
Comment 12 robert spitzenpfeil 2020-07-30 12:12:51 UTC
So far I haven't visited my far away relatives. They're not computer savvy, the laptop is just a "black box" for them. I can't expect them to do a lot of rebooting and debugging via a phone call. I can log into their machine, but then there's the Bluetooth headphone ... too many variables. Of course it doesn't have ILO / IPMI either. This is an on-site job.

There are 2 BIOS updates pending. Unfortunately Lenovo requires Windows for BIOS updates in their consumer grade laptops. Maybe W10-to-go on a USB-stick will help there ... I'll find out.

I will report back after I've made the trip and hopefully made all of the updates happen. Sorry for the delay.
Comment 13 robert spitzenpfeil 2020-07-30 12:16:03 UTC
As the BT adapter is connected via USB, I will try the same thing as on my other laptop, i.e. I will disable LPM on that laptop. Maybe this helps in this case as well - if I'm lucky.

For reference: https://bugzilla.suse.com/show_bug.cgi?id=1174017
Comment 14 Miroslav Beneš 2021-12-31 12:16:01 UTC
Robert, any news here?
Comment 15 robert spitzenpfeil 2021-12-31 12:50:41 UTC
During Xmas holidays I updated the BIOS to the latest version available from Lenovo (ATCN45WW) + TW updates.

It seems to work now.