Bug 1161843 - Screen flickering on latest Dell XPS 7390 with kernel: [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
Screen flickering on latest Dell XPS 7390 with kernel: [drm:intel_cpu_fifo_un...
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
https://gitlab.freedesktop.org/drm/in...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-26 17:10 UTC by Sébastien POHER
Modified: 2020-10-29 08:07 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sébastien POHER 2020-01-26 17:10:17 UTC
# Hardware

Latest (nov 2019) Dell XPS 7390 with Intel i915 chipset

# Kernel

5.4.10-1-default (OS Tumbleweed up to date)
(same behavior was noticed with the 5.3.x kernels)

# Relevant outputs

## lspci

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics (rev 02)

## lshw

        *-display
             description: VGA compatible controller
             product: UHD Graphics
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             logical name: /dev/fb0
             version: 02
             width: 64 bits
             clock: 33MHz
             capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
             configuration: depth=32 driver=i915 latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
             resources: iomemory:600-5ff iomemory:400-3ff irq:139 memory:604a000000-604affffff memory:4000000000-400fffffff ioport:3000(size=64) memory:c0000-dffff

## /proc/cmdline

BOOT_IMAGE=/boot/vmlinuz-5.4.10-1-default root=UUID=55518547-6da3-4579-bdad-ecf3dbee0de4 splash=silent resume=/dev/disk/by-id/nvme-PC601_NVMe_SK_hynix_512GB_AD9BN4767124YBC32-part3 mitigations=auto quiet

# Description

From time to time, the screen flickers, freezes and goes back to normal. The following message can be seen in the journal:

kernel: [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

Sometimes this problem leads to the computer being unusable, the screen does not return to a normal state and switching to another TTY via Ctrl+Alt+Fx does not work.
When the computer exits from sleep, the same behavior can be observed, the login screens' (provided by GDM in my case) colors are messed up.

This affects only the build-in screen in my case. Even if an external monitor is connected it does not seem to be affected so far.

# Possibly related bugs

https://bugzilla.opensuse.org/show_bug.cgi?id=1156254
https://bugzilla.opensuse.org/show_bug.cgi?id=1132926

Please let me know if I can help by providing further information or testing some kernel options.
Comment 1 Frank Krüger 2020-01-26 17:40:13 UTC
Given the reports on screen flickering with XPS 13 7390 at https://www.dell.com/community/XPS/Screen-flickering-on-XPS-13-7390-Ubuntu/m-p/7430121, it seems that for some the issue is solved with kernel version >= 5.4.13. So, you might give the kernel from https://download.opensuse.org/repositories/Kernel:/stable/standard/ a try.
Comment 2 Frank Krüger 2020-01-26 18:05:54 UTC
(In reply to Sébastien POHER from comment #0)
> # Hardware
> 
> Latest (nov 2019) Dell XPS 7390 with Intel i915 chipset
> 
> # Kernel
> 
> 5.4.10-1-default (OS Tumbleweed up to date)
> (same behavior was noticed with the 5.3.x kernels)

By the way, current TW20200124 has kernel version 5.4.13.
Comment 3 Sébastien POHER 2020-01-26 18:46:22 UTC
Hi,
Thank you for the quick reply.
I prepared my bug report this Friday but could no post it because of some issues with the access management system [0].
I just saw that some updates where available and I am on 5.4.13-1 now but had this error once already. I will try do disable adaptive screen brightness as mentioned in the Dell support link you have posted as well as with the very latest kernel build from the Kernel:stable repo.

Regards,

[0] https://progress.opensuse.org/issues/62654
Comment 4 Takashi Iwai 2020-01-27 08:09:23 UTC
The latest Kernel:stable contains an i915 fix on top of 5.4.14, and this might work for you.  Meanwhile this fix might cause another issue on another i915 models, so it seems a bit uncertain.
So the early test report would be appreciated.  Thanks.
Comment 5 Sébastien POHER 2020-01-27 12:16:58 UTC
Thank you for your answer. Just upgraded to the latest kernel stable as well as firmwares:

- kernel: 5.4.14-1.1.gfc4ea7a
- kernel-firmware-i915: 20200114-35.1

A few minutes after login in, the issue happended again with the same message in 'dmesg' output.
When I woke up the laptop from sleep, the colors of GDM were still messed up but they went back to normal instantaneously.
I can not find a pattern in things that I am doing when the flickers happend, this time I was browsing a simple web page, this morning I was using Vim in a terminal emulator (the issue blocked the computer, I had to close the lid to put it to sleep and the screen was back to normal when it woke up).

If relevant, the default refresh rate of the screen is 60.03 Hz. Available rates are 59.96 Hz and 48.03 Hz.

Is there any other information about hardware or settings that I may provide to help sorting this out ?

I have seen on the Web that this kind of issue with the same output as already happened in previous kernel releases. Some threads provide boot option to pass, so far I have tried:

intel_idle.max_cstate=4

without success (https://bugs.freedesktop.org/show_bug.cgi?id=103229#c20).
Comment 6 Takashi Iwai 2020-01-27 13:03:24 UTC
Thanks.  The latest fix in stable branch turned out to be broken, so in anyway you can forget the test with that.  Sorry for inconvenience.

Meanwhile, the stable branch already moved to 5.5 kernel, and the build in tomorrow should contain that.  So please give it a try with 5.5 kernel later.
If the problem is still found with that kernel, we need to report to upstream at first.
Comment 7 Sébastien POHER 2020-01-28 07:19:53 UTC
Thank you for your help.
In the meantime, yesterday, during a few hours, I have tried (while running kernel 5.4.14) to use the non-default refresh rate (59.96 Hz instead of 60.03 Hz) and it seemed to improve things.
I will try will latest 5.5 kernel as soon as it is available and test it in different conditions with both refresh rates and report it back here.
Comment 8 Sébastien POHER 2020-01-29 20:45:30 UTC
I updated the kernel yesterday to 5.5. Since then problem of flickering happened only once, very briefly and without much impact on the display, I barely noticed it.
So far the situation is way better than before so I will a few more days just to be sure and mark this bug as resolved.
Comment 9 Sébastien POHER 2020-02-03 21:02:04 UTC
I though the problem was solved but it happened again right now:

[Mon Feb  3 21:55:05 2020] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

Spotify app, installed via Flatpak, was starting when the screen went all messed up (i.e. the entire screen). I hit the Super key to restore the normal state.
Comment 10 Takashi Iwai 2020-02-04 16:05:51 UTC
Well, then it's high time: care to report it to upstream?
Feel free to put me (tiwai@suse.de) to Cc.  Thanks.
Comment 11 Sébastien POHER 2020-02-04 19:58:04 UTC
Done:
https://bugzilla.kernel.org/show_bug.cgi?id=206417
Thank you.
Comment 12 Takashi Iwai 2020-02-05 09:37:00 UTC
The DRM people are now using gitlab.freedesktop.org for bug tracking.
Could you report rather to
  https://gitlab.freedesktop.org/drm/intel/issues
?
Comment 13 Sébastien POHER 2020-02-05 20:28:10 UTC
My bad, I though bugzilla.kernel.org would be appropriate, should I close it with a link on the Intel DRM Gitlab ?

Here is the bug report:

https://gitlab.freedesktop.org/drm/intel/issues/1145
Comment 14 Miroslav Beneš 2020-10-27 15:16:56 UTC
Sebastien, TW is now on 5.8 kernel (and 5.9 coming soon). I wonder if anything has improved. The upstream report has not got any relevant update unfortunately.
Comment 15 Sébastien POHER 2020-10-28 20:12:42 UTC
(In reply to Miroslav Beneš from comment #14)
> Sebastien, TW is now on 5.8 kernel (and 5.9 coming soon). I wonder if
> anything has improved. The upstream report has not got any relevant update
> unfortunately.

Since kernel 5.7 (if I remember correctly) the main issue is gone (i.e no more flickers while *using* the computer), but from time to time, after waking from sleep, the login (GDM in my case) screen still has messed up colours.

At least from my point of view, this issue is (almost) solved. Should I close it?
Comment 16 Miroslav Beneš 2020-10-29 08:07:48 UTC
Thanks for the update. Let's close, since the main issue is gone. If the other problem persists, consider opening a new bug.