Bug 1163116 - kernel-pae: System does not shutdown or reboot after switching from kernel-default
kernel-pae: System does not shutdown or reboot after switching from kernel-de...
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
i686 Other
: P5 - None : Major (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-02-07 10:10 UTC by Suse User
Modified: 2022-01-28 11:35 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
journal exceprt (5.41 KB, text/plain)
2020-02-07 10:10 UTC, Suse User
Details
unedited journal (68.65 KB, text/plain)
2020-11-27 13:43 UTC, Suse User
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Suse User 2020-02-07 10:10:38 UTC
Created attachment 829616 [details]
journal exceprt

STR:

1. Install kernel-pae ( as advised in bug#1161832 )
2. Attempt a reboot or shutdown


EXPECTED:

Actual reboot or shutdown.


ACTUAL:

A text notification appears:

dracut Warning: Killing all remaining processes
Rebooting. (or "Powering off." if shutdown was requested)

and the system remains in this state without rebooting or shutting down. The system also remains connected to the network - I can ping it from another system.

To exit this state I have to power off and power on the laptop to reboot it.
After rebooting there is no journal for the previous boot, only for the current one.

Additionally during boot with kernel-pae I notice quite a few new error messages in dmesg and in journal. (attached excerpt with hidden hex addresses as I don't know if this may be sensitive info)

# uname -rvpio
5.4.14-2-pae #1 SMP Thu Jan 23 08:54:47 UTC 2020 (fc4ea7a) i686 i386 GNU/Linux
Comment 1 Suse User 2020-02-16 10:16:23 UTC
Still an issue with new kernel:

# uname -rvpio
5.5.2-1-pae #1 SMP Sat Feb 8 07:54:02 UTC 2020 (994cf1f) i686 i386 GNU/Linux
Comment 2 Suse User 2020-02-23 09:48:01 UTC
The problem remains with kernel:

# uname -rvpio
5.5.4-1-pae #1 SMP Sat Feb 15 08:16:55 UTC 2020 (119f9ca) i686 i386 GNU/Linux
Comment 3 Suse User 2020-03-01 10:18:52 UTC
The problem persists:

# uname -rvpio
5.5.6-1-pae #1 SMP Mon Feb 24 09:02:31 UTC 2020 (4a830b1) i686 i386 GNU/Linux

Can anyone please provide some feedback?
Comment 4 Mark Gray 2020-03-01 11:13:51 UTC
I have had this problem on one of my 15.1 x86_64 machine ever since upgrading.

My work around is to do a "telinit 1" before doing a reboot or shutdown.

My suspicion is that the systemd dependencies for rebooting or poweroff from runlevel 5 and runlevel 3 have gotten messed up but the ones for runlevel 1 still work. (Just my 2 cents worth as a fellow sufferer)
Comment 5 Suse User 2020-03-02 18:09:11 UTC
I tried your workaround but it doesn't work for me.
Do you also get the errors I get (those attached in the initial message)?
Comment 6 Mark Gray 2020-03-02 19:01:13 UTC
No errors at all -- it just assumes that the reboot was going to work but hangs at the last message. Sorry my work around didn't work for you, must be a different problem entirely. Good luck with your problem.
Comment 7 Suse User 2020-03-08 11:37:43 UTC
Unfortunately this continues to be a problem:

5.5.7-1-pae #1 SMP Sun Mar 1 19:28:06 UTC 2020 (1004bce) i686 i386 GNU/Linux

Can anyone look into this please? This is a serious issue.
Comment 8 Miroslav Beneš 2020-06-17 13:19:49 UTC
Jiri, Takashi, any idea who could take a look?

Suse User (whoever that is), could you provide the unedited journal excerpt, please? The one attached is almost useless. BUG report must be complete.
Comment 9 Miroslav Beneš 2020-09-16 10:37:32 UTC
No response. Closing.
Comment 10 Suse User 2020-11-27 13:43:52 UTC
Created attachment 843934 [details]
unedited journal

Sorry for the late reply. I was unable to answer due to all the COVID situations etc.

Attaching an unedited journal from today. The issue remains and is really problematic. There is an upstream report for it too:

https://bugzilla.kernel.org/show_bug.cgi?id=206957
Comment 11 Suse User 2020-11-27 13:45:21 UTC
Reopening after providing fresh info.
Comment 12 Miroslav Beneš 2020-12-23 10:14:15 UTC
It looks like something fishy is happening in the wistron module. Have you tried to blacklist it as suggested in bug 1142370?

However, I am not sure it would help with the bug reported here (unsuccessful reboot or shutdown).
Comment 13 Suse User 2020-12-25 10:39:29 UTC
I tried blacklisting it right after your message here and tadaaa: No errors and reboot/power off works fine! Thank you!

Should we assume there is no bug in the kernel-pae itself but it is just the wistron module that causes problems (which IIUC is a WONTFIX)? Or should we rather rephrase this bug report or probably create a new one?
Comment 14 Takashi Iwai 2020-12-26 07:53:13 UTC
Currently wistron driver is an orphan and badly maintained, so yes, it's a WONTFIX bug for now.  We'd need to ping the input subsystem maintainer to consider either to drop or fix this stuff.
Comment 15 Miroslav Beneš 2022-01-28 11:35:57 UTC
Let me close with WONTFIX as the driver is orphaned and lack any maintenance.