Bug 1164459 - (CVE-2019-20479) VUL-0: CVE-2019-20479: apache2-mod_auth_openidc: open redirect issue exists in URLs with slash and backslash
(CVE-2019-20479)
VUL-0: CVE-2019-20479: apache2-mod_auth_openidc: open redirect issue exists i...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/253416/
CVSSv2:NVD:CVE-2019-20479:5.8:(AV:N/...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-02-20 10:28 UTC by Alexandros Toptsoglou
Modified: 2020-06-30 07:48 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandros Toptsoglou 2020-02-20 10:28:03 UTC
CVE-2019-20479

A vulnerability was found in mod_auth_openidc before version 2.4.1. An open redirect issue exists in URLs with a slash and backslash at the beginning.

Reference:
https://github.com/zmartzone/mod_auth_openidc/commit/02431c0adfa30f478cf2eb20ed6ea51fdf446be7
https://github.com/zmartzone/mod_auth_openidc/pull/453

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1805102
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-20479
Comment 1 Alexandros Toptsoglou 2020-02-20 10:28:38 UTC
Tracked SLE12-SP2 and SLE15-SP1 as affected
Comment 2 Kristyna Streitova 2020-03-04 14:22:37 UTC
|    Codestream    |   Request    |
|------------------|--------------|
| SLE12SP2         | #213193      |
| SLE15SP1         | #213195      |
| openSUSE:Leap    | via SLE      |
| openSUSE:Factory | not affected |

Done, I'm reassigning it back to the security team.
Comment 3 Swamp Workflow Management 2020-03-17 17:15:25 UTC
SUSE-SU-2020:0706-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1164459
CVE References: CVE-2019-20479
Sources used:
SUSE Linux Enterprise Server 12-SP5 (src):    apache2-mod_auth_openidc-2.4.0-3.11.1
SUSE Linux Enterprise Server 12-SP4 (src):    apache2-mod_auth_openidc-2.4.0-3.11.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 4 Swamp Workflow Management 2020-03-17 17:18:15 UTC
SUSE-SU-2020:0705-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1164459
CVE References: CVE-2019-20479
Sources used:
SUSE Linux Enterprise Module for Server Applications 15-SP1 (src):    apache2-mod_auth_openidc-2.3.8-3.7.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 5 Swamp Workflow Management 2020-03-25 14:25:24 UTC
openSUSE-SU-2020:0376-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1164459
CVE References: CVE-2019-20479
Sources used:
openSUSE Leap 15.1 (src):    apache2-mod_auth_openidc-2.3.8-lp151.2.6.1
Comment 6 Alexandros Toptsoglou 2020-06-30 07:48:48 UTC
Done