Bug 1165790 - System hung - nouveau 0000:01:00.0: plasmashell[2512]: channel 7 killed!
System hung - nouveau 0000:01:00.0: plasmashell[2512]: channel 7 killed!
Status: RESOLVED NORESPONSE
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Kernel
Leap 15.1
Other Other
: P5 - None : Major (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-03-05 10:27 UTC by Suse User
Modified: 2020-10-27 15:20 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
journal (1.91 KB, text/plain)
2020-03-05 10:27 UTC, Suse User
Details
journal (581 bytes, text/plain)
2020-03-13 15:09 UTC, Suse User
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Suse User 2020-03-05 10:27:52 UTC
Created attachment 831994 [details]
journal

While I was downloading a few torrents via qbittorrent and converting a video with ffmpeg in console suddenly the desktop became unresponsive. I could only move the mouse but pressing keys didn't have any effect.

After hardware reset I checked the journal right before the reboot (attached)
Comment 1 Takashi Iwai 2020-03-06 12:56:10 UTC
The nouveau kernel driver on Leap 15.1 is rather comparable with 4.19.y kernel, which is a bit old, and likely no chance to get any fix from nouveau upstream, unfortunately.

Still you can try to report to upstream about the issue if it's reproducible reliably, though.
Comment 2 Suse User 2020-03-09 10:07:33 UTC
> which is a bit old

If that is known why doesn't it get an update?

> reproducible reliably

I am not sure how to reproduce it actually. But this is definitely not the first time I experience a system hang due to nouveau. See bug#1139774 (I don't know if it has anything to do with the current one).
Comment 3 Takashi Iwai 2020-03-10 11:11:41 UTC
(In reply to Suse User from comment #2)
> > which is a bit old
> 
> If that is known why doesn't it get an update?

You can use the newer kernel version from OBS Kernel:stable or Kernel:HEAD repo, too.  Leap 15.1 kernel version is fixed long long time ago, and won't be newer.
Comment 4 Suse User 2020-03-10 11:50:25 UTC
> You can use the newer kernel version from OBS Kernel:stable or Kernel:HEAD repo, too.

What is the difference between the two please? Also could you provide links to the particular repos (just in case, so I don't make any mistake and use the wrong one).

> Leap 15.1 kernel version is fixed long long time ago, and won't be newer.

Why is that? Is it not anti-security not to keep kernel up to date (or at least to back port fixes from newer versions)?
Comment 5 Takashi Iwai 2020-03-10 11:56:21 UTC
(In reply to Suse User from comment #4)
> > You can use the newer kernel version from OBS Kernel:stable or Kernel:HEAD repo, too.
> 
> What is the difference between the two please? Also could you provide links
> to the particular repos (just in case, so I don't make any mistake and use
> the wrong one).

The former is based on the upstream stable branch (currently 5.5.y) while the latter is based on the latest Linus tree (currently 5.6-rc).

You can get the former from
  http://download.opensuse.org/repositories/Kernel:/stable/standard/

Guess for the latter by yourself.

> > Leap 15.1 kernel version is fixed long long time ago, and won't be newer.
> 
> Why is that? Is it not anti-security not to keep kernel up to date (or at
> least to back port fixes from newer versions)?

The *VERSION* is fixed.  You're using openSUSE Leap, and that's different from Tumbleweed, which is the rolling release.
Comment 6 Suse User 2020-03-10 12:03:17 UTC
Thanks for the link.

Re. Kernel:HEAD I found:

https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.reference/cha-tuning-multikernel.html#sec-tuning-multikernel-latest

which says:

"Warning: Installing from Kernel:HEAD May Break the System"

Do you actually recommend using this?


As for upstream stable (for which you gave the link): is it safe to stick to it long term?
Comment 7 Takashi Iwai 2020-03-10 12:53:55 UTC
(In reply to Suse User from comment #6)
> Thanks for the link.
> 
> Re. Kernel:HEAD I found:
> 
> https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.
> reference/cha-tuning-multikernel.html#sec-tuning-multikernel-latest
> 
> which says:
> 
> "Warning: Installing from Kernel:HEAD May Break the System"
> 
> Do you actually recommend using this?
> 
> 
> As for upstream stable (for which you gave the link): is it safe to stick to
> it long term?

The stable branch is more stable, obviously.  Kernel:HEAD contains "rc", a release candidate, that is still under development.
Comment 8 Suse User 2020-03-10 13:11:43 UTC
Thank you.
So after installing Kernel:stable I am getting new errors:

bug#1166242

Could you please have a look?
Comment 9 Suse User 2020-03-13 15:09:30 UTC
Created attachment 832769 [details]
journal

So... today it happened again, with latest stable kernel (journal attached):

5.5.8-3.g1538c30-default #1 SMP Wed Mar 11 09:50:08 UTC 2020 (1538c30) x86_64 x86_64
Comment 10 Miroslav Beneš 2020-06-29 13:38:40 UTC
If the issue still happens with the latest kernel in Kernel:stable (that is 5.7.x), it is time to report it upstream.
Comment 11 Miroslav Beneš 2020-10-27 15:20:15 UTC
No response. Closing.