Bug 1165912 - [Build 20200304] openQA test fails in await_install of kde live installer upgrade path - installer seems to crash (/run)
[Build 20200304] openQA test fails in await_install of kde live installer upg...
Status: NEW
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://trello.com/c/IMxqDT9s
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-03-06 10:57 UTC by Oliver Kurz
Modified: 2020-03-10 05:26 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: Yes
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Kurz 2020-03-06 10:57:34 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-KDE-Live-x86_64-kde_live_upgrade_leap_42.3@64bit-2G fails in
[await_install](https://openqa.opensuse.org/tests/1196553/modules/await_install/steps/15) in a black screen but with blinking cursor. Seems like the installer or maybe even complete plasma crashes here?

## Test suite description
Uses the live installer on the kde live media for upgrading the system.


## Reproducible

Fails since (at least) Build [20200205](https://openqa.opensuse.org/tests/1166278)


## Expected result

Last good: [20190624](https://openqa.opensuse.org/tests/967962) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=KDE-Live&machine=64bit-2G&test=kde_live_upgrade_leap_42.3&version=Tumbleweed)

Also see potentially related https://bugzilla.opensuse.org/show_bug.cgi?id=994044
Comment 1 Fabian Vogt 2020-03-06 11:03:03 UTC
Ouch - somehow YaST breaks /run, killing logind and thus breaking everything:

Mar 05 20:05:07 localhost.localdomain systemd-logind[1620]: Failed to read /var/run/utmp, ignoring: No such file or directory
Mar 05 20:05:07 localhost.localdomain systemd-logind[1620]: Assertion '*_head == _item' failed at src/libsystemd/sd-event/sd-event.c:2675, function event_inotify_data_drop(). Aborting.
Mar 05 20:05:08 localhost.localdomain systemd[1]: systemd-logind.service: Main process exited, code=dumped, status=6/ABRT
Mar 05 20:05:08 localhost.localdomain systemd[1]: systemd-logind.service: Failed with result 'core-dump'.
Mar 05 20:05:08 localhost.localdomain systemd[1]: systemd-logind.service: Scheduled restart job, restart counter is at 3.
Comment 2 Martin Vidner 2020-03-09 13:13:41 UTC
Thanks for the report!
Comment 3 Lukas Ocilka 2020-03-09 13:33:54 UTC
KDE Live installer is an unsupported and untested feature. I'm sorry guys.
Comment 4 Fabian Vogt 2020-03-09 16:11:40 UTC
It seems like having /run bind-mounted to /mnt/run can't really work - some packages do dirty stuff in their %post like reloading dbus-daemon using dbus-send, which should really not affect the inst-sys (and by that I mean both the live environment as well as installation-images).

(In reply to Lukas Ocilka from comment #3)
> KDE Live installer is an unsupported and untested feature. I'm sorry guys.
                                           ^^^^^^^^
Considering that this bug was literally found by openQA that's not really true.
Comment 5 Oliver Kurz 2020-03-10 05:26:24 UTC
(In reply to Lukas Ocilka from comment #3)
> KDE Live installer is an unsupported […] feature. I'm sorry guys.

I know that the SUSE SysMgmt Team does not support the KDE Live Installer. This does not make the bug invalid. In the case that you can not help to fix it please assign to the corresponding target (was it "yast-community" or something?).