Bug 1167146 - USB3 adapter (hub + ethernet) issues with unresponsive usb devices
USB3 adapter (hub + ethernet) issues with unresponsive usb devices
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-03-19 17:04 UTC by robert spitzenpfeil
Modified: 2020-12-23 11:23 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
oneukum: needinfo? (rs.opensuse)


Attachments
syslog messages of unplugging / replugging the usb-c thing (42.25 KB, text/plain)
2020-03-19 19:37 UTC, robert spitzenpfeil
Details
stuck at "reboot" (655.47 KB, image/png)
2020-03-19 19:45 UTC, robert spitzenpfeil
Details
lspci (2.05 KB, text/plain)
2020-03-25 14:08 UTC, robert spitzenpfeil
Details
lspci (2.05 KB, text/plain)
2020-03-25 14:09 UTC, robert spitzenpfeil
Details
lspci (2.05 KB, text/plain)
2020-03-25 14:09 UTC, robert spitzenpfeil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description robert spitzenpfeil 2020-03-19 17:04:08 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.149 Safari/537.36
Build Identifier: 

As of late, I've been having issues with this adapter. It appears to be getting worse since 5.5.5 (I've checked back that far).

Upon unplugging the usb-c connector, some devices remain visible with lsusb.


Bus 004 Device 003: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter
Bus 004 Device 002: ID 2109:0813 VIA Labs, Inc.

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 04f2:b59e Chicony Electronics Co., Ltd
Bus 001 Device 003: ID 8087:0a2b Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The 1st two lines should not be there.

I will try to get suitable syslog entries that match the time of this event.

Reproducible: Always
Comment 1 robert spitzenpfeil 2020-03-19 18:49:28 UTC
I may have wonky hardware.

I will report back once I have acquired meaningful logs.
Comment 2 robert spitzenpfeil 2020-03-19 19:30:19 UTC
5.5.5-1 is definitely more resilient than 5.5.7-1

I've just had stuck usb devices with the latter. They vanished when I did a "rcnetwork" restart. One of those stuck devices is the RTL8153.
Comment 3 robert spitzenpfeil 2020-03-19 19:37:03 UTC
Created attachment 833423 [details]
syslog messages of unplugging / replugging the usb-c thing

After unplugging with 5.5.7-1 the RTL8153 and "VIA" lines still remain, but should be gone. After "rcnetwork restart" they go away most of the time.
Comment 4 robert spitzenpfeil 2020-03-19 19:45:26 UTC
Created attachment 833424 [details]
stuck at "reboot"

When these usb devices are in a stuck state, rebooting doesn't always work.

--> REISUB
Comment 5 robert spitzenpfeil 2020-03-22 17:16:49 UTC
Exact same issue with 5.5.9-1-default
Comment 6 robert spitzenpfeil 2020-03-22 17:20:51 UTC
I'll quit using this adapter until this virus clusterfck is over.

I will run tests upon request though.
Comment 7 Oliver Neukum 2020-03-25 11:29:48 UTC
Please provide 'lspci' before and after the unplug
Comment 8 robert spitzenpfeil 2020-03-25 14:08:50 UTC
Created attachment 833844 [details]
lspci
Comment 9 robert spitzenpfeil 2020-03-25 14:09:03 UTC
Created attachment 833845 [details]
lspci
Comment 10 robert spitzenpfeil 2020-03-25 14:09:15 UTC
Created attachment 833846 [details]
lspci
Comment 11 robert spitzenpfeil 2020-03-25 14:10:05 UTC
Nothing changes
Comment 12 Nicolas Patricio Saenz Julienne 2020-03-25 15:57:01 UTC
What is the adapter name?
Comment 13 robert spitzenpfeil 2020-03-25 17:14:42 UTC
GOOBAY 62106

USB-C Multiport Adapter

https://www.amazon.de/Goobay-62106-USB-C-Multiport-Adapter-Ethernet/dp/B07BKNP8DT


Only I didn't pay that much for it a year ago :-)
Comment 14 robert spitzenpfeil 2020-03-27 18:21:23 UTC
Same issue with 5.5.11-1-default.

It seems nothing gets stuck if I run 'rcnetwork stop' before plugging or unplugging the adapter.
Comment 15 robert spitzenpfeil 2020-03-29 17:52:37 UTC
I'm not sure anymore that this is a problem of said adapter itself.

Now I have a stuck USB WiFi stick in the 'lsusb' list.

Bus 001 Device 021: ID 0cf3:9271 Qualcomm Atheros Communications AR9271 802.11n

I would really like to test older kernels, because I think this problem didn't exist back then.

Is there an easy way? Please no funny business, I need this machine for work.
Comment 16 Oliver Neukum 2020-04-07 07:54:19 UTC
(In reply to robert spitzenpfeil from comment #15)
> I'm not sure anymore that this is a problem of said adapter itself.
> 
> Now I have a stuck USB WiFi stick in the 'lsusb' list.
> 
> Bus 001 Device 021: ID 0cf3:9271 Qualcomm Atheros Communications AR9271
> 802.11n

So we need to provisionally blame the controller, not a device.

> Is there an easy way? Please no funny business, I need this machine for work.

Please disable LPM for your root hub, retest and provide dmesg.
Comment 17 robert spitzenpfeil 2020-07-10 18:25:13 UTC
Today I've checked with Leap 15.2 - works with no issues so far.

Kernel: 5.3.18-lp152.20.7
Comment 18 robert spitzenpfeil 2020-07-10 18:39:00 UTC
Disabling LPM on TW looks promising so far:

https://askubuntu.com/questions/802712/how-to-disable-usb3-lpm-hardware-controlled-power-management
Comment 19 robert spitzenpfeil 2020-07-10 19:01:52 UTC
Might be the same as bug 1174017, just not as bad when I posted my initial report with 5.5.x kernel - which still worked sometimes.
Comment 20 Miroslav Beneš 2020-09-16 11:14:40 UTC
Robert, any news here? Did you disable LPM as Oliver suggested? If yes, could you provide dmesg, please. TW is also on 5.8.x kernel now. Did it change anything?
Comment 21 robert spitzenpfeil 2020-09-16 15:39:20 UTC
LPM was disabled, see comment 18.

It was a huge success.


I will retest with the latest kernel over the weekend.
Comment 22 robert spitzenpfeil 2020-09-22 16:57:11 UTC
I've run some tests with "5.8.7-1-default". So far it looks very good - without disabling LPM myself.

There are the usual hiccups with SANE and my old canon scanner, but so far I was _not_ able to the the USB ports / the USB-C adapter stuck.

I've removed my rc-local script to disable LPM as per comment 18. It seems LPM is disabled nevertheless, but it wasn't me this time.

--- snip ---

/sys/devices/pci0000:00/0000:00:1c.6/0000:03:00.0/usb4/4-0:1.0/usb4-port2/usb3_lpm_permit 0
/sys/devices/pci0000:00/0000:00:1c.6/0000:03:00.0/usb4/4-0:1.0/usb4-port1/usb3_lpm_permit 0
/sys/devices/pci0000:00/0000:00:1c.6/0000:03:00.0/usb4/4-1/4-1:1.0/4-1-port4/usb3_lpm_permit 0
/sys/devices/pci0000:00/0000:00:1c.6/0000:03:00.0/usb4/4-1/4-1:1.0/4-1-port2/usb3_lpm_permit 0
/sys/devices/pci0000:00/0000:00:1c.6/0000:03:00.0/usb4/4-1/4-1:1.0/4-1-port3/usb3_lpm_permit 0
/sys/devices/pci0000:00/0000:00:1c.6/0000:03:00.0/usb4/4-1/4-1:1.0/4-1-port1/usb3_lpm_permit 0
/sys/devices/pci0000:00/0000:00:14.0/usb2/power/usb3_hardware_lpm_u2 disabled
/sys/devices/pci0000:00/0000:00:14.0/usb2/power/usb3_hardware_lpm_u1 disabled
/sys/devices/pci0000:00/0000:00:14.0/usb2/2-0:1.0/usb2-port7/usb3_lpm_permit 0
/sys/devices/pci0000:00/0000:00:14.0/usb2/2-0:1.0/usb2-port5/usb3_lpm_permit 0
/sys/devices/pci0000:00/0000:00:14.0/usb2/2-0:1.0/usb2-port3/usb3_lpm_permit 0
/sys/devices/pci0000:00/0000:00:14.0/usb2/2-0:1.0/usb2-port1/usb3_lpm_permit 0
/sys/devices/pci0000:00/0000:00:14.0/usb2/2-0:1.0/usb2-port8/usb3_lpm_permit 0
/sys/devices/pci0000:00/0000:00:14.0/usb2/2-0:1.0/usb2-port6/usb3_lpm_permit 0
/sys/devices/pci0000:00/0000:00:14.0/usb2/2-0:1.0/usb2-port4/usb3_lpm_permit 0
/sys/devices/pci0000:00/0000:00:14.0/usb2/2-0:1.0/usb2-port2/usb3_lpm_permit 0

--- snip ---

There is one line in "dmesg" that might explain this.

"usb usb4: We don't know the algorithms for LPM for this host, disabling LPM."

This did exist previously (e.g. booting 5.7.7-1-default), but maybe it didn't work as it should have.



If this now happens automagically, I'm more than OK with that.

I'll report back after some days of using the machine + adapter without explicitly disabling LPM myself and if it keeps on working I vote for closing this bug.
Comment 23 Miroslav Beneš 2020-12-23 11:23:51 UTC
No bad feedback since, so let's close. If it is still a problem, we can revisit. Thanks.