Bug 1167306 - ACPI Error
ACPI Error
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Kernel
Leap 15.1
x86-64 Other
: P2 - High : Critical (vote)
: Leap 15.1
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-03-21 09:17 UTC by Kornilios Tekakis
Modified: 2020-07-29 12:25 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
tiwai: needinfo? (kornilios.tekakis)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kornilios Tekakis 2020-03-21 09:17:12 UTC
When I boot my machine , the kernel runs and shows : 

ACPI Error: Method parse/execution failed \_SB.PCI0.SAT0.PRT3._GTF, AE_NOT_FOUND (20170303/psparse-516)

This problem is displaying when I run the dmesg command in konsole.
Comment 1 Takashi Iwai 2020-03-24 15:49:01 UTC
Could you check whether the issue is seen with Leap 15.2 kernel?

It's likely a BIOS firmware bug that can be ignored.
Comment 2 Ralf Czekalla 2020-03-25 21:05:51 UTC
I have similar messages on several Intel boards. 

The message you have here seems to be related to SATA0 with the PORT 3 in your case. From my experience this is connected to special non-Intel SATA chips on the main-board. If you unplug them, the messages disappear. Please check the mainboard guide to know which port is related to these non-Intel chipset SATA connectors.

In my case these chips often have better options like 6GB/s instead of 3GB/s on original Intel chipsets. That is the reason why I tend to use these SATA ports - especially with the switch to SSDs. And here you get always at least one message (two lines) for every sata connector sitting in the non-Intel related SATA ports at the mainboard. 

What I can not tell, if this is happening because these Jmicron, Maxwell - you name them - chips, are not properly handled in ACPI definitions in the BIOS, or if they are miss-interpreted in Linux Kernel on boot-up. 
Usually I recognise that these Jmicron, Maxwell and similar chips are properly supported later in the usual operation by the Linux kernel and this should make the initial message obsolete. 

It's annoying and you never know, if something more is behind this message and surprises are to be expected.

I'm using the latest stable kernel on these installations from 42.3 via 15.0 to 15.1 now. 15.2 so far only on KVM-based virtual installations. Current kernel is 5.5.9 to 5.5.11, tomorrow probably 5.5.12/5.5.13. I'm always using these latest stable kernels exclusively since more than a decade on all of my installations. 

Still these messages come every time on boot-up. BIOS are on the latest available version. All ASUS boards - as I remember right now.
Comment 3 Miroslav Beneš 2020-07-29 12:24:32 UTC
Let me close this one. The message is very likely harmless as Takashi pointed out. If you notice a weird behaviour regarding the issue, feel free to reopen (with a re-test on Leap 15.2).