Bug 1167388 - System freeze after 10-15 minutes of heavy use with Atheros AR9271 wifi
System freeze after 10-15 minutes of heavy use with Atheros AR9271 wifi
Status: RESOLVED NORESPONSE
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-03-23 08:57 UTC by Wilman Darnasutisna
Modified: 2021-12-31 14:42 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
tiwai: needinfo? (wilmanzendart)


Attachments
dmesg (4.46 KB, text/plain)
2020-03-23 08:57 UTC, Wilman Darnasutisna
Details
hwinfo. (499.63 KB, text/plain)
2020-03-23 09:16 UTC, Wilman Darnasutisna
Details
dmesg-new-1 (80.98 KB, text/plain)
2020-03-23 10:50 UTC, Wilman Darnasutisna
Details
Latest dmesg without nvidia. (83.17 KB, text/plain)
2020-04-07 13:00 UTC, Wilman Darnasutisna
Details
debug patch (1.28 KB, patch)
2020-06-18 06:12 UTC, Jiri Slaby
Details | Diff
debug patch v2 (1.79 KB, patch)
2020-06-18 06:25 UTC, Jiri Slaby
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Wilman Darnasutisna 2020-03-23 08:57:28 UTC
Created attachment 833617 [details]
dmesg

My system often freezes when connected to a wifi hotspot. Usually around 10-15 minutes of computer usage. And especially when playing videos, music, and also when downloading fairly large files using XDM and torrenting via QBittorrent.
After my system is frozen. I can't restore my connection, when I unplug my wifi adapter, suddenly everything freezes. The music I'm playing is playing repeatedly/on loop. Until finally I had to force a reboot by pressing the reset button on my PC.
Comment 1 Takashi Iwai 2020-03-23 09:02:56 UTC
Judging from the dmesg output, it looks like a memory corruption, likely triggered by ath9k stuff.

Is it a regression?  If yes, it'd be helpful to identify the last working version.

Also, please give hwinfo output.  Thanks.
Comment 2 Wilman Darnasutisna 2020-03-23 09:16:46 UTC
Created attachment 833624 [details]
hwinfo.

Sorry i don't quite understand about regression thing. Did you mean i should attach new dmesg?
Comment 3 Michal Suchanek 2020-03-23 09:53:26 UTC
did it work before? with which kernel?
Comment 4 Wilman Darnasutisna 2020-03-23 09:57:38 UTC
(In reply to Michal Suchanek from comment #3)
> did it work before? with which kernel?

Never work. I've tried Leap, and not work too.
Comment 5 Takashi Iwai 2020-03-23 10:23:35 UTC
OK.  Also, could you give the full dmesg output right after the kernel Oops is triggered?  It might show some condition that brings up the problem.
Comment 6 Wilman Darnasutisna 2020-03-23 10:50:39 UTC
Created attachment 833639 [details]
dmesg-new-1

here the new one
Comment 7 Wilman Darnasutisna 2020-03-26 08:07:30 UTC
what next to do?
i've tried update my kernel to 5.5.9. still freezing
Comment 8 Takashi Iwai 2020-03-26 08:35:55 UTC
At best, try the latest 5.6-rc kernel in OBS Kernel:HEAD repository.
If the problem persists with it (I guess so), report it to upstream, e.g. bugzilla.kernel.org.

But now I see that you're using Nvidia binary driver.  Could you try without this?  We can't exclude the possibility of the bug in Nvidia driver because of its binary-only nature.

Also, the dmesg output in comment 6 doesn't contain the Oops from ath9k.  It's helpful to see the condition before the Oops is triggered.
Comment 9 Wilman Darnasutisna 2020-03-26 08:51:18 UTC
(In reply to Takashi Iwai from comment #8)
> At best, try the latest 5.6-rc kernel in OBS Kernel:HEAD repository.
ok. i'll try.

> If the problem persists with it (I guess so), report it to upstream, e.g.
> bugzilla.kernel.org.
> 
> But now I see that you're using Nvidia binary driver.  Could you try without
> this?  We can't exclude the possibility of the bug in Nvidia driver because
> of its binary-only nature.

actually it's freezing since before installing nvidia
Comment 10 Wilman Darnasutisna 2020-03-26 09:08:50 UTC
(In reply to Wilman Darnasutisna from comment #9)
> (In reply to Takashi Iwai from comment #8)
> > At best, try the latest 5.6-rc kernel in OBS Kernel:HEAD repository.

is this the repo?
https://en.opensuse.org/openSUSE:Kernel_of_the_day
Comment 11 Wilman Darnasutisna 2020-03-26 09:24:33 UTC
this is right repo?

zypper ar https://download.opensuse.org/repositories/Kernel:/HEAD/standard/Kernel:HEAD.repo

but i don't see kernel-default for 5.6 in YaST
Comment 12 Takashi Iwai 2020-03-26 09:32:30 UTC
(In reply to Wilman Darnasutisna from comment #11)
> this is right repo?
> 
> zypper ar
> https://download.opensuse.org/repositories/Kernel:/HEAD/standard/Kernel:HEAD.
> repo
> 
> but i don't see kernel-default for 5.6 in YaST

The OBS repo can be easily added via obs:// prefix, e.g.
  zypper ar obs://Kernel:/HEAD/standard

But the easiest way would be to just grab kernel-default.rpm from
  http://download.opensuse.org/repositories/Kernel:/HEAD/standard/x86_64/

and install the rpm file directly via zypper.
Comment 13 Wilman Darnasutisna 2020-03-26 10:12:02 UTC
(In reply to Takashi Iwai from comment #12)
> (In reply to Wilman Darnasutisna from comment #11)
> > this is right repo?
> > 
> > zypper ar
> > https://download.opensuse.org/repositories/Kernel:/HEAD/standard/Kernel:HEAD.
> > repo
> > 
> > but i don't see kernel-default for 5.6 in YaST
> 
> The OBS repo can be easily added via obs:// prefix, e.g.
>   zypper ar obs://Kernel:/HEAD/standard
> 
> But the easiest way would be to just grab kernel-default.rpm from
>   http://download.opensuse.org/repositories/Kernel:/HEAD/standard/x86_64/
> 
> and install the rpm file directly via zypper.

should i install all the kernel-default-*? or just a kernel-default 5.6?
Comment 14 Takashi Iwai 2020-03-26 10:52:54 UTC
Just installing only kernel-default-5.6-rc7*.rpm should suffice.
Comment 15 Wilman Darnasutisna 2020-03-26 15:19:00 UTC
(In reply to Takashi Iwai from comment #14)
> Just installing only kernel-default-5.6-rc7*.rpm should suffice.

i can't get into login screen. it's black screen with blinking dash on the top left of screen.
Comment 16 Takashi Iwai 2020-03-26 15:29:57 UTC
Did you disable the Nvidia binary stuff?
Comment 17 Wilman Darnasutisna 2020-04-07 13:00:48 UTC
Created attachment 835092 [details]
Latest dmesg without nvidia.

Hello, i'm sorry for late rswesponses. i've been busy this month.  Here the problem still not fixed with latest kernel 5.6.0. and i've got this dmesg without nvidia installed.
Comment 18 Takashi Iwai 2020-04-07 13:09:52 UTC
Thanks!

I'll check the relevant code path.  Meanwhile could you report this to the upstream bugzilla?  bugzilla.kernel.org should reach to the upstream devs, I suppose.

Feel free to put me (tiwai@suse.de) to Cc there in case of any assistance from the distro side.
Comment 19 Wilman Darnasutisna 2020-04-07 13:29:17 UTC
(In reply to Takashi Iwai from comment #18)
> Thanks!
> 
> I'll check the relevant code path.  Meanwhile could you report this to the
> upstream bugzilla?  bugzilla.kernel.org should reach to the upstream devs, I
> suppose.
> 
> Feel free to put me (tiwai@suse.de) to Cc there in case of any assistance
> from the distro side.

which product to enter a bug?

ACPI: 	
Alternate Trees: 	
Backports project: 	
Documentation: 	
Drivers: 	
EFI: 	
File System: 	
IO/Storage: 	
Memory Management: 	
Networking: 	
Other: 	
Platform Specific/Hardware: 	
Power Management: 	
Process Management: 	
SCSI Drivers: 	
Timers: 	
Tools: 	
Tracing/Profiling: 	
v4l-dvb: 	
Virtualization:
Comment 20 Takashi Iwai 2020-04-07 14:20:27 UTC
Drivers / network-wireless would fit, I suppose.
Comment 21 Wilman Darnasutisna 2020-04-08 10:45:51 UTC
(In reply to Takashi Iwai from comment #20)
> Drivers / network-wireless would fit, I suppose.

Why they are not responding? i've file the bug yesterday.

https://bugzilla.kernel.org/show_bug.cgi?id=207149
Comment 22 Takashi Iwai 2020-04-08 11:07:57 UTC
Don't expect a quick response from upstream.  It really depends on the subsystem and the maintainer.  You can occasionally ping there, though.
Comment 23 Jiri Slaby 2020-06-18 06:12:24 UTC
Created attachment 838916 [details]
debug patch

IS this still reproducible?

If so, it might be worth applying this patch and seeing the dmesg output with that applied.
Comment 24 Jiri Slaby 2020-06-18 06:25:45 UTC
Created attachment 838917 [details]
debug patch v2

One more debug location added.
Comment 25 Miroslav Beneš 2020-09-16 11:08:33 UTC
I applied Jiri's debugging patch and uploaded the kernel to https://build.opensuse.org/project/monitor/home:mbenes:bsc1167388.

Wilman, could you tried that, once it finishes building, and provide the resultin dmesg with the crash, please? Well, in case it is still the issue with 5.8.x kernel...
Comment 26 Miroslav Beneš 2021-12-31 14:42:27 UTC
No response, closing.