Bug 1168873 - Mounting of SMB share through fstab fails on boot
Mounting of SMB share through fstab fails on boot
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Major (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-07 13:40 UTC by Thomas Rother
Modified: 2021-12-31 12:29 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Rother 2020-04-07 13:40:10 UTC
Since an unknown time, the automatic mounting of SMB shares during boot fails in this system (as long as it is done through systemd). fstab entries:

## nas
//192.168.72.3/downloads                   /mnt/nas_downloads      cifs   vers=3.0,credentials=/home/thommie/.smb/nascredentials,iocharset=utf8,uid=thommie,gid=users  0  0
//192.168.72.3/photo                       /mnt/nas_photo          cifs   vers=3.0,credentials=/home/thommie/.smb/nascredentials,uid=thommie,gid=users  0  0
//192.168.72.3/music                       /mnt/nas_music          cifs   vers=3.0,credentials=/home/thommie/.smb/nascredentials,uid=thommie,gid=users  0  0
//192.168.72.3/video                       /mnt/nas_video          cifs   vers=3.0,credentials=/home/thommie/.smb/nascredentials,uid=thommie,gid=users  0  0
//192.168.72.3/buch                        /mnt/nas_buch           cifs   vers=3.0,credentials=/home/thommie/.smb/nascredentials,uid=thommie,gid=users  0  0
//192.168.72.3/data1                       /mnt/nas_data1          cifs   vers=3.0,credentials=/home/thommie/.smb/nascredentials,uid=thommie,gid=users  0  0
//192.168.72.3/backup                      /mnt/nas_backup         cifs   vers=3.0,credentials=/home/thommie/.smb/nascredentials,uid=thommie,gid=users  0  0

The bootlog shows "duplicate cookie detected":

Apr 04 08:11:23 locutus kernel: FS-Cache: Duplicate cookie detected
Apr 04 08:11:23 locutus kernel: FS-Cache: O-cookie c=000000002985697d [p=0000000088c4e2e7 fl=222 nc=0 na=1]

later, mounting fails:

Apr 04 08:11:23 locutus mount[1830]: mount error(2): No such file or directory
Apr 04 08:11:23 locutus mount[1830]: Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)
Apr 04 08:11:23 locutus mount[1829]: mount error(2): No such file or directory
Apr 04 08:11:23 locutus mount[1829]: Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)


A reload of fstab through "mount -a" AFTER the full boot (multi-user.target) is always successful. This happens with all kernels up to 5.5.13-1-default, but is not tested with 5.6
Comment 1 Miroslav Beneš 2020-07-30 11:34:20 UTC
Forgotten one, sorry about that.

Thomas, is it still happening with the current TW and its 5.7.x kernel?

CCing Jim, so that his team is aware.
Comment 2 Thomas Rother 2020-07-30 13:01:52 UTC
I have the same errors in the boot log with kernel 5.7.9-1-default

Jul 30 07:02:54 locutus kernel: FS-Cache: Netfs 'cifs' registered for caching
Jul 30 07:02:58 locutus kernel: FS-Cache: Duplicate cookie detected
Jul 30 07:02:58 locutus kernel: FS-Cache: O-cookie c=000000006e3a0472 [p=000000003e41e630 fl=222 nc=0 na=1]
Jul 30 07:02:58 locutus kernel: FS-Cache: O-cookie d=000000006c3ea506 n=00000000e04cf4ce
Jul 30 07:02:58 locutus kernel: FS-Cache: O-key=[8] '0200008bc0a84803'
Jul 30 07:02:58 locutus kernel: FS-Cache: N-cookie c=00000000ca118bc4 [p=000000003e41e630 fl=2 nc=0 na=1]
Jul 30 07:02:58 locutus kernel: FS-Cache: N-cookie d=000000006c3ea506 n=00000000f80486d7
Jul 30 07:02:58 locutus kernel: FS-Cache: N-key=[8] '0200008bc0a84803'

And the same behaviour: mounting during bootup fails but mounting after full boot with "mount -a" is successful.
Comment 3 Miroslav Beneš 2021-12-31 12:19:41 UTC
Thomas, I am really sorry for the late reply. Is this still a problem with the latest TW kernel? There have been many changes around cifs and fscache subsystems since 5.7 kernel.
Comment 4 Thomas Rother 2021-12-31 12:29:56 UTC
@Miroslav, no worries. The problem is solved for a longer time, but I cant recreate exactly WHEN it was solved ..  Nevertheless, we can close this.