Bug 1169199 - xreader: Segmentation fault when trying to open EPUB files
xreader: Segmentation fault when trying to open EPUB files
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Xfce
Current
i686 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Aaron Stern
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-10 16:45 UTC by Suse User
Modified: 2021-01-02 15:16 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
EPUB 2.0 (1.98 KB, application/epub+zip)
2021-01-02 14:30 UTC, Suse User
Details
EPUB 3.0 (2.40 KB, application/epub+zip)
2021-01-02 14:32 UTC, Suse User
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Suse User 2020-04-10 16:45:23 UTC
On a 32-bit Tumbleweed system trying to open any EPUB file with xreader-2.2.2-3.3.i586 results in "Segmentation fault" and the file cannot be opened.

The same files can be opened without problem on a Leap 15.1 system using xreader-1.6.2-lp151.2.3.x86_64.
Comment 1 Maurizio Galli 2020-05-19 09:23:36 UTC
This is not a xfce bug but i’ll look into it. Do you experience the same problem if you use evince instead of xreader?
Comment 2 Suse User 2020-11-27 13:19:56 UTC
Sorry for the late reply.
I don't use evince, so I can't say.
I can confirm that with xreader-2.6.4-1.1.i586 the issue remains though.
Comment 3 andy great 2020-11-28 08:38:28 UTC
(In reply to Suse User from comment #2)
> Sorry for the late reply.
> I don't use evince, so I can't say.
> I can confirm that with xreader-2.6.4-1.1.i586 the issue remains though.

I could not reproduce the error.
Could you try running xreader in terminal and open your epub file?
Have you tried opening other epub file, or possible download epub file from other source?
Could you try installing other reader and open your epub?
Comment 4 Suse User 2020-11-28 17:16:57 UTC
> Could you try running xreader in terminal and open your epub file?

I do this every time.

> Have you tried opening other epub file, or possible download epub file from other source?

Yes.

> Could you try installing other reader and open your epub?

I have calibre installed and it opens the same (and all other) EPUB files without issues.
Comment 5 andy great 2020-12-30 17:39:38 UTC
Do you have some ebub file that can send to me so I can test it?
Comment 6 Suse User 2021-01-02 14:30:36 UTC
Created attachment 844779 [details]
EPUB 2.0

Here is one for the sake of testing.
Simply exported from Libre Office.
Comment 7 Suse User 2021-01-02 14:32:05 UTC
Created attachment 844781 [details]
EPUB 3.0

One more.
Comment 8 Suse User 2021-01-02 15:16:30 UTC
So... after all this time I noticed that there is a package named xreader-plugin-epubdocument. Installed it and now opening EPUB files works.

I guess this is not a bug then.
Sorry for the trouble.