Bug 1172958 - (CVE-2020-8618) VUL-1: CVE-2020-8618, CVE-2020-8619: bind: two vulnerabilities
(CVE-2020-8618)
VUL-1: CVE-2020-8618, CVE-2020-8619: bind: two vulnerabilities
Status: RESOLVED UPSTREAM
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/261605
CVSSv3.1:SUSE:CVE-2020-8618:4.9:(AV:N...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-06-16 07:16 UTC by Wolfgang Frisch
Modified: 2020-10-20 10:17 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Frisch 2020-06-16 07:16:55 UTC
CVE:                 CVE-2020-8618
Document version:    1.0
Posting date:        17 June 2020
Program impacted:    BIND
Versions affected:   BIND 9.16.0 -> 9.16.3
Severity:            Medium

Exploitable:

   Remotely, if the attacker is permitted to initiate a
   zone transfer to the target server

Description:

   An assertion check in BIND (that is meant to prevent going beyond
   the end of a buffer when processing incoming data) can be
   incorrectly triggered by a large response during zone transfer.

Impact:

   An attacker who is permitted to send zone data to a server via
   zone transfer can exploit this to intentionally trigger the
   assertion failure with a specially constructed zone, denying
   service to clients.

CVSS Score:          4.3
CVSS Vector:         AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C

For more information on the Common Vulnerability Scoring System and
to obtain your specific environmental score please visit:
https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator?vector=AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C&version=3.1.

Workarounds:

   None

Active exploits:

   We are not aware of any active exploits.

Solution:

   Upgrade to the patched release most closely related to your
   current version of BIND:

   -  BIND 9.16.4

Document revision history:

   1.0 Early Notification, 10 June 2020

Related documents:

   See our BIND 9 Security Vulnerability Matrix for a complete
   listing of security vulnerabilities and versions affected.

Do you still have questions? Questions regarding this advisory
should go to security-officer@isc.org. To report a new issue, please
encrypt your message using security-officer@isc.org's PGP key which
can be found here: https://www.isc.org/pgpkey/. If you are unable
to use encrypted email, you may also report new issues at:
https://www.isc.org/reportbug/.

Note:

   ISC patches only currently supported versions. When possible we
   indicate EOL versions affected. (For current information on which
   versions are actively supported, please see
   https://www.isc.org/download/.)

ISC Security Vulnerability Disclosure Policy:

   Details of our current security advisory policy and practice can
   be found in the ISC Software Defect and Security Vulnerability
   Disclosure Policy at https://kb.isc.org/docs/aa-00861.

The Knowledgebase article https://kb.isc.org/docs/cve-2020-8618 is
the complete and official security advisory document.

Legal Disclaimer:

   Internet Systems Consortium (ISC) is providing this notice on
   an "AS IS" basis. No warranty or guarantee of any kind is expressed
   in this notice and none should be implied. ISC expressly excludes
   and disclaims any warranties regarding this notice or materials
   referred to in this notice, including, without limitation, any
   implied warranty of merchantability, fitness for a particular
   purpose, absence of hidden defects, or of non-infringement. Your
   use or reliance on this notice or materials referred to in this
   notice is at your own risk. ISC may change this notice at any
   time. A stand-alone copy or paraphrase of the text of this
   document that omits the document URL is an uncontrolled copy.
   Uncontrolled copies may lack important information, be out of
   date, or contain factual errors.
Comment 1 Wolfgang Frisch 2020-06-16 07:18:36 UTC
CVE:                 CVE-2020-8619
Document version:    1.0
Posting date:        17 June 2020
Program impacted:    BIND
Versions affected:   BIND 9.11.14 -> 9.11.19, BIND 9.14.9 -> 9.14.12,
                     BIND 9.16.0 -> 9.16.3
Severity:            Medium

Exploitable:

   Remotely, but only if records matching a certain pattern are
   present in a zone being served.

Description:

   The asterisk character ("*") is allowed in DNS zone files, where
   it is most commonly present as a wildcard at a terminal node of
   the Domain Name System graph. However, the RFCs do not require
   and BIND does not enforce that an asterisk character be present
   only at a terminal node.

   A problem can occur when an asterisk is present in an empty
   non-terminal location within the DNS graph. If such a node exists,
   after a series of queries, named can reach an inconsistent state
   that results in the failure of an assertion check in rbtdb.c,
   followed by the program exiting due to the assertion failure.

Impact:

   Unless a nameserver is providing authoritative service for one
   or more zones and at least one zone contains an empty non-terminal
   entry containing an asterisk ("*") character this defect cannot
   be encountered.

   A would-be attacker who is allowed to change zone content could
   theoretically introduce such a record in order to exploit this
   condition to cause denial of service, though we consider the use
   of this vector unlikely because any such attack would require a
   significant privilege level and be easily traceable.

CVSS Score:          4.3
CVSS Vector:         AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C

For more information on the Common Vulnerability Scoring System and
to obtain your specific environmental score please visit:
https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator?vector=AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C&version=3.1.

Workarounds:

   None

Active exploits:

   We are not aware of any active exploits.

Solution:

   Upgrade to the patched release most closely related to your
   current version of BIND:

   -  BIND 9.11.20
   -  BIND 9.16.4

   BIND Supported Preview Edition is a special feature preview
   branch of BIND provided to eligible ISC support customers.

   -  BIND 9.11.20-S1

Document revision history:

   1.0 Early Notification, 10 June 2020

Related documents:

   See our BIND 9 Security Vulnerability Matrix for a complete
   listing of security vulnerabilities and versions affected.

Do you still have questions? Questions regarding this advisory
should go to security-officer@isc.org. To report a new issue, please
encrypt your message using security-officer@isc.org's PGP key which
can be found here: https://www.isc.org/pgpkey/. If you are unable
to use encrypted email, you may also report new issues at:
https://www.isc.org/reportbug/.

Note:

   ISC patches only currently supported versions. When possible we
   indicate EOL versions affected. (For current information on which
   versions are actively supported, please see https://www.isc.org/download/.)

ISC Security Vulnerability Disclosure Policy:

   Details of our current security advisory policy and practice can
   be found in the ISC Software Defect and Security Vulnerability
   Disclosure Policy at https://kb.isc.org/docs/aa-00861.

The Knowledgebase article https://kb.isc.org/docs/cve-2020-8619 is
the complete and official security advisory document.

Legal Disclaimer:

   Internet Systems Consortium (ISC) is providing this notice on
   an "AS IS" basis. No warranty or guarantee of any kind is expressed
   in this notice and none should be implied. ISC expressly excludes
   and disclaims any warranties regarding this notice or materials
   referred to in this notice, including, without limitation, any
   implied warranty of merchantability, fitness for a particular
   purpose, absence of hidden defects, or of non-infringement. Your
   use or reliance on this notice or materials referred to in this
   notice is at your own risk. ISC may change this notice at any
   time. A stand-alone copy or paraphrase of the text of this
   document that omits the document URL is an uncontrolled copy.
   Uncontrolled copies may lack important information, be out of
   date, or contain factual errors.
Comment 6 Johannes Segitz 2020-06-18 07:10:03 UTC
Public: https://kb.isc.org/docs/cve-2020-8618
Comment 9 Marcus Meissner 2020-06-23 11:22:03 UTC
fixed
Comment 12 Swamp Workflow Management 2020-10-13 20:16:11 UTC
SUSE-SU-2020:2914-1: An update that solves 12 vulnerabilities, contains one feature and has 8 fixes is now available.

Category: security (moderate)
Bug References: 1100369,1109160,1118367,1118368,1128220,1156205,1157051,1161168,1170667,1170713,1171313,1171740,1172958,1173307,1173311,1173983,1175443,1176092,1176674,906079
CVE References: CVE-2017-3136,CVE-2018-5741,CVE-2019-6477,CVE-2020-8616,CVE-2020-8617,CVE-2020-8618,CVE-2020-8619,CVE-2020-8620,CVE-2020-8621,CVE-2020-8622,CVE-2020-8623,CVE-2020-8624
JIRA References: ECO-1402
Sources used:
SUSE Linux Enterprise Server for SAP 15 (src):    bind-9.16.6-12.32.1, sysuser-tools-2.0-4.2.8
SUSE Linux Enterprise Server 15-LTSS (src):    bind-9.16.6-12.32.1, sysuser-tools-2.0-4.2.8
SUSE Linux Enterprise Module for Server Applications 15-SP2 (src):    bind-9.16.6-12.32.1
SUSE Linux Enterprise Module for Server Applications 15-SP1 (src):    bind-9.16.6-12.32.1
SUSE Linux Enterprise Module for Development Tools 15-SP2 (src):    sysuser-tools-2.0-4.2.8
SUSE Linux Enterprise Module for Basesystem 15-SP2 (src):    bind-9.16.6-12.32.1, sysuser-tools-2.0-4.2.8
SUSE Linux Enterprise Module for Basesystem 15-SP1 (src):    bind-9.16.6-12.32.1, sysuser-tools-2.0-4.2.8
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    bind-9.16.6-12.32.1, sysuser-tools-2.0-4.2.8
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    bind-9.16.6-12.32.1, sysuser-tools-2.0-4.2.8

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 13 Swamp Workflow Management 2020-10-19 22:15:57 UTC
openSUSE-SU-2020:1699-1: An update that solves 12 vulnerabilities and has 8 fixes is now available.

Category: security (moderate)
Bug References: 1100369,1109160,1118367,1118368,1128220,1156205,1157051,1161168,1170667,1170713,1171313,1171740,1172958,1173307,1173311,1173983,1175443,1176092,1176674,906079
CVE References: CVE-2017-3136,CVE-2018-5741,CVE-2019-6477,CVE-2020-8616,CVE-2020-8617,CVE-2020-8618,CVE-2020-8619,CVE-2020-8620,CVE-2020-8621,CVE-2020-8622,CVE-2020-8623,CVE-2020-8624
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    bind-9.16.6-lp152.14.3.1, libuv-1.18.0-lp152.4.3.1, sysuser-tools-2.0-lp152.5.3.1
Comment 14 Swamp Workflow Management 2020-10-20 10:17:51 UTC
openSUSE-SU-2020:1701-1: An update that solves 12 vulnerabilities and has 8 fixes is now available.

Category: security (moderate)
Bug References: 1100369,1109160,1118367,1118368,1128220,1156205,1157051,1161168,1170667,1170713,1171313,1171740,1172958,1173307,1173311,1173983,1175443,1176092,1176674,906079
CVE References: CVE-2017-3136,CVE-2018-5741,CVE-2019-6477,CVE-2020-8616,CVE-2020-8617,CVE-2020-8618,CVE-2020-8619,CVE-2020-8620,CVE-2020-8621,CVE-2020-8622,CVE-2020-8623,CVE-2020-8624
JIRA References: 
Sources used:
openSUSE Leap 15.1 (src):    bind-9.16.6-lp151.11.9.1, libuv-1.18.0-lp151.3.3.1, sysuser-tools-2.0-lp151.4.3.1