Bug 1174293 - AppArmor X abstraction not compatible with sddm change
AppArmor X abstraction not compatible with sddm change
Status: RESOLVED DUPLICATE of bug 1174290
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: AppArmor
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Christian Boltz
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-07-20 06:57 UTC by Fabian Vogt
Modified: 2020-07-20 19:30 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Vogt 2020-07-20 06:57:25 UTC
Recently, we applied https://github.com/sddm/sddm/pull/1230 to sddm to improve the use of Xauthority. This includes a move of the file to $XDG_RUNTIME_DIR/xauth_XXXXXX, but it seems like AppArmor doesn't allow access there by default.

According to https://github.com/jonls/redshift/issues/763, this works:

owner /{,var/}run/user/*/xauth_* r,

No idea where to submit that, as the PR isn't merged upstream yet, so I just opened a bug report instead...
Comment 1 Fabian Vogt 2020-07-20 07:00:48 UTC
Apparently reported already

*** This bug has been marked as a duplicate of bug 1174290 ***
Comment 2 OBSbugzilla Bot 2020-07-20 19:30:11 UTC
This is an autogenerated message for OBS integration:
This bug (1174293) was mentioned in
https://build.opensuse.org/request/show/821972 Factory / apparmor