Bug 1174415 - (CVE-2020-15900) VUL-0: CVE-2020-15900: ghostscript: Memory Corruption
(CVE-2020-15900)
VUL-0: CVE-2020-15900: ghostscript: Memory Corruption
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P2 - High : Major
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/264127/
CVSSv3.1:SUSE:CVE-2020-15900:7.5:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-07-23 07:27 UTC by Alexandros Toptsoglou
Modified: 2020-08-27 13:34 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 16 OBSbugzilla Bot 2020-07-27 12:55:07 UTC
This is an autogenerated message for IBS integration:
This bug (1174415) was mentioned in
https://build.suse.de/request/show/222929 SLE-15 / ghostscript
https://build.suse.de/request/show/222930 SLE-12 / ghostscript
Comment 18 Alexandros Toptsoglou 2020-07-27 13:50:26 UTC
Now public through https://github.com/ArtifexSoftware/ghostpdl/commit/5d499272b95a6b890a1397e11d20937de000d31b

Further information in the upstream bug [1], currently private. 

[1] https://bugs.ghostscript.com/show_bug.cgi?id=702582
Comment 19 Alexandros Toptsoglou 2020-07-27 13:52:12 UTC
SLE12 and SLE15 are affected and are in the process of receiving the fix
Comment 22 OBSbugzilla Bot 2020-07-28 08:40:06 UTC
This is an autogenerated message for OBS integration:
This bug (1174415) was mentioned in
https://build.opensuse.org/request/show/823078 Factory / ghostscript
Comment 23 Swamp Workflow Management 2020-07-30 19:13:43 UTC
SUSE-SU-2020:2095-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1174415
CVE References: CVE-2020-15900
JIRA References: 
Sources used:
SUSE Linux Enterprise Server for SAP 15 (src):    ghostscript-9.52-3.32.1
SUSE Linux Enterprise Server 15-LTSS (src):    ghostscript-9.52-3.32.1
SUSE Linux Enterprise Module for Basesystem 15-SP2 (src):    ghostscript-9.52-3.32.1
SUSE Linux Enterprise Module for Basesystem 15-SP1 (src):    ghostscript-9.52-3.32.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    ghostscript-9.52-3.32.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    ghostscript-9.52-3.32.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 24 Swamp Workflow Management 2020-07-30 19:14:34 UTC
SUSE-SU-2020:2097-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1174415
CVE References: CVE-2020-15900
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    ghostscript-9.52-23.39.1
SUSE OpenStack Cloud Crowbar 8 (src):    ghostscript-9.52-23.39.1
SUSE OpenStack Cloud 9 (src):    ghostscript-9.52-23.39.1
SUSE OpenStack Cloud 8 (src):    ghostscript-9.52-23.39.1
SUSE OpenStack Cloud 7 (src):    ghostscript-9.52-23.39.1
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    ghostscript-9.52-23.39.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    ghostscript-9.52-23.39.1
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    ghostscript-9.52-23.39.1
SUSE Linux Enterprise Server for SAP 12-SP2 (src):    ghostscript-9.52-23.39.1
SUSE Linux Enterprise Server 12-SP5 (src):    ghostscript-9.52-23.39.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    ghostscript-9.52-23.39.1
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    ghostscript-9.52-23.39.1
SUSE Linux Enterprise Server 12-SP3-BCL (src):    ghostscript-9.52-23.39.1
SUSE Linux Enterprise Server 12-SP2-LTSS (src):    ghostscript-9.52-23.39.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    ghostscript-9.52-23.39.1
SUSE Enterprise Storage 5 (src):    ghostscript-9.52-23.39.1
HPE Helion Openstack 8 (src):    ghostscript-9.52-23.39.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 25 Swamp Workflow Management 2020-08-03 22:14:35 UTC
openSUSE-SU-2020:1142-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1174415
CVE References: CVE-2020-15900
JIRA References: 
Sources used:
openSUSE Leap 15.1 (src):    ghostscript-9.52-lp151.3.15.1, ghostscript-mini-9.52-lp151.3.15.1
Comment 26 Swamp Workflow Management 2020-08-04 16:13:51 UTC
openSUSE-SU-2020:1146-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1174415
CVE References: CVE-2020-15900
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    ghostscript-9.52-lp152.2.4.1, ghostscript-mini-9.52-lp152.2.4.1
Comment 27 Alexandros Toptsoglou 2020-08-27 13:34:37 UTC
Done