Bug 1176767 - YaST too big on disk, but glibc-locale-base would shave 209 MiB
YaST too big on disk, but glibc-locale-base would shave 209 MiB
Status: CONFIRMED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Enhancement (vote)
: ---
Assigned To: Martin Vidner
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-09-21 10:26 UTC by Martin Vidner
Modified: 2020-09-21 15:11 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Vidner 2020-09-21 10:26:15 UTC
Recently I was looking at https://cockpit-project.org/ and how it relates to
YaST. One of the factors was the disk footprint: Cockpit takes up less than 10 MB.

YaST takes up 258 MiB on disk. (counting just the base, not the actual config modules)

Starting with a 2020-09-01 openSUSE Tumbleweed that already has Cockpit installed, these are the byte sizes of packages installed by "zypper install yast2"

218922718 glibc-locale
16627072 ruby2.7
9940016 ruby2.7-rubygem-nokogiri
3427518 hwinfo
3413184 libruby2_7-2_7
3310778 yast2-core
2589200 yast2
2279763 ruby2.7-rubygem-unf_ext
1378488 yast2-pkg-bindings
1179325 libyui-ncurses13
1095423 ruby2.7-rubygem-simpleidn
949088 libyui13
788911 libjemalloc2
721238 yast2-hardware-detection
686097 augeas-lenses
646032 yast2-ycp-ui-bindings
463280 yast2-ruby-bindings
360824 libxslt1
316728 yast2-perl-bindings
226562 augeas
167706 libx86emu3
129288 libyaml-0-2
129144 ruby2.7-rubygem-unf
115505 ruby2.7-rubygem-ruby-augeas
108310 ruby2.7-rubygem-fast_gettext
63522 ruby2.7-rubygem-cfa
62415 ruby2.7-rubygem-gem2rpm
51387 ruby2.7-rubygem-cheetah
47974 fdupes
38714 ruby-common
34725 perl-gettext
10762 ruby2.7-rubygem-abstract_method
3389 yast2-logs
84 ruby

Now, glibc-locale is required by libyui-ncurses (based on bug 849255) but
since 2 years ago a smaller subpackage exists, glibc-locale-base, which can be
used as long as YaST runs in English only.
Comment 1 Martin Vidner 2020-09-21 10:27:05 UTC
Bugzilla has suggested this as a related bug:
https://bugzilla.suse.com/show_bug.cgi?id=1154405 "libyui-ncurses10 is not satisfied by glibc-locale-base on EN-only installation"
Comment 2 Martin Vidner 2020-09-21 10:27:51 UTC
Looking into another big dependency, ruby2.7-rubygem-nokogiri.rpm (a XML
library) has 9.5 MiB out of which 8.8 MiB is /usr/lib64/ruby/gems/2.7.0/cache/nokogiri-1.10.10.gem, just a useless repackaging of the source gem.
Comment 3 Felix Miata 2020-09-21 15:11:26 UTC
(In reply to Martin Vidner from comment #1)
> https://bugzilla.suse.com/show_bug.cgi?id=1154405

And for openSUSE users: https://bugzilla.opensuse.org/show_bug.cgi?id=1154405

Note Bugzilla's linkification is smart. bug 1154405 produces URL matching BZ URL logged into.