Bug 1177143 - (CVE-2020-26154) VUL-0: CVE-2020-26154: libproxy: sending more than 102400 bytes in PAC without a Content-Length present could result in buffer overflow
(CVE-2020-26154)
VUL-0: CVE-2020-26154: libproxy: sending more than 102400 bytes in PAC withou...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Major
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/268490/
CVSSv3.1:SUSE:CVE-2020-26154:8.0:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-09-30 15:05 UTC by Wolfgang Frisch
Modified: 2020-10-17 10:16 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Frisch 2020-09-30 15:05:03 UTC
CVE-2020-26154

It was found that if the server serving a PAC file sends more than 102400 bytes without a Content-Length present, libproxy can overflow its buffer by PAC_HTTP_BLOCK_SIZE (512) bytes.

References:
https://github.com/libproxy/libproxy/pull/126
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=968366
https://bugzilla.redhat.com/show_bug.cgi?id=1869639
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-26154
Comment 1 Wolfgang Frisch 2020-09-30 15:13:33 UTC
SUSE:SLE-11-SP1:Update  Not affected [1]
SUSE:SLE-12-SP2:Update  Affected
SUSE:SLE-15:Update      Affected

[1] assumes Content-Length == 0 when the header is absent.
Comment 2 OBSbugzilla Bot 2020-10-05 15:40:17 UTC
This is an autogenerated message for OBS integration:
This bug (1177143) was mentioned in
https://build.opensuse.org/request/show/839601 Factory / libproxy
Comment 4 Swamp Workflow Management 2020-10-13 16:16:55 UTC
SUSE-SU-2020:2901-1: An update that fixes two vulnerabilities is now available.

Category: security (important)
Bug References: 1176410,1177143
CVE References: CVE-2020-25219,CVE-2020-26154
JIRA References: 
Sources used:
SUSE Linux Enterprise Workstation Extension 15-SP2 (src):    libproxy-plugins-0.4.15-4.3.1
SUSE Linux Enterprise Workstation Extension 15-SP1 (src):    libproxy-plugins-0.4.15-4.3.1
SUSE Linux Enterprise Server for SAP 15 (src):    libproxy-0.4.15-4.3.1, libproxy-plugins-0.4.15-4.3.1
SUSE Linux Enterprise Server 15-LTSS (src):    libproxy-0.4.15-4.3.1, libproxy-plugins-0.4.15-4.3.1
SUSE Linux Enterprise Module for Development Tools 15-SP2 (src):    libproxy-plugins-0.4.15-4.3.1
SUSE Linux Enterprise Module for Development Tools 15-SP1 (src):    libproxy-plugins-0.4.15-4.3.1
SUSE Linux Enterprise Module for Basesystem 15-SP2 (src):    libproxy-0.4.15-4.3.1
SUSE Linux Enterprise Module for Basesystem 15-SP1 (src):    libproxy-0.4.15-4.3.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    libproxy-0.4.15-4.3.1, libproxy-plugins-0.4.15-4.3.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    libproxy-0.4.15-4.3.1, libproxy-plugins-0.4.15-4.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 5 Swamp Workflow Management 2020-10-13 16:21:27 UTC
SUSE-SU-2020:2900-1: An update that fixes two vulnerabilities is now available.

Category: security (important)
Bug References: 1176410,1177143
CVE References: CVE-2020-25219,CVE-2020-26154
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    libproxy-0.4.13-18.3.1, libproxy-plugins-0.4.13-18.3.1
SUSE OpenStack Cloud Crowbar 8 (src):    libproxy-0.4.13-18.3.1, libproxy-plugins-0.4.13-18.3.1
SUSE OpenStack Cloud 9 (src):    libproxy-0.4.13-18.3.1, libproxy-plugins-0.4.13-18.3.1
SUSE OpenStack Cloud 8 (src):    libproxy-0.4.13-18.3.1, libproxy-plugins-0.4.13-18.3.1
SUSE OpenStack Cloud 7 (src):    libproxy-0.4.13-18.3.1, libproxy-plugins-0.4.13-18.3.1
SUSE Linux Enterprise Workstation Extension 12-SP5 (src):    libproxy-plugins-0.4.13-18.3.1
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    libproxy-0.4.13-18.3.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    libproxy-0.4.13-18.3.1, libproxy-plugins-0.4.13-18.3.1
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    libproxy-0.4.13-18.3.1, libproxy-plugins-0.4.13-18.3.1
SUSE Linux Enterprise Server for SAP 12-SP2 (src):    libproxy-0.4.13-18.3.1, libproxy-plugins-0.4.13-18.3.1
SUSE Linux Enterprise Server 12-SP5 (src):    libproxy-0.4.13-18.3.1, libproxy-plugins-0.4.13-18.3.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    libproxy-0.4.13-18.3.1, libproxy-plugins-0.4.13-18.3.1
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    libproxy-0.4.13-18.3.1, libproxy-plugins-0.4.13-18.3.1
SUSE Linux Enterprise Server 12-SP3-BCL (src):    libproxy-0.4.13-18.3.1, libproxy-plugins-0.4.13-18.3.1
SUSE Linux Enterprise Server 12-SP2-LTSS (src):    libproxy-0.4.13-18.3.1, libproxy-plugins-0.4.13-18.3.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    libproxy-0.4.13-18.3.1, libproxy-plugins-0.4.13-18.3.1
SUSE Enterprise Storage 5 (src):    libproxy-0.4.13-18.3.1, libproxy-plugins-0.4.13-18.3.1
HPE Helion Openstack 8 (src):    libproxy-0.4.13-18.3.1, libproxy-plugins-0.4.13-18.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 6 Michael Gorse 2020-10-14 20:00:37 UTC
Updates released. Re-assigning to security team.
Comment 7 Wolfgang Frisch 2020-10-15 11:33:26 UTC
Released.
Comment 8 Swamp Workflow Management 2020-10-16 22:15:05 UTC
openSUSE-SU-2020:1676-1: An update that fixes two vulnerabilities is now available.

Category: security (important)
Bug References: 1176410,1177143
CVE References: CVE-2020-25219,CVE-2020-26154
JIRA References: 
Sources used:
openSUSE Leap 15.1 (src):    libproxy-0.4.15-lp151.4.3.1, libproxy-plugins-0.4.15-lp151.4.3.1
Comment 9 Swamp Workflow Management 2020-10-17 10:16:56 UTC
openSUSE-SU-2020:1680-1: An update that fixes two vulnerabilities is now available.

Category: security (important)
Bug References: 1176410,1177143
CVE References: CVE-2020-25219,CVE-2020-26154
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    libproxy-0.4.15-lp152.5.3.1, libproxy-plugins-0.4.15-lp152.5.3.1