Bug 1178512 - (CVE-2020-28196) VUL-0: CVE-2020-28196: krb5: unbounded recursion via an ASN.1-encoded Kerberos message
(CVE-2020-28196)
VUL-0: CVE-2020-28196: krb5: unbounded recursion via an ASN.1-encoded Kerbero...
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Minor
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/271110/
CVSSv3.1:SUSE:CVE-2020-28196:7.5:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-11-06 14:51 UTC by Robert Frohl
Modified: 2020-12-18 10:47 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Frohl 2020-11-06 14:51:33 UTC
CVE-2020-28196

MIT Kerberos 5 (aka krb5) before 1.17.2 and 1.18.x before 1.18.3 allows
unbounded recursion via an ASN.1-encoded Kerberos message because the
lib/krb5/asn.1/asn1_encode.c support for BER indefinite lengths lacks a
recursion limit.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-28196
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-28196
https://github.com/krb5/krb5/commit/57415dda6cf04e73ffc3723be518eddfae599bfd
Comment 1 Robert Frohl 2020-11-06 14:54:29 UTC
looks to me like only these codestreams are affected:

- SUSE:SLE-12-SP2:Update/krb5
- SUSE:SLE-15:Update/krb5
- SUSE:SLE-15-SP1:Update/krb5

@Samuel: could you have a look too please and confirm that 1.6.3 is not affected?
Comment 2 Samuel Cabrero 2020-11-09 09:55:49 UTC
(In reply to Robert Frohl from comment #1)
> looks to me like only these codestreams are affected:
> 
> - SUSE:SLE-12-SP2:Update/krb5
> - SUSE:SLE-15:Update/krb5
> - SUSE:SLE-15-SP1:Update/krb5
> 
> @Samuel: could you have a look too please and confirm that 1.6.3 is not
> affected?

Correct, it affects 1.11 and later.
Comment 4 Swamp Workflow Management 2020-11-19 14:15:59 UTC
SUSE-SU-2020:3379-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1178512
CVE References: CVE-2020-28196
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    krb5-1.12.5-40.40.2
SUSE OpenStack Cloud Crowbar 8 (src):    krb5-1.12.5-40.40.2
SUSE OpenStack Cloud 9 (src):    krb5-1.12.5-40.40.2
SUSE OpenStack Cloud 8 (src):    krb5-1.12.5-40.40.2
SUSE OpenStack Cloud 7 (src):    krb5-1.12.5-40.40.2
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    krb5-1.12.5-40.40.2
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    krb5-1.12.5-40.40.2
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    krb5-1.12.5-40.40.2
SUSE Linux Enterprise Server for SAP 12-SP2 (src):    krb5-1.12.5-40.40.2
SUSE Linux Enterprise Server 12-SP5 (src):    krb5-1.12.5-40.40.2
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    krb5-1.12.5-40.40.2
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    krb5-1.12.5-40.40.2
SUSE Linux Enterprise Server 12-SP3-BCL (src):    krb5-1.12.5-40.40.2
SUSE Linux Enterprise Server 12-SP2-LTSS (src):    krb5-1.12.5-40.40.2
SUSE Linux Enterprise Server 12-SP2-BCL (src):    krb5-1.12.5-40.40.2
SUSE Enterprise Storage 5 (src):    krb5-1.12.5-40.40.2
HPE Helion Openstack 8 (src):    krb5-1.12.5-40.40.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 5 Swamp Workflow Management 2020-11-19 14:17:04 UTC
SUSE-SU-2020:3377-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1178512
CVE References: CVE-2020-28196
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for Server Applications 15-SP2 (src):    krb5-1.16.3-3.15.1
SUSE Linux Enterprise Module for Server Applications 15-SP1 (src):    krb5-1.16.3-3.15.1
SUSE Linux Enterprise Module for Basesystem 15-SP2 (src):    krb5-1.16.3-3.15.1
SUSE Linux Enterprise Module for Basesystem 15-SP1 (src):    krb5-1.16.3-3.15.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 6 Swamp Workflow Management 2020-11-19 14:30:22 UTC
SUSE-SU-2020:3375-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1178512
CVE References: CVE-2020-28196
JIRA References: 
Sources used:
SUSE Linux Enterprise Server for SAP 15 (src):    krb5-1.15.2-6.12.2
SUSE Linux Enterprise Server 15-LTSS (src):    krb5-1.15.2-6.12.2
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    krb5-1.15.2-6.12.2
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    krb5-1.15.2-6.12.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2020-11-26 20:24:05 UTC
openSUSE-SU-2020:2037-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1178512
CVE References: CVE-2020-28196
JIRA References: 
Sources used:
openSUSE Leap 15.1 (src):    krb5-1.16.3-lp151.2.15.1, krb5-mini-1.16.3-lp151.2.15.1
Comment 8 Swamp Workflow Management 2020-11-27 11:15:44 UTC
openSUSE-SU-2020:2062-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1178512
CVE References: CVE-2020-28196
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    krb5-1.16.3-lp152.5.13.1, krb5-mini-1.16.3-lp152.5.13.1
Comment 9 Samuel Cabrero 2020-12-18 10:47:02 UTC
Reassign to security team to close it.