Bug 1179004 - Musescore doesn't load palettes
Musescore doesn't load palettes
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Other
Leap 15.2
x86-64 openSUSE Leap 15.2
: P5 - None : Normal (vote)
: ---
Assigned To: Fabian Vogt
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-11-20 08:30 UTC by Mark Akermann
Modified: 2020-12-01 07:17 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
fvogt: needinfo? (mark.akermann)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Akermann 2020-11-20 08:30:25 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0
Build Identifier: 

Musescore doesn't display palettes for musical symbols. So the application is unusable.

After Musescore starts, the following error messages are displayed at the commandline:
qrc:/qml/palettes/PaletteTree.qml:152: Error: Cannot assign to non-existent property "color"
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 837, resource id: 37749162, major code: 40 (TranslateCoords), minor code: 0
qrc:/qml/palettes/PaletteTree.qml:193:19: QML Component: Cannot create delegate
qrc:/qml/palettes/PaletteTree.qml: Object or context destroyed during incubation
libpng error: Read Error




Reproducible: Always

Steps to Reproduce:
1.Start musescore on commandline
2.See error messages, in GUI palette is empty.
Actual Results:  
Palettes not loaded.

Expected Results:  
Palettes for editing and adding symbols are missing. Application unusable for music editing.

Used stock version from OpenSuse 15.2. Repository.

See bug filed at Musescore.org:
https://musescore.org/en/node/307236
Comment 1 Cor Blom 2020-11-23 12:26:00 UTC
This seems to be a KDE bug:

https://bugs.kde.org/show_bug.cgi?id=425949

reassigning the bug.
Comment 3 Cor Blom 2020-11-23 14:17:10 UTC
(In reply to Fabian Vogt from comment #2)
> Please try with the package from
> https://build.opensuse.org/package/show/home:Vogtinator:boo1179004/qqc2-
> desktop-style.openSUSE_Leap_15.2_Update.

I can confirm this solves the bug.
Comment 4 OBSbugzilla Bot 2020-11-23 15:20:07 UTC
This is an autogenerated message for OBS integration:
This bug (1179004) was mentioned in
https://build.opensuse.org/request/show/850233 15.2 / qqc2-desktop-style
Comment 5 Mark Akermann 2020-11-23 15:34:40 UTC
Confirmed. Patch fixed issue. Palette is visible, error messages gone.
Thanks Fabian(In reply to Fabian Vogt from comment #2)
> Please try with the package from
> https://build.opensuse.org/package/show/home:Vogtinator:boo1179004/qqc2-
> desktop-style.openSUSE_Leap_15.2_Update.

Confirmed. Patch fixed issue. Palette is visible, error messages gone.
Thanks Fabian
Comment 6 Swamp Workflow Management 2020-11-27 17:27:28 UTC
openSUSE-RU-2020:2081-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1179004
CVE References: 
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    qqc2-desktop-style-5.71.0-lp152.2.3.1
Comment 7 Swamp Workflow Management 2020-11-30 23:17:08 UTC
openSUSE-RU-2020:2124-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1179004
CVE References: 
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP2 (src):    qqc2-desktop-style-5.71.0-bp152.2.3.1
Comment 8 Cor Blom 2020-12-01 07:17:12 UTC
Bug is fixed