Bug 1179226 - System hang related to power saving
System hang related to power saving
Status: RESOLVED NORESPONSE
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-11-25 19:29 UTC by jean-christophe baptiste
Modified: 2022-01-21 12:14 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
tiwai: needinfo? (jc)


Attachments
hwinfo (949.03 KB, text/plain)
2020-11-25 19:29 UTC, jean-christophe baptiste
Details
dmesg (108.73 KB, text/plain)
2020-11-25 19:30 UTC, jean-christophe baptiste
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jean-christophe baptiste 2020-11-25 19:29:00 UTC
# Issue :

Screen and input devices would stop responding (black screen, no TTY), as soon as the computer goes into some low power mode.

It can be triggered by locking the screen in Gnome (through gdm), and can also be reproduced in XFCE / LightDM by just leaving the computer for a while.

# Impact :

- black screen, no TTY access
- unresponsive system (impossible to launch new processes, reboot, no way to switch init3 & init 5, etc.)
- SSH/network access still available, existing process seem to run

Moreover, no related log entry, no error (journalctl, dmesg...).

# Notes :

Hardware is very likely to be fine :

- no issue with a Fedora LiveUSB ;
- memtest tests passed.

# Hardware :

Asus PN40
Intel(R) Celeron(R) J4005 CPU @ 2.00GHz
Intel Corporation UHD Graphics 605 (rev 03)

# System

Tumbleweed 20201123


I have no idea on how to debug it further. My huntch is that it is power saving related with Intel chipset.
Comment 1 jean-christophe baptiste 2020-11-25 19:29:43 UTC
Created attachment 843882 [details]
hwinfo
Comment 2 jean-christophe baptiste 2020-11-25 19:30:07 UTC
Created attachment 843883 [details]
dmesg
Comment 3 Takashi Iwai 2020-11-26 07:30:50 UTC
Likely the same i915 bug as tracked in bug 1179092 and bug 1178474.
Comment 4 jean-christophe baptiste 2020-11-27 08:19:42 UTC
It could be, but the impact on my computer is much more serious.
It becomes totally unusable.

They also don't mention power management, and I can reproduce the crash.

So I am not totally sure that it's related.
Comment 5 jean-christophe baptiste 2020-11-27 08:21:03 UTC
Also, I have settled Caffeine to make sure that the screen never goes off.

And thanks to that the computer has not crashed for the last 2 days.
Comment 6 Takashi Iwai 2020-11-27 08:28:35 UTC
(In reply to jean-christophe baptiste from comment #4)
> It could be, but the impact on my computer is much more serious.
> It becomes totally unusable.

What do you mean "unusable"?  Can you never recover the graphics?
In many cases, Linux console seems still working via switching to VT.  Or, (killing and) starting a new session seems working.

> They also don't mention power management, and I can reproduce the crash.

I guess a few reports that don't appear in Bugzilla but reported on opensuse-factory ML mentioned about the suspend/resume.

> So I am not totally sure that it's related.

No one really knows yet, and a crystal ball doesn't tell you a true story :)
Comment 7 jean-christophe baptiste 2020-11-27 08:31:41 UTC
> What do you mean "unusable"?  Can you never recover the graphics?

Totally unrecoverable. It was what I meant when I wrote "no access to TTY" :

> - unresponsive system (impossible to launch new processes, reboot, no way to switch init3 & init 5, etc.)
Comment 8 Takashi Iwai 2020-12-01 16:29:49 UTC
Could you check with 5.10-rc kernel in OBS Kernel:HEAD repo?
Most users reported that the issue is gone with the 5.10-rc.
Comment 9 Miroslav Beneš 2022-01-21 12:13:57 UTC
No response, closing.
Comment 10 Miroslav Beneš 2022-01-21 12:14:15 UTC
...