Bug 1180870 - ETPS/2 Elantech TrackPoint and ETPS/2 Elantech Touchpad not working
ETPS/2 Elantech TrackPoint and ETPS/2 Elantech Touchpad not working
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Kernel
Leap 15.3
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-01-13 10:49 UTC by Cosmin Tanczel
Modified: 2022-07-21 19:25 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
hwinfo (2.19 MB, text/plain)
2021-01-13 12:01 UTC, Cosmin Tanczel
Details
dmesg (111.08 KB, text/plain)
2021-01-13 12:03 UTC, Cosmin Tanczel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cosmin Tanczel 2021-01-13 10:49:16 UTC
Linux localhost.localdomain 5.3.18-40-default #1 SMP Wed Dec 9 15:00:18 UTC 2020 (6a70196) x86_64 x86_64 x86_64 GNU/Linux

DMESG:
input: ETPS/2 Elantech TrackPoint as /devices/platform/i8042/serio1/input/input3
input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio1/input/input2

xinput --list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech K360                             id=9    [slave  pointer  (2)]
⎜   ↳ Logitech M705                             id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ Integrated Camera: Integrated C           id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=13   [slave  keyboard (3)]
    ↳ Logitech K360                             id=14   [slave  keyboard (3)]

These 2 devices are not working at all.
I tried to remove xf86-input-synaptics and xf86-input-evdev so that the system will be forced to use libinput, but still no luck.

Machine:   Type: Laptop System: LENOVO product: 20TA002GRI v: ThinkPad E14 Gen 2  

Any hints?
Comment 1 Takashi Iwai 2021-01-13 11:47:55 UTC
Please give the output of hwinfo, and also the dmesg from Leap 15.3 kernel.

Also, try to install the recent upstream kernel from OBS Kernel:stable repo, and see whether the touchpad works with it.  If yes, please upload the hwinfo and the dmesg outputs from it as well.
Comment 2 Cosmin Tanczel 2021-01-13 12:01:47 UTC
Created attachment 845071 [details]
hwinfo
Comment 3 Cosmin Tanczel 2021-01-13 12:03:22 UTC
Created attachment 845072 [details]
dmesg
Comment 4 Cosmin Tanczel 2021-01-13 12:04:23 UTC
Attached full hwinfo and dmesg for openSUSE 15.3 Alpha 5.3.18-40-default
Comment 5 Takashi Iwai 2021-01-13 12:35:36 UTC
Thanks.  From the log, it looks like the device gets detected.

Any better result with the 5.10.y kernel in OBS Kernel:stable repo?
Comment 6 Cosmin Tanczel 2021-01-13 13:02:53 UTC
I checked the content of /sys/bus/serio/devices/serio1/protocol' and by default it is ETSMBus.

I did a sudo sh -c 'echo -n "elantech"> /sys/bus/serio/devices/serio1/protocol' and now both the touchpad and the trackpoint are working.

So I guess if I boot with kernel parameter "psmouse.elantech_smbus=0" it should work.

I'll let you know after reboot.

Thanks,
Comment 7 Cosmin Tanczel 2021-01-13 13:10:35 UTC
SOLVED!

Ok, as said above, adding psmouse.elantech_smbus=0 as a kernel boot parameter, solved the problem.

Not sure about 5.10... It's kind of difficult to try it now, but for sure this is a regression since it's working on the same laptop with openSUSE 15.2

Thanks!
Comment 8 Takashi Iwai 2021-01-13 13:28:12 UTC
Thanks for the updates.  OK, so something in elantech driver might be relevant.
The workaround may result in the lack of some features of the modern touchpad, so it's of course better to fix the handling of the new protocol.

I'm going to try to backport the upstream changes to SLE15-SP3 kernel and let you try.  It's a good chance to cover the whole.
Comment 9 Takashi Iwai 2021-01-13 13:40:39 UTC
The test SLE15-SP3 kernel is being built in OBS home:tiwai:bsc1180870 repo.  It takes for a while until the build finishes (for an hour or so).  Please test it later.
Comment 10 Takashi Iwai 2021-01-13 16:52:19 UTC
The test kernel is ready now at
  http://download.opensuse.org/repositories/home:/tiwai:/bsc1180870/standard/
Comment 19 Artyom 2021-11-25 09:17:42 UTC
(In reply to Takashi Iwai from comment #8)
> Thanks for the updates.  OK, so something in elantech driver might be
> relevant.
> The workaround may result in the lack of some features of the modern
> touchpad, so it's of course better to fix the handling of the new protocol.
> 
> I'm going to try to backport the upstream changes to SLE15-SP3 kernel and
> let you try.  It's a good chance to cover the whole.

I too have problem with elantech touchpad, but on another laptop
Could you help me, please?
https://bugzilla.suse.com/show_bug.cgi?id=1193064
Comment 20 Takashi Iwai 2021-11-29 16:12:33 UTC
I close this bug as the potential fix was already merged in SLE15-SP3 kernel branch.
Comment 21 Artyom 2021-11-29 17:27:28 UTC
(In reply to Takashi Iwai from comment #20)
> I close this bug as the potential fix was already merged in SLE15-SP3 kernel
> branch.

Can I check it on my tumbleweed or any other free way?
Comment 22 Takashi Iwai 2021-11-29 19:14:10 UTC
(In reply to Artyom from comment #21)
> (In reply to Takashi Iwai from comment #20)
> > I close this bug as the potential fix was already merged in SLE15-SP3 kernel
> > branch.
> 
> Can I check it on my tumbleweed or any other free way?

TW already contains the fix.  Your problem is likely different from this.
Comment 23 Artyom 2021-11-29 19:17:27 UTC
(In reply to Takashi Iwai from comment #22)
> (In reply to Artyom from comment #21)
> > (In reply to Takashi Iwai from comment #20)
> > > I close this bug as the potential fix was already merged in SLE15-SP3 kernel
> > > branch.
> > 
> > Can I check it on my tumbleweed or any other free way?
> 
> TW already contains the fix.  Your problem is likely different from this.

Okay, what kind of error has been fixed? Invalid elan driver (currently fixed via blacklist) or suspend/restore (currently fixed via disabling touchpad service)? I'll check then
Comment 24 Artyom 2021-11-29 19:19:25 UTC
oh, sorry, just now I noticed that this is not my bug report