Bug 1181836 - (CVE-2021-20176) VUL-0: CVE-2021-20176: ImageMagick: processing crafted file leads to division by zero
(CVE-2021-20176)
VUL-0: CVE-2021-20176: ImageMagick: processing crafted file leads to division...
Status: NEW
: CVE-2021-20242 (view as bug list)
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/277130/
CVSSv3.1:SUSE:CVE-2021-20176:5.3:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-02-05 12:10 UTC by Gianluca Gabrielli
Modified: 2022-09-08 11:20 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gianluca Gabrielli 2021-02-05 12:10:36 UTC
CVE-2021-20176


A flaw was found in ImageMagick in MagickCore/gem.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of math division by zero. This would most likely lead to an impact to application availability, but could potentially cause other problems related to undefined behavior. This flaw affects ImageMagick versions prior to 7.0.10-56.

References: 
 
https://github.com/ImageMagick/ImageMagick/issues/3077

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1916610
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2021-20176
Comment 2 Petr Gajdos 2021-02-09 10:28:03 UTC
There's no testcase.
Comment 3 Petr Gajdos 2021-02-09 12:32:40 UTC
Submitted for 15,12,11/ImageMagick.
Comment 4 Gianluca Gabrielli 2021-02-09 13:02:44 UTC
Hi Petr, can you please also check SUSE:SLE-15-SP2:Update?
Comment 8 Gianluca Gabrielli 2021-02-17 14:57:01 UTC
Two CVEs have been assigned to the same vulnerability (CVE-2021-20176, CVE-2021-20242) as explained here [0].

[0] https://github.com/ImageMagick/ImageMagick/pull/3192#issuecomment-779925131
Comment 9 Swamp Workflow Management 2021-02-19 17:19:32 UTC
SUSE-SU-2021:0528-1: An update that fixes two vulnerabilities is now available.

Category: security (moderate)
Bug References: 1179322,1181836
CVE References: CVE-2020-27767,CVE-2021-20176
JIRA References: 
Sources used:
SUSE Linux Enterprise Workstation Extension 12-SP5 (src):    ImageMagick-6.8.8.1-71.159.2
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    ImageMagick-6.8.8.1-71.159.2
SUSE Linux Enterprise Server 12-SP5 (src):    ImageMagick-6.8.8.1-71.159.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 10 Petr Gajdos 2021-02-23 08:30:11 UTC
*** Bug 1182326 has been marked as a duplicate of this bug. ***
Comment 13 Gianluca Gabrielli 2021-12-02 11:09:16 UTC
Hi Petr, I think we have a missing submission for SUSE:SLE-15-SP2:Update.
Comment 14 Petr Gajdos 2021-12-07 14:42:10 UTC
This is now submitted also for 15sp2/ImageMagick.
Comment 16 Swamp Workflow Management 2021-12-10 20:19:10 UTC
SUSE-SU-2021:3996-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1181836
CVE References: CVE-2021-20176
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for Development Tools 15-SP3 (src):    ImageMagick-7.0.7.34-10.18.1
SUSE Linux Enterprise Module for Development Tools 15-SP2 (src):    ImageMagick-7.0.7.34-10.18.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (src):    ImageMagick-7.0.7.34-10.18.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP2 (src):    ImageMagick-7.0.7.34-10.18.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 17 Swamp Workflow Management 2021-12-10 20:20:20 UTC
openSUSE-SU-2021:3996-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1181836
CVE References: CVE-2021-20176
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    ImageMagick-7.0.7.34-10.18.1
Comment 18 Swamp Workflow Management 2021-12-14 02:17:34 UTC
openSUSE-SU-2021:1583-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1181836
CVE References: CVE-2021-20176
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    ImageMagick-7.0.7.34-lp152.12.18.1