Bug 1182088 - Half of Fn keys do not work after bios update
Half of Fn keys do not work after bios update
Status: RESOLVED DUPLICATE of bug 1175646
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Kernel
Leap 15.2
x86-64 openSUSE Leap 15.2
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-02-11 01:48 UTC by Z B
Modified: 2022-02-18 11:34 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
tiwai: needinfo? (zhonb)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Z B 2021-02-11 01:48:03 UTC
After updating the bios on a Dell Precision 7530, approx half the function keys stopped working.  Brightness control, microphone mute, Fn lock, Wifi toggle, possibly a few others.  

# dmidecode 3.2
Getting SMBIOS data from sysfs.
SMBIOS 3.1.1 present.

Handle 0x0000, DMI type 0, 26 bytes
BIOS Information
        Vendor: Dell Inc.
        Version: 1.14.4
        Release Date: 10/21/2020
        Address: 0xF0000
        Runtime Size: 64 kB
        ROM Size: 32 MB
        Characteristics:
                PCI is supported
                PNP is supported
                BIOS is upgradeable
                BIOS shadowing is allowed
                Boot from CD is supported
                Selectable boot is supported
                EDD is supported
                Japanese floppy for NEC 9800 1.2 MB is supported (int 13h)
                5.25"/1.2 MB floppy services are supported (int 13h)
                3.5"/720 kB floppy services are supported (int 13h)
                3.5"/2.88 MB floppy services are supported (int 13h)
                Print screen service is supported (int 5h)
                8042 keyboard services are supported (int 9h)
                Serial services are supported (int 14h)
                Printer services are supported (int 17h)
                ACPI is supported
                USB legacy is supported
                Smart battery is supported
                BIOS boot specification is supported
                Function key-initiated network boot is supported
                Targeted content distribution is supported
                UEFI is supported
        BIOS Revision: 1.14

Handle 0xF04F, DMI type 13, 22 bytes
BIOS Language Information
        Language Description Format: Long
        Installable Languages: 2
                en|US|iso8859-1
                <BAD INDEX>
        Currently Installed Language: en|US|iso8859-1

Handle 0x0015, DMI type 8, 9 bytes
Port Connector Information
        Internal Reference Designator: JKBTP1 - Keyboard
        Internal Connector Type: None
        External Reference Designator: Not Specified
        External Connector Type: None
        Port Type: Keyboard Port
Comment 1 Takashi Iwai 2021-02-23 16:07:19 UTC
Could you check the recent upstream kernel in OBS Kernel:stable repo whether those keys are still not working, too?  It doesn't matter whether the full graphics work or not, it's only about testing those keys.

For testing the keys, you could login on the Linux console (e.g. VT1), and run evtest there, and see whether any of the input devices get the proper key event from the corresponding Fn keys.  This can be used without the graphics screen, hence it's more valuable information.
Comment 2 Z B 2021-02-23 18:13:15 UTC
On kernel 5.11.0-4.g9ce8b38-default, the following keys still do not produce any output at all with evtest:

Microphone mute, sleep, and brightness control.  The wifi toggle button does show up in evest, but it has no effect in the desktop.  I'll see if I can fix that.
Comment 3 Takashi Iwai 2021-02-24 07:34:28 UTC
Just to be sure, you didn't run the test on X or Wayland, but ran on Linux console (move to VT1 via ctrl-alt-F1), right?  Also, you tested different input devices?  e.g. usually the brightness up/down keys are handled by "Video Bus", and the media keys are handled by "Dell WMI", the sleep key is "Power Button" (or similar).

And that's same even if you press with or without Fn key?
Comment 4 Z B 2021-02-24 14:16:13 UTC
I ran the test both in the desktop environment and under another tty session, terminal only.  Same results in both environments.  I tested other inputs besides keyboard, the reported results apply to every input tested.  All Fn+ keys tested return no results at all on the evtest, with the exception of the wifi toggle, but that doesn't actually turn the wifi card on or off.  If they keys are pressed without the Fn key, they work fine.  Brightness control is the same as the up/down arrows, sleep is the end key, wifi is home, etc.  The non-Fn versions work.
Comment 5 Miroslav Beneš 2022-02-18 11:34:53 UTC
Looks like a duplicate report.

*** This bug has been marked as a duplicate of bug 1175646 ***