Bug 1182912 - (CVE-2021-25122) VUL-0: CVE-2021-25122: tomcat,tomcat6: Apache Tomcat h2c request mix-up
(CVE-2021-25122)
VUL-0: CVE-2021-25122: tomcat,tomcat6: Apache Tomcat h2c request mix-up
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Major
: ---
Assigned To: Abid Mehmood
Security Team bot
https://smash.suse.de/issue/278745/
CVSSv3.1:SUSE:CVE-2021-25122:7.5:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-03-02 10:42 UTC by Robert Frohl
Modified: 2021-07-14 08:14 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Robert Frohl 2021-03-02 10:42:47 UTC
fix, from tomcat 10.x branch:
https://github.com/apache/tomcat/commit/dd757c0a893e2e35f8bc1385d6967221ae8b9b9b
Comment 2 Robert Frohl 2021-03-02 11:34:47 UTC
tracking as affected:

- SUSE:SLE-12-SP4:Update/tomcat
- SUSE:SLE-15:Update/tomcat
- SUSE:SLE-15-SP1:Update/tomcat
- SUSE:SLE-15-SP2:Update/tomcat
Comment 6 Swamp Workflow Management 2021-03-30 19:21:48 UTC
SUSE-SU-2021:0988-1: An update that fixes two vulnerabilities is now available.

Category: security (important)
Bug References: 1182909,1182912
CVE References: CVE-2021-25122,CVE-2021-25329
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    tomcat-9.0.36-3.64.1
SUSE OpenStack Cloud 9 (src):    tomcat-9.0.36-3.64.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    tomcat-9.0.36-3.64.1
SUSE Linux Enterprise Server 12-SP5 (src):    tomcat-9.0.36-3.64.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    tomcat-9.0.36-3.64.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2021-03-30 19:23:07 UTC
SUSE-SU-2021:0989-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1180947,1182909,1182912
CVE References: CVE-2021-24122,CVE-2021-25122,CVE-2021-25329
JIRA References: 
Sources used:
SUSE Linux Enterprise Server for SAP 15 (src):    tomcat-9.0.36-3.79.1
SUSE Linux Enterprise Server 15-LTSS (src):    tomcat-9.0.36-3.79.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    tomcat-9.0.36-3.79.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    tomcat-9.0.36-3.79.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 8 Swamp Workflow Management 2021-04-01 19:15:58 UTC
SUSE-SU-2021:1008-1: An update that fixes two vulnerabilities is now available.

Category: security (important)
Bug References: 1182909,1182912
CVE References: CVE-2021-25122,CVE-2021-25329
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for Web Scripting 15-SP3 (src):    tomcat-9.0.36-3.24.1
SUSE Linux Enterprise Module for Web Scripting 15-SP2 (src):    tomcat-9.0.36-3.24.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 9 Swamp Workflow Management 2021-04-01 19:19:17 UTC
SUSE-SU-2021:1009-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1180947,1182909,1182912
CVE References: CVE-2021-24122,CVE-2021-25122,CVE-2021-25329
JIRA References: 
Sources used:
SUSE Manager Server 4.0 (src):    tomcat-9.0.36-4.58.1
SUSE Manager Retail Branch Server 4.0 (src):    tomcat-9.0.36-4.58.1
SUSE Manager Proxy 4.0 (src):    tomcat-9.0.36-4.58.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    tomcat-9.0.36-4.58.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    tomcat-9.0.36-4.58.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    tomcat-9.0.36-4.58.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    tomcat-9.0.36-4.58.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    tomcat-9.0.36-4.58.1
SUSE Enterprise Storage 6 (src):    tomcat-9.0.36-4.58.1
SUSE CaaS Platform 4.0 (src):    tomcat-9.0.36-4.58.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 10 Swamp Workflow Management 2021-04-02 13:16:33 UTC
openSUSE-SU-2021:0496-1: An update that fixes two vulnerabilities is now available.

Category: security (important)
Bug References: 1182909,1182912
CVE References: CVE-2021-25122,CVE-2021-25329
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    tomcat-9.0.36-lp152.2.22.1
Comment 12 Abid Mehmood 2021-04-23 06:36:16 UTC
All MRs have been accepted for this. 12-SP2 and 12-SP3 should not be affected by this because this CVE is about the HTTP/2 which was only supported from 8.5.x onwards(SLE12-SP4 and later).

Nothing further to be done from our side.
Comment 13 Robert Frohl 2021-07-14 08:14:02 UTC
(In reply to Abid Mehmood from comment #12)
> All MRs have been accepted for this. 12-SP2 and 12-SP3 should not be
> affected by this because this CVE is about the HTTP/2 which was only
> supported from 8.5.x onwards(SLE12-SP4 and later).
> 
> Nothing further to be done from our side.

please do not set the needinfo. the expected workflow is to re-assign to security-team@suse.de. Someone from the team will double check and close the bug.
Comment 14 Robert Frohl 2021-07-14 08:14:24 UTC
all released, closing