Bug 1183056 - Leap 15.3 kernel cannot load on a system with 32-bit UEFI
Leap 15.3 kernel cannot load on a system with 32-bit UEFI
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Kernel
Leap 15.3
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-03-04 19:53 UTC by Neil Rickert
Modified: 2021-06-16 01:51 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Neil Rickert 2021-03-04 19:53:24 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0
Build Identifier: 

I see this as related to bug 1172292

It seems impossible to load a Leap 15.3 kernel with 32-bit UEFI firmware.

I tried several ways, but could not boot the installer.

I eventually installed to a KVM virtual machine using legacy booting.  I then took the installed memory image, and converted that to using 32-bit UEFI with ovmf-ia32-{code,vars}.bin firmware.  And that still would not boot.

I now have it successfully booting with kernel-default-5.3.18-lp152.63.1 which is a kernel from Leap 15.2.  But it will not boot with the Leap 15.3 kernel.

I'll grant that this is not an officially supported setup.

Reproducible: Always
Comment 1 Takashi Iwai 2021-03-08 16:16:43 UTC
I don't think this is ever fixed for Leap 15.3.  Gary?
Comment 2 Gary Ching-Pang Lin 2021-03-09 09:30:26 UTC
Although it's not supported officially, I still wonder why grub2 failed to load the kernel.

Did the grub2 menu show? Was there any error message when loading Leap 15.3 kernel?

It also could be interested to see the firmware log. Just add the following line to qemu command:

-debugcon file:debug.log -global isa-debugcon.iobase=0x402

then ovmf will dump log into debug.log.
Comment 3 Neil Rickert 2021-03-09 10:46:35 UTC
>Did the grub2 menu show? Was there any error message when loading Leap 15.3 kernel?

Yes, the grub2 menu shows just fine.

I then see:

Loading Linux 5.3.18-47-default ...
Loading initial ramdisk ...

And, after that, nothing.  It just stays there showing those lines.

I did install both kernel 5.3.18-lp152.66-default from Leap 15.2, and kernel -5.11.2-1-default from Tumbleweed.  And those boot as expected.  So I think it is a difference in the way that kernels are built for the Jump project (or for SLE) compared to the way that they are built for openSUSE.

Sorry, but I don't know how to add to the "qemu" command.  I'm using KVM and "virt-manager", so I am not directly running the "qemu" command.

For completeness, I should add that I am booting with "grub2-i386-efi-2.04-lp152.7.12.1.noarch.rpm" (from Leap 15.2).  Anything newer will not boot 5.3 kernels (see bug 1177009 ).  Newer grub2 versions will boot the Tumbleweed kernel, but not the Leap 15.2 kernels.

(Only marginally related -- bug 1183063 seems to also be because of the difference between how SLE/Jump kernels are built and how openSUSE kernels are built).
Comment 4 Gary Ching-Pang Lin 2021-03-10 03:19:03 UTC
Hmmmm, that sounds like an issue for the mixed mode support in kernel.

The kernel patch(*) mentioned by Michael in bsc#1177009 is already merged into Leap 15.3 kernel. Maybe there is some other mixed mode patch still missing.

Joey,

Any suggestion?

(*) https://github.com/torvalds/linux/commit/4911ee401b7ceff8f38e0ac597cbf503d71e690c
Comment 5 Joey Lee 2021-03-10 04:25:20 UTC
(In reply to Gary Ching-Pang Lin from comment #4)
> Hmmmm, that sounds like an issue for the mixed mode support in kernel.
> 
> The kernel patch(*) mentioned by Michael in bsc#1177009 is already merged
> into Leap 15.3 kernel. Maybe there is some other mixed mode patch still
> missing.
> 
> Joey,
> 
> Any suggestion?
> 
> (*)
> https://github.com/torvalds/linux/commit/
> 4911ee401b7ceff8f38e0ac597cbf503d71e690c

Because SLE doesn't support mixed mode, so I didn't backport mixed mode patches to SLE kernel. 

If kernel-default-5.3.18-lp152.63.1 from Leap 15.2 can boot success, then the difference is between Leap 15.3/SLE kernel with kernel-default-5.3.18-lp152.63.1.
Comment 6 Jens K. 2021-06-10 16:53:35 UTC
Isn't this a duplicate of https://bugzilla.opensuse.org/show_bug.cgi?id=1172292?
Comment 7 Neil Rickert 2021-06-10 22:39:50 UTC
>Isn't this a duplicate of https://bugzilla.opensuse.org/show_bug.cgi?id=1172292?

No, it isn't.  Bug 1172292 is about the general problem of support for these systems.  However, if you can manage to get it booted, then it does work.

This bug is about a more specific problem, that the 15.3 kernel won't load, even if you get around the other difficulties.

I actually have Leap 15.3 working in a VM with 32-bit EFI.  However, I have to use either the Tumbleweed kernel or the Leap 15.2 kernel.  I cannot get the 15.3 kernel to load.
Comment 8 Neil Rickert 2021-06-16 01:51:33 UTC
This seems to have been fixed with the latest kernel update (to 5.3.18-59.5.2).

That won't help with installing, because you are stuck with the kernel on the install media.  But if you managed to install, it will now boot the latest kernel.  It seems that the needed kernel support has now been provided.