Bug 1183500 - [BID 91.1] click toggle update nvram off killed installer GUI
[BID 91.1] click toggle update nvram off killed installer GUI
Status: RESOLVED DUPLICATE of bug 1179482
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Installation
Leap 15.3
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-03-15 03:28 UTC by Felix Miata
Modified: 2021-03-22 10:40 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
y2logs.tgz from the aborted 15.3 Beta upgrade installation attempt (1.69 MB, application/octet-stream)
2021-03-15 03:28 UTC, Felix Miata
Details
y2logs.tgz from boot subsequent to the successful offline offline upgrade subsequent to the summary's failed 15.3 Beta upgrade installation attempt (3.27 MB, application/octet-stream)
2021-03-15 03:32 UTC, Felix Miata
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Miata 2021-03-15 03:28:15 UTC
Created attachment 847187 [details]
y2logs.tgz from the aborted 15.3 Beta upgrade installation attempt

Original Summary:
[BID 91.1] click toggle update nvram off killed installer GUI

This was from a NET USB stick upgrade to an existing 15.3 Alpha on unbootable NVME partition 2 on a multi- multiboot PC configured to always boot via custom.cfg via TW's Grub-efi. Included in the target installation is/was this purposely included, and normal for this installation (timestamp 26 February), line item in /etc/fstab:
	
	#LABEL=TVGP01ESP  /boot/efi  vfat  noatime,codepage=437  0 0

NVME0N1P2 target's /etc/default/grub included this (normal, intended) entry:

	GRUB_DISABLE_OS_PROBER="true"

I didn't want NVRAM touched, so I tried to disable update NVRAM in 15.3 installation summary. That killed the installation process by leaving a mouse pointer on an otherwise black screen that stayed so even after Ctrl-Alt-F2 and Alt-F7. On reboot, after save_y2logs, and restart installation in same manner, I ignored the problem of expected NVRAM corruption to enable proceeding to upgrade 15.3. As consequently expected, TW's boot via custom.cfg had been usurped by 15.3's Grub, which I didn't even want installed, and have no use for.

Initial attempts to correct somehow created extreme BIOS corruption, and no attempt by the Asus A88X motherboard to POST. I had to clear BIOS before it would POST again, which left only two media entries for the SATA device, one of which brought up TW's custom.cfg, from which I recreated a proper TW entry:
# efibootmgr -b 0 -c -L "opensusetw" -l '\EFI\opensusetw\grubx64.efi'
Comment 1 Felix Miata 2021-03-15 03:32:39 UTC
Created attachment 847188 [details]
y2logs.tgz from boot subsequent to the successful offline offline upgrade subsequent to the summary's failed 15.3 Beta upgrade installation attempt
Comment 2 Felix Miata 2021-03-15 03:43:05 UTC
I suspect the click was just the trigger, but the cause was absence of the ESP partition being mounted.
Comment 3 Stefan Hundhammer 2021-03-15 08:55:19 UTC
The exact error (from the proposal dialog):


2021-03-14 15:56:49 <1> asa88(4137) [Ruby]
  installation/proposal_runner.rb(block in input_loop):210
  Proposal - UserInput: 'disable_update_nvram'

2021-03-14 15:56:49 <3> asa88(4137) [Ruby]
  yast/wfm.rb(handle_exception):272 Client
  /mounts/mp_0001/usr/share/YaST2/clients/inst_proposal.rb failed
  with 'Unknown user request disable_update_nvram.
  Broken proposal client?' (RuntimeError).
Comment 4 Stefan Hundhammer 2021-03-15 08:56:21 UTC
Felix, BTW your Bugzilla real name still says

  "Felix Miata (offline until ???)".

Is this still true / relevant?
Comment 5 Stefan Hundhammer 2021-03-15 09:07:42 UTC
AFAICS the kernel detected this as an EFI boot system
(directory /sys/firmware/efi/efivars exists):

2021-03-14 15:47:17 <1> asa88(4137) [libstorage]
  SystemCmd.cc(SystemCmd):67 constructor
  SystemCmd("/usr/bin/test -d /sys/firmware/efi/efivars'")

2021-03-14 15:47:17 <1> asa88(4137) [libstorage]
  SystemCmd.cc(doExecute):431 system() Returns:0

2021-03-14 15:47:17 <1> asa88(4137) [libstorage]
  Arch.cc(probe):127 ... efiboot: true


...and the corresponding "efivars" type filesystem was
successfully mounted:

2021-03-14 15:52:55 <1> asa88(4137) [Ruby]
  modules/RootPart.rb(MountPartition):494
  mount -t efivarfs efivarfs /mnt/sys/firmware/efi/efivars
Comment 6 Stefan Hundhammer 2021-03-15 09:29:48 UTC
This is this code adding the hyperlink to the proposal:

https://github.com/yast/yast-bootloader/blob/master/src/lib/bootloader/grub2base.rb#L425

which at that time did not have the corresponding functional part that makes use of it:

https://github.com/yast/yast-bootloader/blob/master/src/lib/bootloader/proposal_client.rb#L83

which was fixed with this pull request:

https://github.com/yast/yast-bootloader/pull/634/files

which makes this a duplicate of bug #1179482.

*** This bug has been marked as a duplicate of bug 1179482 ***
Comment 7 Stefan Hundhammer 2021-03-15 09:54:50 UTC
See also bug #1183516
Comment 8 Felix Miata 2021-03-15 17:06:35 UTC
(In reply to Stefan Hundhammer from comment #4)
> Felix, BTW your Bugzilla real name still says
 
>   "Felix Miata (offline until ???)".

> Is this still true / relevant?

No, but fixing it is blocked by bug 1172619 reported 9 months ago.