Bug 1183838 - Full resolution of the monitor no longer available in 5.11 kernels with i9-9900K and Intel display driver
Full resolution of the monitor no longer available in 5.11 kernels with i9-99...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 openSUSE Tumbleweed
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-03-21 16:47 UTC by Marian Ciobanu
Modified: 2021-04-19 14:05 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
dmesg and hwinfo outputs, as requested (1.10 MB, application/gzip)
2021-03-27 18:24 UTC, Marian Ciobanu
Details
More dmesg logs (202.06 KB, application/gzip)
2021-04-12 05:27 UTC, Marian Ciobanu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Ciobanu 2021-03-21 16:47:26 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:85.0) Gecko/20100101 Firefox/85.0
Build Identifier: 

I use TumbleWeed as my main OS, and also have a separate TumbleWeed partition to test the updates first. So my main system is still on 5.10.16-1-default, while the test system is on 5.11.6-1, after trying 5.11.2-1.

There is no graphic card besides the one embedded in the CPU, with the built-in drivers, which so far has been good enough for me.

On the test system, my 3440x1440 monitor is now seen as 2560x1080 (or sometimes 1024x768 or 1600x900), in the sense that you cannot set a higher resolution.

The reason I'm saying this has to do with the kernel rather than with X, is what happens at boot: I use "nosplash", to see the boot messages. On the old/main system, there is some text with a large font for less than 1 second, and then it enters a text mode with around 90 lines, and then the X graphics mode of 3440x1440. On the updated system, the first boot goes the same in the text modes, but at reboots the text mode is really some 77 visible lines (or sometimes fewer), but it still thinks there are 90, so what happens is the bottom lines and right columns aren't shown. (Well, the bottom visible line is truncated, only the top of the characters are seen.) I think these text modes are configured before X had a chance to do anything, so it looks more like some "garbage" left in some memory from a previous run that decides the resolution.

It didn't occur to me to try the older kernel (5.10.16-1) when I saw that things no longer worked as expected with 5.11.6-1, which would have made it clearer if the issue is with the kernel or not. Now I'm not sure how to go about installing an older kernel, as I don't see it in YaST.

However, there is a workaround of sorts: Disconnect the DP cable and reconnect it. Then I can set the resolution to 3440x1440@60. This seems to make the text mode (e.g. Ctrl+Alt+F1) unavailable, though.


Reproducible: Always

Steps to Reproduce:
1. Start TumbleWeed with "nosplash" on a 3440x1440 monitor (Samsung CF791) and TW as of 2021.03.21
2. Reboot, once it started

Actual Results:  
1. In text mode during boot, bottom lines are not visible.
2. In graphics mode the resolution is something smaller (usually 2560x1080) and cannot be made 3440x1440

Expected Results:  
1. All text lines should be visible during boot (except maybe the first boot).
2. It should be possible to set the resolution to 3440x1440@60
3. The resolution should be kept between reboots.
Comment 1 Takashi Iwai 2021-03-26 09:29:48 UTC
Could you give the hardware details (e.g. hwinfo output)?

Then boot with drm.debug=0x1e boot option and get the kernel messages (dmesg output).  Gather this from both good (5.10.x) and bad (5.11.x) kernels to compare.

FWIW, some old TW kernel packages are found in TW history repo,
  http://download.opensuse.org/history/
Comment 2 Marian Ciobanu 2021-03-27 18:24:53 UTC
Created attachment 847732 [details]
dmesg and hwinfo outputs, as requested

Sure, attaching these files
Comment 3 Marian Ciobanu 2021-03-27 18:28:44 UTC
Also, I noticed that I don't actually need to unplug the monitor in order to be able to set the native resolution. It's enough to turn the monitor off and back on, and then 3440x1440 is shown in the list of available resolutions and I can set it and use it.
Comment 4 Takashi Iwai 2021-04-07 11:24:08 UTC
Unfortunately the early kernel log of the 5.11.x boot was cut down, so it can't be compared with the old boot.  Could you try to get the output at the earlier point?
Comment 5 Marian Ciobanu 2021-04-12 05:27:20 UTC
Created attachment 848226 [details]
More dmesg logs

The issue seems fixed now, with 5.11.11-1. I think it would be a good idea to understand what actually happened, but I don't know if there is the capacity to do this. If not, I guess it should be closed.

Added new logs, for both the version that wasn't working and the latest one, which works.
Comment 6 Takashi Iwai 2021-04-19 14:05:13 UTC
Thanks for the update.  Then let's close now.