Bug 1184739 - (CVE-2021-3497) VUL-0: CVE-2021-3497: gstreamer-plugins-good: Use-after-free in matroska demuxing
(CVE-2021-3497)
VUL-0: CVE-2021-3497: gstreamer-plugins-good: Use-after-free in matroska demu...
Status: IN_PROGRESS
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/281740/
CVSSv3.1:SUSE:CVE-2021-3497:5.3:(AV:N...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-04-14 14:14 UTC by Alexander Bergmann
Modified: 2022-10-20 02:06 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Bergmann 2021-04-14 14:14:11 UTC
rh#1945339

GStreamer before 1.18.4 might access already-freed memory in error code paths when demuxing certain malformed Matroska files.

References:

https://gstreamer.freedesktop.org/security/sa-2021-0002.html
https://gstreamer.freedesktop.org/releases/1.18/#1.18.4

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1945339
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2021-3497
Comment 2 Swamp Workflow Management 2021-09-02 13:20:27 UTC
# maintenance_jira_update_notice
openSUSE-SU-2021:2915-1: An update that fixes two vulnerabilities is now available.

Category: security (moderate)
Bug References: 1184735,1184739
CVE References: CVE-2021-3497,CVE-2021-3498
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    gstreamer-plugins-good-1.16.3-3.6.1
Comment 3 Swamp Workflow Management 2021-09-02 13:27:44 UTC
# maintenance_jira_update_notice
SUSE-SU-2021:2915-1: An update that fixes two vulnerabilities is now available.

Category: security (moderate)
Bug References: 1184735,1184739
CVE References: CVE-2021-3497,CVE-2021-3498
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    gstreamer-plugins-good-1.16.3-3.6.1
SUSE Linux Enterprise Module for Basesystem 15-SP2 (src):    gstreamer-plugins-good-1.16.3-3.6.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 4 Swamp Workflow Management 2021-09-02 13:28:51 UTC
# maintenance_jira_update_notice
SUSE-SU-2021:2916-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1184739
CVE References: CVE-2021-3497
JIRA References: 
Sources used:
SUSE Linux Enterprise Server 12-SP5 (src):    gstreamer-plugins-good-1.8.3-16.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 5 Swamp Workflow Management 2021-09-05 19:16:05 UTC
# maintenance_jira_update_notice
openSUSE-SU-2021:1230-1: An update that fixes two vulnerabilities is now available.

Category: security (moderate)
Bug References: 1184735,1184739
CVE References: CVE-2021-3497,CVE-2021-3498
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    gstreamer-plugins-good-1.16.3-lp152.2.6.1
Comment 7 Jia Zhaocong 2022-10-20 02:06:33 UTC
Cleaning up GNOME CVE backlog. The fix has been submitted and accepted. Assign back to security team.