Bug 1184767 - Several firmwares missing when installing MicroOS
Several firmwares missing when installing MicroOS
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-04-15 02:14 UTC by Dario Faggioli
Modified: 2022-03-16 08:26 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dario Faggioli 2021-04-15 02:14:29 UTC
After finishing installing MicroOS on my laptop, I have this in dmesg:

dario@Palanthas-eth:~> dmesg |grep firmware
[    0.073533] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    2.964996] i915 0000:00:02.0: Direct firmware load for i915/kbl_dmc_ver1_04.bin failed with error -2
[    2.964998] i915 0000:00:02.0: [drm] Failed to load DMC firmware i915/kbl_dmc_ver1_04.bin. Disabling runtime power management.
[    2.964999] i915 0000:00:02.0: [drm] DMC firmware homepage: https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/i915
[   66.877346] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[   66.928640] r8152 4-1.4:1.0: Direct firmware load for rtl_nic/rtl8153a-3.fw failed with error -2
[   66.928646] r8152 4-1.4:1.0: unable to load firmware patch rtl_nic/rtl8153a-3.fw (-2)
[   67.153449] bluetooth hci0: Direct firmware load for qca/rampatch_usb_00000302.bin failed with error -2
[   67.906512] ath10k_pci 0000:3a:00.0: Failed to find firmware-N.bin (N between 2 and 6) from ath10k/QCA6174/hw3.0: -2
[   67.906552] ath10k_pci 0000:3a:00.0: could not fetch firmware files (-2)

And WiFi and Bluetooth are not working.

All the firmware related messages go away if I install the following packages:
- kernel-firmware-iwlwifi
- kernel-firmware-realtek
- kernel-firmware-i915
- kernel-firmware-bluetooth
- kernel-firmware-ath10k

The message about regulatory.db goes away if I install the crda package

This is related to bug 1184403 with the only difference that there the missing firmware is in kernel-firmware-iwlwifi.

Also, it looks like this shouldn't happen, according to bug 1174521, as it's marked as fixed, but the problem seems to still be there
Comment 1 Dario Faggioli 2021-04-15 02:17:34 UTC
My current theory is that this is due to the fact that, despite the kernel-firmware package is present in the install media, it currently comes with no "Supplements:", so it's not installed.

And I have indeed verified that it is actually not present on a fresh install.

My current plan is to explicitly add to the media a few of the kernel-firmware-foo packages, which do have each one their own set of "Supplements:".
Comment 2 Miroslav Beneš 2022-03-11 12:24:30 UTC
Dario, is this still an issue or was it resolved meanwhile?
Comment 3 Dario Faggioli 2022-03-16 08:26:11 UTC
(In reply to Miroslav Beneš from comment #2)
> Dario, is this still an issue or was it resolved meanwhile?
>
We have kernel-firmware-all now, at least in the DVD, and as far as both my knowledge and my testing goes, the issue is fixed by that, and we can close this bug.