Bug 1185352 - exfat: ERROR: invalid VBR checksum 0xc746d7e6 (expected 0x8122115) on zram test
exfat: ERROR: invalid VBR checksum 0xc746d7e6 (expected 0x8122115) on zram test
Status: RESOLVED UPSTREAM
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Goldwyn Rodrigues
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-04-27 12:46 UTC by Petr Vorel
Modified: 2021-05-04 16:34 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
dmesg from failing machine (https://openqa.opensuse.org/tests/1713946/file/serial0.txt) (336.01 KB, text/plain)
2021-04-27 12:46 UTC, Petr Vorel
Details
test output (https://openqa.opensuse.org/tests/1713946/file/serial_terminal.txt) (38.13 KB, text/plain)
2021-04-27 12:47 UTC, Petr Vorel
Details
strace of failing command (ROD mount /dev/zram$i zram$i) (20.39 KB, text/plain)
2021-05-04 11:25 UTC, Petr Vorel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Vorel 2021-04-27 12:46:40 UTC
Created attachment 848788 [details]
dmesg from failing machine (https://openqa.opensuse.org/tests/1713946/file/serial0.txt)

LTP zram01 test triggers failure on exfat [1]:

FUSE exfat 1.3.0
ERROR: invalid VBR checksum 0xc746d7e6 (expected 0x8122115).
zram01 6 TBROK: mount /dev/zram6 zram6 failed

I don't see anything suspicious in dmesg, not in test output.
I can provide strace (or whatever you need).
Test started to fail since it's introduction in build 20210419.

[1] https://openqa.opensuse.org/tests/1713946#step/zram01/8
[2] https://openqa.opensuse.org/tests/1707519#step/zram01/6
Comment 2 Takashi Iwai 2021-04-28 08:13:38 UTC
So this is about fuse-exfat, not the exfat module in the kernel, right?

Adding Goldwyn to Cc, as this is a filesystem matter.
Comment 3 Petr Vorel 2021-04-28 08:47:57 UTC
(In reply to Takashi Iwai from comment #2)
> So this is about fuse-exfat, not the exfat module in the kernel, right?
Yes (mount.exfat).

> Adding Goldwyn to Cc, as this is a filesystem matter.

Thanks!
Comment 4 Petr Vorel 2021-05-04 11:25:48 UTC
Created attachment 849017 [details]
strace of failing command (ROD mount /dev/zram$i zram$i)
Comment 5 Petr Vorel 2021-05-04 11:30:31 UTC
Unlike of #1185546 this bug is reproducible, thus I added strace.

Also adding a quicker reproducer example than using LTP:

# modprobe -v zram
insmod /lib/modules/5.11.12-1-default/kernel/drivers/block/zram/zram.ko.xz 

# zramctl --size 25M /dev/zram0 

# mkfs.exfat /dev/zram0 
exfatprogs version : 1.1.0
Creating exFAT filesystem(/dev/zram0, cluster size=4096)

Writing volume boot record: done
Writing backup volume boot record: done
Fat table creation: done
Allocation bitmap creation: done
Upcase table creation: done
Writing root directory entry: done
Synchronizing...

exFAT format complete!
# mount /dev/zram0 /mnt/
FUSE exfat 1.3.0
ERROR: invalid VBR checksum 0xc74161e6 (expected 0x71fe3afd).
Comment 6 Petr Vorel 2021-05-04 11:39:13 UTC
NOTE: I was not able to reproduce it on my laptop with 5.12.1-1.g9bb8944-default using FUSE exfat 1.3.0, maybe it has been fixed in 5.12 (but haven't find anything obvious in kernel git).
Comment 7 Goldwyn Rodrigues 2021-05-04 16:34:06 UTC
I am unable to reproduce this on older kernel either. So I am not sure what was wrong here. There were a couple of changes in zram writebacks which could be the reason.

Closing as UPSTREAM.