Bug 1185833 - (CVE-2020-18032) VUL-0: CVE-2020-18032: graphviz-addons,graphviz,graphviz-plugins: Buffer Overflow in Graphviz Graph Visualization Tools from commit ID f8b9e035 and earlier allows remote attackers to execute arbitrary code or cause a denial of service
(CVE-2020-18032)
VUL-0: CVE-2020-18032: graphviz-addons,graphviz,graphviz-plugins: Buffer Over...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Critical
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/283198/
CVSSv3.1:SUSE:CVE-2020-18032:9.8:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-05-10 10:03 UTC by Gianluca Gabrielli
Modified: 2022-06-10 12:53 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gianluca Gabrielli 2021-05-10 10:03:57 UTC
CVE-2020-18032

Buffer Overflow in Graphviz Graph Visualization Tools from commit ID f8b9e035
and earlier allows remote attackers to execute arbitrary code or cause a denial
of service (application crash) by loading a crafted file into the
"lib/common/shapes.c" component.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-18032
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-18032
https://gitlab.com/graphviz/graphviz/-/issues/1700
Comment 1 Gianluca Gabrielli 2021-05-10 10:06:34 UTC
Affected packages:

SUSE:SLE-12-SP2:Update/graphviz         2.28.0
SUSE:SLE-15:Update/graphviz             2.40.1
SUSE:SLE-15:Update/graphviz-addons      2.40.1
SUSE:SLE-12-SP2:Update/graphviz-plugins 2.28.0

Upstream patch [0].


[0] https://gitlab.com/graphviz/graphviz/-/commit/784411ca3655c80da0f6025ab20634b2a6ff696b.patch
Comment 3 Swamp Workflow Management 2021-05-19 16:31:39 UTC
SUSE-SU-2021:1651-1: An update that fixes one vulnerability is now available.

Category: security (critical)
Bug References: 1185833
CVE References: CVE-2020-18032
JIRA References: 
Sources used:
SUSE Manager Server 4.0 (src):    graphviz-2.40.1-6.9.1, graphviz-addons-2.40.1-6.9.1
SUSE Manager Retail Branch Server 4.0 (src):    graphviz-2.40.1-6.9.1, graphviz-addons-2.40.1-6.9.1
SUSE Manager Proxy 4.0 (src):    graphviz-2.40.1-6.9.1, graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    graphviz-2.40.1-6.9.1, graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise Server for SAP 15 (src):    graphviz-2.40.1-6.9.1, graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    graphviz-2.40.1-6.9.1, graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    graphviz-2.40.1-6.9.1, graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise Server 15-LTSS (src):    graphviz-2.40.1-6.9.1, graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise Module for Server Applications 15-SP3 (src):    graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise Module for Server Applications 15-SP2 (src):    graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (src):    graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP2 (src):    graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise Module for Development Tools 15-SP3 (src):    graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise Module for Development Tools 15-SP2 (src):    graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    graphviz-2.40.1-6.9.1
SUSE Linux Enterprise Module for Basesystem 15-SP2 (src):    graphviz-2.40.1-6.9.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    graphviz-2.40.1-6.9.1, graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    graphviz-2.40.1-6.9.1, graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    graphviz-2.40.1-6.9.1, graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    graphviz-2.40.1-6.9.1, graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise High Availability 15-SP3 (src):    graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise High Availability 15-SP2 (src):    graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise High Availability 15-SP1 (src):    graphviz-addons-2.40.1-6.9.1
SUSE Linux Enterprise High Availability 15 (src):    graphviz-addons-2.40.1-6.9.1
SUSE Enterprise Storage 6 (src):    graphviz-2.40.1-6.9.1, graphviz-addons-2.40.1-6.9.1
SUSE CaaS Platform 4.0 (src):    graphviz-2.40.1-6.9.1, graphviz-addons-2.40.1-6.9.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 4 Swamp Workflow Management 2021-05-19 16:37:00 UTC
SUSE-SU-2021:1646-1: An update that fixes one vulnerability is now available.

Category: security (critical)
Bug References: 1185833
CVE References: CVE-2020-18032
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    graphviz-2.28.0-29.6.1, graphviz-plugins-2.28.0-29.6.1
SUSE OpenStack Cloud Crowbar 8 (src):    graphviz-2.28.0-29.6.1, graphviz-plugins-2.28.0-29.6.1
SUSE OpenStack Cloud 9 (src):    graphviz-2.28.0-29.6.1, graphviz-plugins-2.28.0-29.6.1
SUSE OpenStack Cloud 8 (src):    graphviz-2.28.0-29.6.1, graphviz-plugins-2.28.0-29.6.1
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    graphviz-2.28.0-29.6.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    graphviz-2.28.0-29.6.1, graphviz-plugins-2.28.0-29.6.1
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    graphviz-2.28.0-29.6.1, graphviz-plugins-2.28.0-29.6.1
SUSE Linux Enterprise Server 12-SP5 (src):    graphviz-2.28.0-29.6.1, graphviz-plugins-2.28.0-29.6.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    graphviz-2.28.0-29.6.1, graphviz-plugins-2.28.0-29.6.1
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    graphviz-2.28.0-29.6.1, graphviz-plugins-2.28.0-29.6.1
SUSE Linux Enterprise Server 12-SP3-BCL (src):    graphviz-2.28.0-29.6.1, graphviz-plugins-2.28.0-29.6.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    graphviz-2.28.0-29.6.1, graphviz-plugins-2.28.0-29.6.1
SUSE Linux Enterprise High Availability 12-SP5 (src):    graphviz-plugins-2.28.0-29.6.1
SUSE Linux Enterprise High Availability 12-SP4 (src):    graphviz-plugins-2.28.0-29.6.1
SUSE Linux Enterprise High Availability 12-SP3 (src):    graphviz-plugins-2.28.0-29.6.1
HPE Helion Openstack 8 (src):    graphviz-2.28.0-29.6.1, graphviz-plugins-2.28.0-29.6.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 5 Swamp Workflow Management 2021-05-22 10:20:55 UTC
openSUSE-SU-2021:0757-1: An update that fixes one vulnerability is now available.

Category: security (critical)
Bug References: 1185833
CVE References: CVE-2020-18032
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    graphviz-2.40.1-lp152.7.10.1, graphviz-addons-2.40.1-lp152.7.10.1
Comment 6 Swamp Workflow Management 2021-07-10 23:09:01 UTC
openSUSE-SU-2021:1651-1: An update that fixes one vulnerability is now available.

Category: security (critical)
Bug References: 1185833
CVE References: CVE-2020-18032
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    graphviz-2.40.1-6.9.1, graphviz-addons-2.40.1-6.9.1
Comment 7 Carlos López 2022-06-10 12:53:03 UTC
Done, closing.