Bug 1186491 - (CVE-2020-24020) VUL-1: CVE-2020-24020: ffmpeg: Buffer Overflow vulnerability in dnn_execute_layer_pad in libavfilter/dnn/dnn_backend_native_layer_pad.c
(CVE-2020-24020)
VUL-1: CVE-2020-24020: ffmpeg: Buffer Overflow vulnerability in dnn_execute_l...
Status: RESOLVED INVALID
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Minor
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/300828/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-05-27 09:51 UTC by Robert Frohl
Modified: 2021-05-28 09:10 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Frohl 2021-05-27 09:51:51 UTC
CVE-2020-24020

Buffer Overflow vulnerability in FFMpeg 4.2.3 in dnn_execute_layer_pad in
libavfilter/dnn/dnn_backend_native_layer_pad.c due to a call to memcpy without
length checks, which could let a remote malicious user execute arbitrary code.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-24020
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-24020
http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=584f396132aa19d21bb1e38ad9a5d428869290cb
https://trac.ffmpeg.org/ticket/8718
Comment 1 Robert Frohl 2021-05-27 11:38:16 UTC
the version we ship does not contain the code
Comment 2 Robert Frohl 2021-05-28 09:10:54 UTC
closing